OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Numbering Style: None in Stylist ignored

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
valen1260
General User
General User


Joined: 22 Jul 2004
Posts: 8
Location: Kentucky

PostPosted: Wed Nov 02, 2005 12:03 pm    Post subject: Numbering Style: None in Stylist ignored Reply with quote

I use OOo to document procedures in a very loose outline. I was using v1.1.3 without problem, but since upgrading to 2.0, I'm having a great deal of trouble with my numbering.

My document is set up so that the main steps are in a paragraph style indicated by Roman Numerals (the default "Numbering 4"). In addition, I have bullet styles for "command prompts" ($ and #), and there is also text without any numbering (Numbering Style set to none).

The "next style" for the "steps" style is a non-numbered style, but the Roman Numeral carries over. The styles are not based on each other. Instead of automatically switching styles and numbering, each time I expect the switch, I have to use the toolbar. This was not the case in OOo 1.1.3.

I tried this on a fresh ODT file, to rule out that it was a fault of converting an SXW file, and had the same trouble. I don't know if there is a setting I'm missing or if this needs to be reported as a bug.

I see two problems here:
1) Numbering Style: None is being ignored. In the breakdown of the style in its Organizer tab, there is no mention of Numbering Style: None, so I interpret this to mean that no numbering is added, but that any carried over numbering is not cleared. I would expect the latter, in the same way "normal" turns off "bold".

2) Even resetting the paragraph style to Default does not clear the number/bullet.

Does anyone have any suggestions?
Back to top
View user's profile Send private message
RGCook
General User
General User


Joined: 19 Jul 2004
Posts: 6
Location: Saint Louis, MO

PostPosted: Wed Nov 02, 2005 9:32 pm    Post subject: Reply with quote

Instead of using paragraph numbering, consider editing an outline numbering style. This is extremely powerful. Here's a simple way to try it.

Step 1 - Open a new document and click on the Numbering On/Off button on the toolbar.
Step 2 - Type "This is level 1 text. Notice that a toolbar pops up that gives you context sensitive control over the numbering. Don't do anything yet with any of them buttons, just follow along here...
Step 3 - Hit enter and then tab.
Step 4 - Click, this is Level 2 text.
Step 5 - Repeat the above for levels 3 and four.
You will now have a staircase list with number 1 on all items.

Step 6 - Put your mouse anywhere inside the text that you typed in the list.
Step 7 - Click on the far right button (tooltip will say bullets and numbering).
Step 8 - Click the outline tab and pick a style. Hit OK to see it applied. Cool.
Step 9 - Repeat Step 8 with other outline styles to see how it works.
Step 10 - Now, select one of the outline styles and then click on options. Specify the setting you want for each level of the outline. This has temendous power. So make a change and "see" what it does. In no time you will have exactly what you want.

Bonus - Once you have the outline set as you want, consider saving it as a template that can be used later in future documents.

Have fun. Good luck.

Bob
Back to top
View user's profile Send private message
valen1260
General User
General User


Joined: 22 Jul 2004
Posts: 8
Location: Kentucky

PostPosted: Thu Nov 03, 2005 6:32 am    Post subject: Reply with quote

While that is helfpul to know, it really doesn't solve my problem or address the possible bug. I have a "level 1" that is numbered with Roman Numerals. Inside the level 1, there are different styles with different or no bullets, but none of them "out rank" any others. In other words, my "level 2" is a mixture of styles.

The bug, if it is a bug, is still that a paragraph style set to Numbering Style: None should turn off numbering for that paragraph. Should I go ahead and file this as a bug?
Back to top
View user's profile Send private message
jrkrideau
Super User
Super User


Joined: 08 Aug 2005
Posts: 6732
Location: Kingston ON Canada

PostPosted: Thu Nov 03, 2005 6:52 am    Post subject: Reply with quote

valen1260 wrote:
While that is helfpul to know, it really doesn't solve my problem or address the possible bug. I have a "level 1" that is numbered with Roman Numerals. Inside the level 1, there are different styles with different or no bullets, but none of them "out rank" any others. In other words, my "level 2" is a mixture of styles.

The bug, if it is a bug, is still that a paragraph style set to Numbering Style: None should turn off numbering for that paragraph. Should I go ahead and file this as a bug?


I believe it is a bug. There have been several threads talking about what seems to be the same or similar problems with Outline Numbing or using number lists
_________________
jrkrideau
Kingston ON Canada
Currently using Windows 7 & OOo 3.4.0 and Ubuntu 12.04 & LibreOffice 3.5.2.2
Back to top
View user's profile Send private message
ftack
Moderator
Moderator


Joined: 27 Jan 2003
Posts: 3102
Location: Belgium

PostPosted: Thu Nov 03, 2005 7:46 am    Post subject: Reply with quote

Yes, this definitely is erroneous behaviour. There are currently several issues with automatic numbering. See also this thread http://www.oooforum.org/forum/viewtopic.phtml?t=25536&highlight=numbering
Back to top
View user's profile Send private message
valen1260
General User
General User


Joined: 22 Jul 2004
Posts: 8
Location: Kentucky

PostPosted: Thu Nov 03, 2005 9:11 am    Post subject: Reply with quote

I added this to Issue 52888
Back to top
View user's profile Send private message
ftack
Moderator
Moderator


Joined: 27 Jan 2003
Posts: 3102
Location: Belgium

PostPosted: Fri Nov 04, 2005 8:05 am    Post subject: Reply with quote

According to issue 52888, it should be fixed in the forthcoming release.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group