OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Set default language to UK English?

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
Mr_Cynical
General User
General User


Joined: 07 Jan 2006
Posts: 9

PostPosted: Mon Sep 18, 2006 7:29 am    Post subject: Set default language to UK English? Reply with quote

I have the 'default language' bug that hasw been mentioned many times on this forum. I've tried all the tricks mentioned (deleting some config file or another, editing the raw files, etc.) and nothing works. How can I get it to recognise my wish to use UK English (en-gb)? I don't care if it involves changing a menu option, editing the default template, or whatever, I just want to set the language!

Alternatively, is it possible (as it was with pre-2.0 OOo) to get a download that is already set to UK English?

EDIT: suppose it would help if I mentioned that I'm on 32-bit Windows XP and Intel
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
Robert Tucker
Moderator
Moderator


Joined: 16 Aug 2004
Posts: 3407
Location: Manchester UK

PostPosted: Mon Sep 18, 2006 10:29 am    Post subject: Reply with quote

If you want the menus and dialogues in UK English you will need to download and install the en_GB language pack:

http://oootranslation.services.openoffice.org/pub/OpenOffice.org/

If you want the UK English spellchecker, install it going to:

File>Wizards>Install new dictionaries...
Back to top
View user's profile Send private message
jrkrideau
Super User
Super User


Joined: 08 Aug 2005
Posts: 6732
Location: Kingston ON Canada

PostPosted: Mon Sep 18, 2006 11:26 am    Post subject: Reply with quote

Robert Tucker wrote:
If you want the menus and dialogues in UK English you will need to download and install the en_GB language pack:

http://oootranslation.services.openoffice.org/pub/OpenOffice.org/

If you want the UK English spellchecker, install it going to:

File>Wizards>Install new dictionaries...


The languages have diverged that much??.
_________________
jrkrideau
Kingston ON Canada
Currently using Windows 7 & OOo 3.4.0 and Ubuntu 12.04 & LibreOffice 3.5.2.2
Back to top
View user's profile Send private message
Mr_Cynical
General User
General User


Joined: 07 Jan 2006
Posts: 9

PostPosted: Mon Sep 18, 2006 12:48 pm    Post subject: Reply with quote

I already have the UK English spellchecker installed, I just can't get OOo to use it by default (even when I change the Language Settings options, the next time I use OOo it reverts to US English)
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
Robert Tucker
Moderator
Moderator


Joined: 16 Aug 2004
Posts: 3407
Location: Manchester UK

PostPosted: Mon Sep 18, 2006 1:12 pm    Post subject: Reply with quote

Mr_Cynical wrote:
I already have the UK English spellchecker installed, I just can't get OOo to use it by default (even when I change the Language Settings options, the next time I use OOo it reverts to US English)


At:

Tools>Options...>Language Settings>Languages>Default languages for documents ?

Is the "For the current document only" box also unchecked?
Back to top
View user's profile Send private message
BillP
Super User
Super User


Joined: 07 Jan 2006
Posts: 2703

PostPosted: Mon Sep 18, 2006 2:43 pm    Post subject: Reply with quote

Mr_Cynical wrote:
I already have the UK English spellchecker installed, I just can't get OOo to use it by default (even when I change the Language Settings options, the next time I use OOo it reverts to US English)


I couldn't get OOo to use UK English by default either. I had to change the language settings in a new document and save it as a template.
Back to top
View user's profile Send private message
Mr_Cynical
General User
General User


Joined: 07 Jan 2006
Posts: 9

PostPosted: Tue Sep 19, 2006 2:07 am    Post subject: Reply with quote

Robert Tucker wrote:
Mr_Cynical wrote:
I already have the UK English spellchecker installed, I just can't get OOo to use it by default (even when I change the Language Settings options, the next time I use OOo it reverts to US English)


At:

Tools>Options...>Language Settings>Languages>Default languages for documents ?

Is the "For the current document only" box also unchecked?


Yeah, it's unchecked.
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
BillP
Super User
Super User


Joined: 07 Jan 2006
Posts: 2703

PostPosted: Tue Sep 19, 2006 4:05 am    Post subject: Reply with quote

Mr_Cynical wrote:
Robert Tucker wrote:
Mr_Cynical wrote:
I already have the UK English spellchecker installed, I just can't get OOo to use it by default (even when I change the Language Settings options, the next time I use OOo it reverts to US English)


At:

Tools>Options...>Language Settings>Languages>Default languages for documents ?

Is the "For the current document only" box also unchecked?


Yeah, it's unchecked.


Are you using a custom template? Unchecking "For the current document only" allows the language change to be made in the Default template. New documents created from the Default template should then use the new language setting but new documents created from other templates will revert to US English. The language change has to be made for each template.
Back to top
View user's profile Send private message
Mr_Cynical
General User
General User


Joined: 07 Jan 2006
Posts: 9

PostPosted: Tue Sep 19, 2006 9:45 am    Post subject: Reply with quote

BillP wrote:
Are you using a custom template? Unchecking "For the current document only" allows the language change to be made in the Default template. New documents created from the Default template should then use the new language setting but new documents created from other templates will revert to US English. The language change has to be made for each template.


As far as I'm aware I'm not using a custom template - I'm just using the default blank page that opens when I run Writer.
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
Mr_Cynical
General User
General User


Joined: 07 Jan 2006
Posts: 9

PostPosted: Wed Sep 20, 2006 8:00 am    Post subject: Reply with quote

It now seems to be working for some reason that's unknown to me. I haven't done anything differently, but this time the Language Settings option seems to have worked. Damn temperamentalness Razz
Back to top
View user's profile Send private message Visit poster's website MSN Messenger
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group