OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Problems formatting document with text boxs and images

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
rafcab
Newbie
Newbie


Joined: 21 Sep 2006
Posts: 4

PostPosted: Thu Sep 21, 2006 7:49 am    Post subject: Problems formatting document with text boxs and images Reply with quote

Hello:
I am using OpenOffice 2.0 for Windows and have imported a 65 page DOC made with Word 2000. This doc has many objects like photos, drawings, text boxes and tables, alone or even grouped.
I am experiencing some annoying problems with the doc formatting. When I first opened it I notice some pages with elements moved from their normal position, which is something I could expect. But when I'm repositioning and formatting all the objects I notice two main problems:
- I cannot group different objects in order to flow them together, for instance, an image and a text box. Or even same kind of object, for instance, two text boxes. This problem happens occasionally and not with all the objects, which seems very strange. Anyway it is not the worst one.
- After I place some objects I do something else, go back to them and find they have moved again, even if they are part of a group. For example, I have one circle, one rectangle and one arrow grouped, and the rectangle has the odd behavior of moving its position inside the group, and when I notice that I have to un-group it, replace the rectangle and group it again. Five minutes after doing this task, it may be wrong again.

I have tried with different anchoring and adjusting options but without effect.
The most strange thing is that among the dozens of objetcs the doc has, only 5 or 6 experience the self-moving behavior. I have also tried to delete these objetcs and make them again but they acquire the same bad attitude.

Can anyone explain me why this happens and if I can repair it?
Thank you
Rafael
Back to top
View user's profile Send private message
RGB
Super User
Super User


Joined: 25 Nov 2003
Posts: 1743
Location: In Lombardy, near a glass of red Tuscany wine

PostPosted: Thu Sep 21, 2006 8:19 am    Post subject: Re: Problems formatting document with text boxs and images Reply with quote

For the first problem, this is a known-huge-unresolved-disturbing-etc limitation of Writer that the developers known but don't want to resolve (I remember a "wontfix" at a related issue in issuezilla). The work around is to copy the objects into Draw, group them and then return to Writer with the group.
For the second problem I have no idea: I never saw something similar Shocked
Back to top
View user's profile Send private message
RGB
Super User
Super User


Joined: 25 Nov 2003
Posts: 1743
Location: In Lombardy, near a glass of red Tuscany wine

PostPosted: Thu Sep 21, 2006 8:31 am    Post subject: Re: Problems formatting document with text boxs and images Reply with quote

RGB wrote:
I remember a "wontfix" at a related issue in issuezilla

It seems that I have problems with my memory: I cannot find the issue... Embarassed
Back to top
View user's profile Send private message
RGB
Super User
Super User


Joined: 25 Nov 2003
Posts: 1743
Location: In Lombardy, near a glass of red Tuscany wine

PostPosted: Thu Sep 21, 2006 10:47 pm    Post subject: Reply with quote

It was not an issue, but an e-mail:
http://www.openoffice.org/servlets/ReadMsg?list=users&msgNo=98332
Quote:
Implementing "group" in Writer would have nightmarish knock-on effects
on text flow, which is the single most important thing a word processor
does.

So, you know de reason now... Confused
Back to top
View user's profile Send private message
rafcab
Newbie
Newbie


Joined: 21 Sep 2006
Posts: 4

PostPosted: Fri Sep 22, 2006 10:52 am    Post subject: Reply with quote

Thank you RGB,
It's a good workaround for my first problem. I can't understand why you can't select objects normally and after bypassing them in Draw you can. Word, for example, manages this topic flawlessly. Anyway I can do with this trick until next OO release.

And with respect to my second problem, maybe it has something to do with my import from Word. Some time ago I was working with Impress importing a Powerpoint presentation and everything was a mess. Not only I got most objects moved from their normal position, texts with different colours and faces, no transitions at all, and more bad things (this could be normal considering the import from a different application) but what is worst, I could not place a new working transition; all that I tried failed. At last I decided to start a new presentation from scratch, but it was a pretty big work.
That is why I think Writer can be mis-managing my imported document, so I have decided to move back to Word again, at least for this doc. I do not feel like writing all the 65 page doc again from scratch. MAybe next time i'm bored.

Cheers
Rafael
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group