OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Enable Field Shading does not work [Solved]

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
Napaloni
Newbie
Newbie


Joined: 29 Sep 2006
Posts: 4

PostPosted: Fri Sep 29, 2006 4:13 am    Post subject: Enable Field Shading does not work [Solved] Reply with quote

Hi!

I am currently editing a document which uses fields. It was a long document, but I reduced it to two text lines, one which defines a field, the second one using the field.

Now to my problem:
I can't enable field shading. I tried it from the menu, I found the color configuration dialog and tried giving it a different color and enabling it from there, and I enabled/disabled use of OpenGL, but fields can't be enabled in this document. Even when the cursor is left to the field, I see no shading at all.
The reference itself works perfect: if I change text and press F9 the change is reflected immediately.

An update to OpenOffice 2.0.3 (SuSE Linux 10.1) didn't change the situation, so it seems I have a document which is broken in some way.

If I create a new OO Writer document, all fields I insert are colored in the color I configured for shaded fields earlier, and I can enable/disable field shading as desired, so it really is my other document which must be broken.

Anyone knows a fix for this or do I have to file a bug report?

Many thanks for any hints and pointers,
Walter


Last edited by Napaloni on Thu Oct 05, 2006 4:26 am; edited 1 time in total
Back to top
View user's profile Send private message
acknak
Moderator
Moderator


Joined: 13 Aug 2004
Posts: 4295
Location: ~ 40°N,75°W

PostPosted: Fri Sep 29, 2006 9:36 am    Post subject: Reply with quote

Sounds like a bug to me. All fields in the problem doc are un-shaded, or just one?

Be prepared to submit your document, or an edited version that still shows the problem. My bet is that it won't be reproducible on other systems (or post it here and prove me wrong Wink).
Back to top
View user's profile Send private message
Napaloni
Newbie
Newbie


Joined: 29 Sep 2006
Posts: 4

PostPosted: Wed Oct 04, 2006 3:11 am    Post subject: Enable Field Shading does not work Reply with quote

> All fields in the problem doc are un-shaded, or just one?
All of them. Not a single one is displayed in grey.

>Be prepared to submit your document, or an edited version that still shows the problem. My bet is that it won't be reproducible on other systems (or post it here and prove me wrong:)
All right, I filed a bug report with a stripped down example document (see http://www.openoffice.org/issues/show_bug.cgi?id=70089) . I guess it's the document's fault and that it is reproducible on all OO 2.0.3, as my OO handles field shading well when creating a new document.

Regards,
Walter
Back to top
View user's profile Send private message
Hagar Delest
Super User
Super User


Joined: 06 Feb 2006
Posts: 5164
Location: France

PostPosted: Wed Oct 04, 2006 3:52 am    Post subject: Reply with quote

The background color is applied to the whole text ! I saw it immediately because I set a background window color to grey in XP (so my pages are grey and not white).

In fact, it's just your Default character style that has a background color set to ... white. But I don't manage to remove it (for the default style). It seems we cannot modify this style.

How have you created this document ? Is it imported from another format ?
_________________
Now on the EN user community forum
Back to top
View user's profile Send private message
Napaloni
Newbie
Newbie


Joined: 29 Sep 2006
Posts: 4

PostPosted: Wed Oct 04, 2006 5:19 am    Post subject: Enable Field Shading does not work Reply with quote

> The background color is applied to the whole text ! I saw it immediately because I set a background window color to grey in XP (so my pages are grey and not white).
Nice trick Smile

> In fact, it's just your Default character style that has a background color set to ... white. But I don't manage to remove it (for the default style). It seems we cannot modify this style.
> How have you created this document ? Is it imported from another format ?
Well, that might indeed be the cause: it is a document generated by importing PDF into KWord and then saving as Open Text.

So I won't do that again. As I discovered that Frame Maker can export directly into RTF, I'll try that...

Many thanks!

Walter
Back to top
View user's profile Send private message
Hagar Delest
Super User
Super User


Joined: 06 Feb 2006
Posts: 5164
Location: France

PostPosted: Wed Oct 04, 2006 5:23 am    Post subject: Reply with quote

OK, I think you should add a comment to your bug report.
Thanks to add [Solved] in your first post title if it's ok.

NB: the strange thing here is that it seems to be impossible to remove this character background color from the default character style Confused.
_________________
Now on the EN user community forum
Back to top
View user's profile Send private message
acknak
Moderator
Moderator


Joined: 13 Aug 2004
Posts: 4295
Location: ~ 40°N,75°W

PostPosted: Wed Oct 04, 2006 10:48 am    Post subject: Reply with quote

Quote:
... I set a background window color to grey in XP (so my pages are grey and not white).

Sounds vaguely depressing Wink May I ask why you prefer this?
Back to top
View user's profile Send private message
Hagar Delest
Super User
Super User


Joined: 06 Feb 2006
Posts: 5164
Location: France

PostPosted: Wed Oct 04, 2006 11:11 pm    Post subject: Reply with quote

I find that black on white background is a too violent contrast for me.
It's a bit like this forum silver theme : it's more comfortable for the eyes.
_________________
Now on the EN user community forum
Back to top
View user's profile Send private message
Napaloni
Newbie
Newbie


Joined: 29 Sep 2006
Posts: 4

PostPosted: Thu Oct 05, 2006 1:04 am    Post subject: Enable Field Shading does not work [solved] Reply with quote

All right, now at least my problem is fixed: It seems that KWord really defined the deault style background color as white, and then field shading does not appear to work.

By pressing F11 to get the "Styles and Formatting" window and then editing the "Default" paragraph style, the background color can by set to "no fill" in the "background" tab when selecting the "color for _character_".

However, I proposed to maybe alter the behaviour in such a way that field shading overrides the background color.

Many thanks for your help!

Walter
Back to top
View user's profile Send private message
Hagar Delest
Super User
Super User


Joined: 06 Feb 2006
Posts: 5164
Location: France

PostPosted: Thu Oct 05, 2006 1:13 am    Post subject: Reply with quote

Hagar de l'Est wrote:
the strange thing here is that it seems to be impossible to remove this character background color from the default character style Confused.

How dumb I'm :
Napaloni wrote:
editing the "Default" paragraph style, the background color can by set to "no fill" in the "background" tab when selecting the "color for _character_".

Thanks also !!!
Can you add [Solved] to your first post title ? It helps to spot the threads that don't need support anymore.
_________________
Now on the EN user community forum
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group