OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Line Spacing Default Behavior in Writer
Goto page 1, 2  Next
 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
Saugatak
General User
General User


Joined: 13 Mar 2006
Posts: 17

PostPosted: Tue Mar 14, 2006 3:23 am    Post subject: Line Spacing Default Behavior in Writer Reply with quote

I've used Word and WordPerfect extensively and am now playing around with Writer.

I've made a form of pleading paper in Writer and am having one problem. Most text in pleading paper is double spaced. In order to fit 28 double-spaced lines in 8.5" x 11" paper with 1" top and bottom margins (requirements for pleading paper), I changed the Default style paragraph to have line spacing of exactly .16"

That's fine for single-spaced typing in pleading paper. Then I created a new style based on the revised Default style where I made line spacing exactly .32", or double the line spacing of the revised Default style so that I could use that as my double-spacing style.

Problem: Whereas Word and WordPerfect shove all of the extra space UNDER the line to do double-spacing, Writer appears to spilt half the space ABOVE the line and half the space UNDER the line.

This may not seem like a big deal, but what happens is that now the text using my double-spaced style is not lined up with the pleading paper numbers. Instead it's half a line space off. So instead of text lining up at numbers 1, 2, 3 etc. the text lines up at 1.5, 2.5, 3.5 etc.

Is there any way to change Writer's default such that line spacing adjustments all occur UNDER the line, instead of being split above and below the line?
Back to top
View user's profile Send private message
Westland
Super User
Super User


Joined: 03 Feb 2006
Posts: 562

PostPosted: Tue Mar 14, 2006 3:49 am    Post subject: Reply with quote

I'm checking now, but I suspect that you need to activate the "Register True" option on the Indents&Spacing tab of the paragraph style.

You need to activate the register on the Page style, as well.

I would prefer to use the Leading option on the Line spacing definition of the paragraph style
_________________
"Do one thing every day that scares you"
Back to top
View user's profile Send private message
Saugatak
General User
General User


Joined: 13 Mar 2006
Posts: 17

PostPosted: Tue Mar 14, 2006 4:04 pm    Post subject: Reply with quote

Register True doesn't work.

If you set it for one style (i.e. text body), it doesn't line up the other style (i.e, text body double space).

Leading option doesn't seem to work either. No matter what number I put in, the paragraphs don't line up with the pleading numbers.

Frankly, while this may not be a bug per se, I think that the way OOo handles spacing/kerning between lines needs to be reworked to match the way Word and WordPerfect do it.

When you are trying to do precise control over your document, you can't have the program controlling how the kerningi is being controlled above the line and under the line. You have to be in control of that or else the document doesn't look the way you want it to, it looks the way OOo Writer wants it to look.
Back to top
View user's profile Send private message
Jallan
OOo Advocate
OOo Advocate


Joined: 16 Jan 2006
Posts: 267

PostPosted: Tue Mar 14, 2006 5:54 pm    Post subject: Reply with quote

There are two pleading paper templates at http://ooextras.sourceforge.net/downloads/english/

There are also two pleading paper templates at http://documentation.openoffice.org/Samples_Templates/User/template/legal/index.html , possibly the same ones.

Since I have never had anything to do with pleading paper, I have no idea how good or bad they might be and thefore I have not downloaded them.

But they should at least be useful in showing ways of approaching the problem.

I did play around a little and was not able to duplicate our lineup problem.

I created a table with one row and 3 columns and set cell margins to 0.

I then entered numbers from 1 to 28 as paragraphs in the first cell, and dummy text produced by entering dt followed by pressing F3 in the second and third cells.

Next I set the line spacing for the font in the first two cells to .16" and in the third cell to .32". To force alignment, I added a blank paragraph at the top of each of the first two cells with a line spacing of .13".

I don't know why .13" works. It was just trial and error.

I did not set Activate on register-true to get my results. I tried that later, and saw no difference.
Back to top
View user's profile Send private message
acknak
Moderator
Moderator


Joined: 13 Aug 2004
Posts: 4295
Location: ~ 40°N,75°W

PostPosted: Tue Mar 14, 2006 7:17 pm    Post subject: Reply with quote

Sorry, this seems like a dumb question, but did you try the 'Fixed' line spacing mode? IME, that really does give a fixed spacing between lines.
There is a problem in that you can only enter two digits after the decimal, which may not be precise enough for a whole column of text. E.g, it seems you need 11"2" = 9" with 28 lines; 9/28 = 0.32143". If you set the spacing at 0.32", then over 28 lines, you'll be off by 0.04" (~1/32"). It sounds like you're off by more than that.
I'll grant you that Writer's default line spacing behavior is a little wacky.
Back to top
View user's profile Send private message
JohnV
Administrator
Administrator


Joined: 07 Mar 2003
Posts: 9183
Location: Lexinton, Kentucky, USA

PostPosted: Tue Mar 14, 2006 8:05 pm    Post subject: Reply with quote

I have fooled with legal templates such as yours before and assume your line numbers are in a frame.

Several things to check and try:

A frame uses a different paragraph style than normal text but you can force it to use the same one so you don't end up with a slight difference in the style definition.

Check the Indents & Spacing tab of your style and make sure there is no spacing Above or Below your paragraph. (BTW, the Frame Content style does have space below the paragraph which is one reason for my suggestion above.)

If you open a header/footer remember that they are inside your page margins in OOo whereas they are outside the margins is some other software. You may need to adjust your margins the account for this or you may be short of text area for the number a lines you want.
Back to top
View user's profile Send private message
Saugatak
General User
General User


Joined: 13 Mar 2006
Posts: 17

PostPosted: Tue Mar 14, 2006 9:26 pm    Post subject: Reply with quote

Jallan wrote:
There are two pleading paper templates at http://ooextras.sourceforge.net/downloads/english/

There are also two pleading paper templates at http://documentation.openoffice.org/Samples_Templates/User/template/legal/index.html , possibly the same ones.

Since I have never had anything to do with pleading paper, I have no idea how good or bad they might be and thefore I have not downloaded them.


One is, one isn't pleading paper, which has numbers 1-28 going down just outside left margin separated by double lines. However, if you look at the one that is pleading paper, you'll notice the pleading line numbers and the text don't line up.

On right margin, there's just a single line just to right of right margin.

The attached documents don't have that information.

Quote:
I did play around a little and was not able to duplicate our lineup problem.

I created a table with one row and 3 columns and set cell margins to 0.

I then entered numbers from 1 to 28 as paragraphs in the first cell, and dummy text produced by entering dt followed by pressing F3 in the second and third cells.

Next I set the line spacing for the font in the first two cells to .16" and in the third cell to .32". To force alignment, I added a blank paragraph at the top of each of the first two cells with a line spacing of .13".

I don't know why .13" works. It was just trial and error.

Yes, you can force alignment this way by entering a dummy paragraph, but this is an inelegant and annoying hack.

I want to be able to set up a template so that I can just start typing and change styles in the stylist. The way you're suggesting, in order to get the text to line up to pleading paper numbers requires insertion of a dummy paragraph every time I switch from single to double spacing.

You should be able to set up Writer so that it doesn't do this.

Quote:
I did not set Activate on register-true to get my results. I tried that later, and saw no difference.

Activate true only works when there's one style of line spacing used. When there's multiple styles of line spacing, activate true will match the line spacing of one style and not the others.

The whole point of pleading paper is to figure out a style that allows 28 double spaced numbers to run vertically between 1" top and bottom margins, then fit the line & paragraph spacing of all other styles so that it matches up with the line numbers.


Last edited by Saugatak on Tue Mar 14, 2006 9:41 pm; edited 1 time in total
Back to top
View user's profile Send private message
Saugatak
General User
General User


Joined: 13 Mar 2006
Posts: 17

PostPosted: Tue Mar 14, 2006 9:34 pm    Post subject: Reply with quote

acknak wrote:
Sorry, this seems like a dumb question, but did you try the 'Fixed' line spacing mode? IME, that really does give a fixed spacing between lines.
There is a problem in that you can only enter two digits after the decimal, which may not be precise enough for a whole column of text. E.g, it seems you need 11"2" = 9" with 28 lines; 9/28 = 0.32143". If you set the spacing at 0.32", then over 28 lines, you'll be off by 0.04" (~1/32"). It sounds like you're off by more than that.
I'll grant you that Writer's default line spacing behavior is a little wacky.


Not at all a dumb question. I did use frames and "fixed". The problem is that for my double-space paragraph style, .16" of space is being put above the line and .16" of space is being put beneath the line. So .32" of space separates the lines, but now my double-spaced text is not lined up exactly with pleading paper numbers, but halfway between them.
Back to top
View user's profile Send private message
Saugatak
General User
General User


Joined: 13 Mar 2006
Posts: 17

PostPosted: Tue Mar 14, 2006 9:40 pm    Post subject: Reply with quote

JohnV wrote:
I have fooled with legal templates such as yours before and assume your line numbers are in a frame.

Several things to check and try:

A frame uses a different paragraph style than normal text but you can force it to use the same one so you don't end up with a slight difference in the style definition.


Here's my styles:

Default: Fixed .16" line spacing
Text body: Default + .16 space After paragraph
Text body2: Default, Fixed .32" line spacing.

Style used in frames was "frame content" which was an exact duplicate of Text body.

Results: default matches up, text body matches up, text body 2 is half a space off due to .16" above and .15" below the line.

Quote:
Check the Indents & Spacing tab of your style and make sure there is no spacing Above or Below your paragraph. (BTW, the Frame Content style does have space below the paragraph which is one reason for my suggestion above.)


Not a problem. As mentioned, only text body had after paragraph spacing and it was matched in .

Edit: BTW, thanks for all the comments. I want to compliment the OOo community for being so helpful, active and involved. I am going to file a suggestion with the OOo developers that line spacing needs to be as defined by user. Probably not a big priority for them, but it's the way Word and WordPerfect work so might as well follow along.
Back to top
View user's profile Send private message
JohnV
Administrator
Administrator


Joined: 07 Mar 2003
Posts: 9183
Location: Lexinton, Kentucky, USA

PostPosted: Wed Mar 15, 2006 6:27 am    Post subject: Reply with quote

What font size are you required to use?

Times New Roman 10 just plain double spaced gives me 28 line numbers in a side frame and I have no problems aligning with that using either just plain double or single spaced styles or a mixture of them. FWIW, my frame has no borders and Spacing to Text is set to zero.

OOo2.0.2.
Back to top
View user's profile Send private message
acknak
Moderator
Moderator


Joined: 13 Aug 2004
Posts: 4295
Location: ~ 40°N,75°W

PostPosted: Wed Mar 15, 2006 8:28 am    Post subject: Reply with quote

Don't know if this helps, but here's a PDF with my shot at what you want:
http://www.mytempdir.com/518460
Quote:
...text body 2 is half a space off due to .16" above and .15" below the line.

Having played a little more with this, I think the space above/below the line is because Writer seems to be spacing from the lowest point in the font rather than baseline to baseline. I'm guessing based on the height/position selected text and the spacing of the first line in a frame.
In any case, it's a painful mess to get precise line spacing.
Back to top
View user's profile Send private message
Jallan
OOo Advocate
OOo Advocate


Joined: 16 Jan 2006
Posts: 267

PostPosted: Wed Mar 15, 2006 8:37 am    Post subject: Reply with quote

If you really want fixed and inflexible layout, then you can try using a text grid.

You may need to first go to Tools -> Options.. -> Language Settings -> Languages and select "Enabled for Asian languages".

When this is enabled, and you select Format -> Page or select a Page style to modify, you will see a tab called "Text Grid". Select it.

Set "Grid" to "Grid lines only". Set Lines per page to the 56 single-spaced lines that you need plus whatever other lines you need. Set "Max. base text size" and "Max. Ruby text size" to any values that total 12 pt, since you really want your line spacing to be 12 pt. if you can get it, rather than rounded to .16 inches. A value of 11.9 pt for "Max. base text size" and .1 pt for "Max. Ruby text size" is perhaps the cleanest, as it effectively makes the Ruby spacing invisible which it might as well be as you will not be using Ruby annotation in any case. For normal use "Print Grid" should not be checked.

When setting up any paragraph styles for this template, make sure under the Alignment tab that "Snap to text grid (if active)" is checked.

Now all you have to do in your paragraph settings in the Indents and Spacing tab is to set line spacing to either "Single" or "Double" and all text will line up exactly with the grid, either displaying on every grid line or every second grid line, depending on the line spacing selected.

(You can switch off "Enabled for Asian languages" now if you wish. That won't effect a document already created with the text grid feature.)
Back to top
View user's profile Send private message
DADSGETNDOWN
Newbie
Newbie


Joined: 17 May 2006
Posts: 2

PostPosted: Wed May 17, 2006 2:57 am    Post subject: Lined Paper , Standard / College Ruled Reply with quote

This might be similar, I am looking at making what I hope is VERY SIMPLE lined Paper, either Regular or College Ruled, I want Categories on the left That I will fill in, like "Location of Crime" then to the right I want the "line" so people can fill out or IN, the information and I will have 6 or 8 Categories or Topics, and maybe skip a line (OR add a line or 2 for more information to be written) people will fill this out, and I will put it in a 3 ring binder. Smile
My Question IS, What would be better this Writer OR Calc for my situation?. I can't seem to do it in wordpad , to basic I guess.
_________________
DADSGETNDOWN@hotmail.com
Back to top
View user's profile Send private message
carlturney
General User
General User


Joined: 05 Oct 2006
Posts: 6
Location: Melbourne Australia

PostPosted: Thu Oct 05, 2006 5:43 am    Post subject: Reply with quote

Folks,

I'm having a basic vertical spacing compatibility problem too. And it is INFURIATING! The so-called "single line spacing" of OpenOffice 2.0 is NOT single spaced. I have installed TrueType fonts that match the ones from MSOffice, and configured OpenOffice to recognise/offer them. I have ensured that there is 0.0 space between lines. I have configured OpenOffice to use version 1.1 line spacing. I have created new documents from scratch, and opened old MSOffice documents. I have ensured the right paper size and margins. I am saving documents in MSWord 97/2000/XP format.

And it's still the same damned problem every time... Pages that used to fit a sheet of paper perfectly and were single spaced in MSOffice, are always half a dozen or more lines too long now.

I'm THAT damned close to just throwing out OpenOffice entirely, and using MSOffice via WINE.

Carl Turney, Melbourne, Australia

p.s. I sure hope the programmers in OpenOffice hear about these discussions on the Forum, and fix it.
Back to top
View user's profile Send private message
geoff80fg
OOo Advocate
OOo Advocate


Joined: 26 Jul 2006
Posts: 420
Location: UK

PostPosted: Thu Oct 05, 2006 6:17 am    Post subject: Reply with quote

As a very simple solution to DADSGETNDOWN, how about trying a table with two columns and however many rows required. Then remove all borders in the left-hand column and remove all but the lower borders in the right-hand column. Enter your prompt text in the left-hand rows (missing out any rows where you want to give more lines on the right.
I've used tables before for very complicated forms with the lower cell borders denoting the space for filled-in replies.

Hope this helps,

Geoff
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group