OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

[Linux] Most TTF fonts in user/fonts directory won't work

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
Hark
General User
General User


Joined: 01 Sep 2005
Posts: 29

PostPosted: Wed Jan 31, 2007 8:27 am    Post subject: [Linux] Most TTF fonts in user/fonts directory won't work Reply with quote

I try to get some TTF fonts working in OpenOffice.org (2.0.4) under Linux (Debian and Ubuntu). I used to copy the fonts (.ttf files) from Windows to my .openoffice.org2/user/fonts folder, that worked great with OpenOffice 2.0.2.

But with OpenOffice 2.0.4 most fonts don't work anymore, but some do work however. For example wingding.ttf works, but pala.ttf, palab.ttf and dendanewlight.TTF don't work. When a font doesn't work it does show up in the font pull-down menu, but it is displayed as the default font.

When I copy the font(s) to /usr/share/fonts/truetype I can use them in OpenOffice, then they are displayed correctly. Unfortunately I have to be able to use the fonts from the user profile. Is this a bug or am I doing something wrong?
Back to top
View user's profile Send private message
acknak
Moderator
Moderator


Joined: 13 Aug 2004
Posts: 4295
Location: ~ 40°N,75°W

PostPosted: Wed Jan 31, 2007 8:47 am    Post subject: Reply with quote

If you have the font files in .openoffice.org2/user/fonts, you need to run "spadmin" and add the font files to OOo's list of installed fonts.

However, what you are doing sounds different from the standard ways of installing fonts on Linux, which typically install the fonts to be used by any user and any application on the system, or if limited to one user, then at least available for any application run by that user. What do you mean by this:
Quote:
... I have to be able to use the fonts from the user profile.

What is it specifically you are trying to accomplish?
Back to top
View user's profile Send private message
Hark
General User
General User


Joined: 01 Sep 2005
Posts: 29

PostPosted: Wed Jan 31, 2007 9:34 am    Post subject: Reply with quote

Thanks for your quick reply acknak. If I'm correct the only thing spadmin does is copying the selected fonts to the .openoffice.org/user/fonts directory. The fonts are already there, so spadmin won't solve the problem. I have tried spadmin a few days ago, and as expected it didn't change the situation.

I have to use the user profile (.openoffice.org/) because people should be able to upload their own fonts. I can't install the fonts system wide because of licensing issues.
Back to top
View user's profile Send private message
acknak
Moderator
Moderator


Joined: 13 Aug 2004
Posts: 4295
Location: ~ 40°N,75°W

PostPosted: Wed Jan 31, 2007 11:09 am    Post subject: Reply with quote

Hmm--you may be right; I assumed that spadmin did some kind of "registration" of the fonts, but that's just a guess.

I typically install personal fonts by copying them into ~/.fonts, and that's all that's necessary (aside from re-starting OOo). But that's a feature of fontconfig, and I don't know if Debian supports that yet.
Back to top
View user's profile Send private message
Hagar Delest
Super User
Super User


Joined: 06 Feb 2006
Posts: 5164
Location: France

PostPosted: Wed Jan 31, 2007 12:41 pm    Post subject: Reply with quote

acknak wrote:
I typically install personal fonts by copying them into ~/.fonts, and that's all that's necessary (aside from re-starting OOo). But that's a feature of fontconfig, and I don't know if Debian supports that yet.

That's what I also do with Ubuntu so it should work also for Debian I guess.

Thanks to add '[Solved]' in your first post title (edit button) if it's ok.
_________________
Now on the EN user community forum
Back to top
View user's profile Send private message
dpeach
OOo Advocate
OOo Advocate


Joined: 06 Oct 2003
Posts: 397
Location: Mrida, Yucatn, Mxico

PostPosted: Wed Jan 31, 2007 12:42 pm    Post subject: Reply with quote

I had a similar situation recently where I knew the fonts were installed as a system wide font, but would not show up as usable in OOo or anywhere. It was a matter of telling KDE where the fonts lived.

The issue may be similar for Gnome. You should be able to enable them on a per user basis, but for the whole desktop environment.

Interestingly, though I have used KDE and Linux for many years, this is the first time I had to manually do this. I recently switched to Slackware from Mandriva. Mandriva did a lot more magic behind the scenes. But if you have done this before in Ubuntu (which it sounds like you have), then it should work the same as before.

Anyway, check to see if there is a way to tell Gnome where your fonts are, either system wide or per user.
_________________
dpeach
OOo 2.0.4 *** Slackware 11

www.mythoughtspot.com <-- My Blog *** My Podcast --> www.missionarytalks.com
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group