OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Embedding fonts in pdf export: Solved
Goto page 1, 2  Next
 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
rsv
General User
General User


Joined: 28 Feb 2007
Posts: 20
Location: Namibia

PostPosted: Thu Mar 01, 2007 1:11 am    Post subject: Embedding fonts in pdf export: Solved Reply with quote

I exported a document to pdf, when uploading to a publishing site the error showed font "symbol" not embedded, this font was used for some technical abbreviations.
You have indicated that all fonts are embedded automatically (presumably on version 2.1?), as I see this was a problem earlier in the forum (1.1), and if it is not embedded it is because it is not on my system.
Please help me out here, where on my system? I have normally used symbol on all the programs on all PC's in my office and it prints fine on all the printers, where exactly should it be to help embed?


Last edited by rsv on Thu Mar 08, 2007 9:54 am; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website
Hagar Delest
Super User
Super User


Joined: 06 Feb 2006
Posts: 5164
Location: France

PostPosted: Thu Mar 01, 2007 2:06 am    Post subject: Reply with quote

I guess your system is not Windows, is it ?

If the Symbol font is used in the document, you must install it on the system used to export the file as PDF. You've to copy the symbol.ttf file to the fonts folder of your system.

Else, you've to use another font (like OpenSymbol).

NB: to check that the font is embedded, see in the menu File>Properties of the PDF reader, there should be a Font tab telling their status.

Thanks to add '[Solved]' in your first post title (edit button) if it's ok.
_________________
Now on the EN user community forum
Back to top
View user's profile Send private message
rsv
General User
General User


Joined: 28 Feb 2007
Posts: 20
Location: Namibia

PostPosted: Thu Mar 01, 2007 3:42 am    Post subject: Embedding fonts in pdf export Reply with quote

Hi thanks for your info on the pdf, I now found the details and it is definately the symbol font, and also clearly not embedded, luckily it is the only one.

Not so fast on the solved, I do unfortunately have windows, and the file symbol.ttf is installed in the C:\windows\fonts directory and in my personal settings folder.

Open symbol seems to embed, but doesnt quite look the same -and I am now completely curious as to why it has picked on the one font to not embed.
Back to top
View user's profile Send private message Visit poster's website
Hagar Delest
Super User
Super User


Joined: 06 Feb 2006
Posts: 5164
Location: France

PostPosted: Thu Mar 01, 2007 6:34 am    Post subject: Reply with quote

Let me try some mind reading : your document comes from (or has been saved once by) MS Word, doesn't it ?
_________________
Now on the EN user community forum
Back to top
View user's profile Send private message
rsv
General User
General User


Joined: 28 Feb 2007
Posts: 20
Location: Namibia

PostPosted: Thu Mar 01, 2007 11:06 am    Post subject: Embedding fonts in pdf export Reply with quote

Nope, this particular document has never been opened in word, however some of the tables that are used were copy pasted from word document. And those tables would have the font concerned in them
Back to top
View user's profile Send private message Visit poster's website
Hagar Delest
Super User
Super User


Joined: 06 Feb 2006
Posts: 5164
Location: France

PostPosted: Thu Mar 01, 2007 11:27 am    Post subject: Re: Embedding fonts in pdf export Reply with quote

rsv wrote:
some of the tables that are used were copy pasted from word document. And those tables would have the font concerned in them

OK. I think we got it. See this thread : Can't see symbols in docs from M$ office.

To fix your doc, try to select the text portions where there are such symbols, change the font to arial for example. If you see squares instead of latin characters, it means that there is a problem with the encoding. In this case, you've to retype the characters in OOo (you can still use the Symbol font).

To avoid missing a characters, you can use the Find & Replace feature, search for the Symbol font and change the formatting to bold red (and do the same afterwards to set back to Default Formatting.

Once all the symbols are rightly encoded, the export should be fine.
_________________
Now on the EN user community forum
Back to top
View user's profile Send private message
rsv
General User
General User


Joined: 28 Feb 2007
Posts: 20
Location: Namibia

PostPosted: Thu Mar 01, 2007 10:11 pm    Post subject: Embedding fonts in pdf export Reply with quote

Thanks-yes that is a problem I also keep having in my other doc that was created in MSword originally some years back, I think it is definately the same thing - often when you reopen the doc the symbols change to little squares, seems like again traced to MS!
I will still have to check - tried just now and it seems there are more problems with that font, let you know when I get back from work tomoro
Back to top
View user's profile Send private message Visit poster's website
Hagar Delest
Super User
Super User


Joined: 06 Feb 2006
Posts: 5164
Location: France

PostPosted: Thu Mar 01, 2007 11:45 pm    Post subject: Reply with quote

Before making all the modifications at once, you should try on a single page with such table with symbols : try first to export and check if the symbol font is not embedded. Then, do the changes described above, export and check if all fonts have been embedded.

Thanks to add '[Solved]' in your first post title (edit button) if it's ok.

[Edit] I tried to reproduce it with my Word 2000 but I can't. All the fonts are embedded, even if the characters are squares coming from a bad MS Word encoding. Can you send me the file (PM me, I'll give you my mail) ? or upload it somewhere on a file sharing web site ?

Perhaps it comes from another font. You could split your doc in 2 and try the export to locate the characters or font that could be the root cause.

_________________
Now on the EN user community forum
Back to top
View user's profile Send private message
rsv
General User
General User


Joined: 28 Feb 2007
Posts: 20
Location: Namibia

PostPosted: Sat Mar 03, 2007 5:06 am    Post subject: Embedding fonts in pdf export Reply with quote

You were right, thanks again, but it only seems to have solved part of the problem.
I tried retyping the symbols using the insert symbol function (although I believe it was used to put them in in the first place, but this did not work.
I had to change all the symbols to aerial (which fortunately had the same character) before they would stay symbols, even though using the insert symbol function, the charter in question is the degree symbol.
The document would stil not embed the symbol font in the pdf.

Fortunately all symbols now being arial and as I was not sure where else symbol might be used I cut and pasted the text to a new document and used select all, then changed the entire document to arial. This initially didnt work, then I found a symbol in the footer, thought I had found the problem, but no, still not???

I believe there is no symbol in the document ow - I will perhaps try to upload.
Back to top
View user's profile Send private message Visit poster's website
rsv
General User
General User


Joined: 28 Feb 2007
Posts: 20
Location: Namibia

PostPosted: Sun Mar 04, 2007 1:06 am    Post subject: Embedding fonts from open office Reply with quote

Hi, thanks for your support, I have tried exporting just one page with no symbols - so I can send you a few pages, the whole book is a bit large.
Back to top
View user's profile Send private message Visit poster's website
Hagar Delest
Super User
Super User


Joined: 06 Feb 2006
Posts: 5164
Location: France

PostPosted: Tue Mar 06, 2007 12:40 pm    Post subject: Reply with quote

I reply your mail here so it can be of some help for other users with this problem : it comes from the copyright character in the footer. Replace it (and the space just following) by the same of another font.

Note that to find a font, you can use the Find & Replace feature. Click on the button More options, then the Format button and type your font name (symbol) in the Font tab, even if it's neither installed on my system, nor does it appear in the font list, OOo did find it.

Thanks to add '[Solved]' in your first post title (edit button) if your issue has been fixed.
_________________
Now on the EN user community forum
Back to top
View user's profile Send private message
rsv
General User
General User


Joined: 28 Feb 2007
Posts: 20
Location: Namibia

PostPosted: Thu Mar 08, 2007 11:46 pm    Post subject: Embedding fonts in pdf export Reply with quote

Hi,
thanks hope the title is edited OK. The problem is solved but there is something wrong with the document. But there is now only two pages causing a problem I think it is some problem with the document. Will look further.
Back to top
View user's profile Send private message Visit poster's website
Hagar Delest
Super User
Super User


Joined: 06 Feb 2006
Posts: 5164
Location: France

PostPosted: Sat Mar 10, 2007 2:55 pm    Post subject: Reply with quote

The problem seems to come from the bullets imported from MS Word. The characters used for bullets are taken from the Symbol font ! You've to spot the bullets styles involved and change the character used.
_________________
Now on the EN user community forum
Back to top
View user's profile Send private message
rsv
General User
General User


Joined: 28 Feb 2007
Posts: 20
Location: Namibia

PostPosted: Tue Mar 13, 2007 10:23 am    Post subject: Embedding fonts in pdf export Reply with quote

Hi, I think it is the bullets! but where? I have removed them and reput them as open office bullets, I cannot change the font???
Then some I re-pasted the word bullets which look like little aeroplanes which work so nicely with my doc, but these are not in the two pages isolated, which brings to my other gripe, I will perhaps send you the two pages if I cant sort it out, are there any bullet archives?
Back to top
View user's profile Send private message Visit poster's website
rsv
General User
General User


Joined: 28 Feb 2007
Posts: 20
Location: Namibia

PostPosted: Tue Mar 13, 2007 10:33 am    Post subject: Reply with quote

Okay I got it wrong those aeroplanes are there, but how do I change it and why is it only two pages when the bulleting is thru the whole doc?
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group