OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Selection of font not working

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Calc
View previous topic :: View next topic  
Author Message
linuxlover
General User
General User


Joined: 09 Apr 2007
Posts: 8

PostPosted: Mon Apr 09, 2007 7:03 pm    Post subject: Selection of font not working Reply with quote

Thanks to all, this is my first post.
I am using oo 2.0.3 in Windows XP.

I want to use a particular font for my whole spreadsheet (which can be used from any cell I need). For this I am selecting the whole spreadsheet by clicking the button which is located top left (just left of Column A and just top of Row 1). This works and I can select the whole spreadsheet. Now I am changing the font from the font selection drop down box. The font I am using is the native font of my regional language. Anyway, this procedure should set the whole worksheet for the same font which I have just selected. But as soon as I write something, the font effect is not taking place and some square is showing. If I select the particular square inside the cell and again set the font, then it is working. Thus I have to set the font for each cell I am using.
How to set the same font for whole of my spreadsheet once at a time?
I do not find the same trouble while I use MSExcel.

I thought it is just a bug and fixed in the next version. Now I have downloaded 2.2 but the problem is not solved here too.
Please tell me what to do?
_________________
regards
anindyanuri
Back to top
View user's profile Send private message
acknak
Moderator
Moderator


Joined: 13 Aug 2004
Posts: 4295
Location: ~ 40°N,75°W

PostPosted: Mon Apr 09, 2007 8:42 pm    Post subject: Reply with quote

You want to modify the default cell style.

1. Format > Styles and Formatting
2. Right-click on "Default" and choose "Modify"
3. Font tab: choose your font settings.
4. OK

Now all cells will use the font you set automatically.

If you have installed a language pack for your language, you can also specify a default language on the same style font tab.

This only changes one document. If this works, let us know and we can take the next step.
Back to top
View user's profile Send private message
linuxlover
General User
General User


Joined: 09 Apr 2007
Posts: 8

PostPosted: Tue Apr 10, 2007 8:54 am    Post subject: Reply with quote

Thank you for giving attention to my thread.

Yes, it is working, but only if I use Linux (KUBUNTU) but in case Windows, it is not working.

In Linux, now please guide me what to do to make it default permanently.

Also, a discripancy noticed. If I put numbers into the cell, it is changing to english as soon as I leave the cell. Suppose, I write One in my regional language in cell A1 and as soon as I move to any other cell, the One in the cell A1 changes to 1. Please mention, how to correct it too.

I have changed as per your direction and changed the Font Name entry in CTL fonts drop down box.

NB : Please note that no language pack is installed in my system. I have downloaded Bengali Language Pack, but it is not working at all and I could not install it.

In case of Windows, I did not find any CTL Font Selection Box, and I edited the only Font input box and used as per my desired font, but no effect.
_________________
regards
anindyanuri
Back to top
View user's profile Send private message
acknak
Moderator
Moderator


Joined: 13 Aug 2004
Posts: 4295
Location: ~ 40°N,75°W

PostPosted: Tue Apr 10, 2007 11:44 am    Post subject: Reply with quote

I'm afraid I'm not the right person to help with most of these issues, since they sound like problems arising from incomplete configuration for your locale. I use only one locale, the default, and so I'm not experienced with installing language support (especially CTL support), configuring for a particular locale.

As far as making the font selection "permanent," what we did so far was to change the font specified by the default style. This works for one document, but now we ned to save a template file and specify that file as the default template. Then, on later OOo sessions, the custom template will be loaded on startup and your font selection will take effect for every new document.

1. Start a new spreadsheet and change the font in the "Default" style, as before.
2. File > Templates > Save ...
___New Template: My Default Calc
___OK
3. File > Templates > Organize ...
___Select "My Templates" / "My Default Calc" at the left
___Click "Commands" > "Set as default template" at the right.
___Close

Close the current document; dont' save it (it's already saved as the template)
File > New > Spreadsheet
Your font should now be selected by default.

You may be seeing differences in Windows because CTL is not activated. In WIndows, go to Tools > Options > Language Settings > Languages, make sure "Enhanced Language Support" / "Enabled for complex text layout (CTL)" is checked, and then select a language for CTL just above that.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Calc All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group