OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

export to pdf -> numbers are changed to arabic characters

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
mercury202
General User
General User


Joined: 25 Dec 2006
Posts: 29
Location: Kassel, Germany

PostPosted: Mon Apr 23, 2007 7:48 am    Post subject: export to pdf -> numbers are changed to arabic characters Reply with quote

Hello everybody!

I've got the following problem:

When I'm converting a writer-document into a pdf-file, all the numbers of all the tables therein, and some of the numbers of some of the mathematical formulas therein (I really can't see a scheme in the latter) are changed to arabic numbers. Shocked

The follwing two screenshots might help to visualize the problem:

this is the original (click to enlarge):


this is the pdf-file (note the caption of the table) (click to enlarge):


All the tables are pasted from a calc-document, if that means anything. However, I converted multiple writer-documents into pdf before, quite a number of them containing tables pasted from calc, without ever experiencing any problems at all.

Has anybody some idea, what I could do, about this? It's kind of important to me, because I need to send the file to a tutor of mine...

thanks in advance
mercury202
Back to top
View user's profile Send private message Visit poster's website
hol.sten
Super User
Super User


Joined: 14 Nov 2004
Posts: 3533
Location: Hamburg, Germany

PostPosted: Mon Apr 23, 2007 10:11 am    Post subject: Re: export to pdf -> numbers are changed to arabic charac Reply with quote

mercury202 wrote:
Has anybody some idea, what I could do, about this?

It might be a font problem. Which font are you using?

BTW: Which OOo version and which operating system are you using?

Regards
hol.sten
Back to top
View user's profile Send private message
mercury202
General User
General User


Joined: 25 Dec 2006
Posts: 29
Location: Kassel, Germany

PostPosted: Mon Apr 23, 2007 10:33 am    Post subject: Reply with quote

I'm using OOo version 2.2.0
OS is Win XP SP2.
font: Times New Roman

Any ideas?
Back to top
View user's profile Send private message Visit poster's website
JohnV
Administrator
Administrator


Joined: 07 Mar 2003
Posts: 9183
Location: Lexinton, Kentucky, USA

PostPosted: Mon Apr 23, 2007 10:59 am    Post subject: Reply with quote

Can't reproduce this under Win98 with OOo2.2. I used the default font in one column and Times New Roman in the other. Copied and pasted with Ctrl+C and Ctrl+V then exported the Writer file to PDF. No problem.

You might want to try running a Repair if no one else can confirm.
Back to top
View user's profile Send private message
Hagar Delest
Super User
Super User


Joined: 06 Feb 2006
Posts: 5164
Location: France

PostPosted: Mon Apr 23, 2007 11:32 am    Post subject: Reply with quote

This is indeed a very strange issue. Can you upload a sample (both a modified Calc sheet and the Writer document in a zip file) on a file sharing web site (like UpLoadHut.com) ?
_________________
Now on the EN user community forum
Back to top
View user's profile Send private message
mercury202
General User
General User


Joined: 25 Dec 2006
Posts: 29
Location: Kassel, Germany

PostPosted: Mon Apr 23, 2007 12:07 pm    Post subject: Reply with quote

Now that's weird:
Before I opened this thread I tried to convert the file multiple times - but I never had any success: It was always the same.

Now I'm not able to reproduce the problem (not even with the original file: I kept the original writer-doc, of course, and now I converted it to pdf again, and had no problems.) 'though I didn't change anything at all - I didn't even reboot my computer in the meantime. That's really strange!
Back to top
View user's profile Send private message Visit poster's website
Hagar Delest
Super User
Super User


Joined: 06 Feb 2006
Posts: 5164
Location: France

PostPosted: Mon Apr 23, 2007 12:29 pm    Post subject: Reply with quote

It's the second time within a week I see a bug that is forum sensitive : as soon as it has been explained on the forum, it knows it will be eradicated. Then the only solution is its suicide.
_________________
Now on the EN user community forum
Back to top
View user's profile Send private message
soliplaya
General User
General User


Joined: 22 Apr 2007
Posts: 11
Location: Valencia, Spain

PostPosted: Mon Apr 23, 2007 1:05 pm    Post subject: forum-sensitive bugs Reply with quote

Well I am sorry to say it did not work for mine (http://www.oooforum.org/forum/viewtopic.phtml?t=56171).
I tried my best though : I posted it first to the Writer forum, and since it did not want to disappear, I moved it to the API forum. Then I reloaded the page several times, to make sure my laptop would be aware of it.
But no luck so far.
Maybe I should save the forum page and try to convert the html to ODS?
Cool
Back to top
View user's profile Send private message
mercury202
General User
General User


Joined: 25 Dec 2006
Posts: 29
Location: Kassel, Germany

PostPosted: Mon Apr 23, 2007 10:58 pm    Post subject: Reply with quote

@Hagar:
usually I'm not that quick with posting bugs - but because I have to send the file today I felt it was kind of urgent.

@all:
sorry for troubling you, but thanks for your help
Back to top
View user's profile Send private message Visit poster's website
ranson
Newbie
Newbie


Joined: 25 Apr 2007
Posts: 1

PostPosted: Wed Apr 25, 2007 8:01 pm    Post subject: Arabic in PDF Export Reply with quote

I can confirm this problem. A friend of mine, using OOffice 2.1under Windows XP Service Pack 2, ran into the same bug. Numbers in equations were rendered as Arabic (I think) when the document was exported to PDF. When I took the same document and exported it to PDF from OOffice 2.0.4, I didn't have any problems.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group