OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Upgrading From 2.2 to 2.3; Clean Install Required? [Solved]

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> Setup and Troubleshooting
View previous topic :: View next topic  
Author Message
Mulsiphix
General User
General User


Joined: 01 Jul 2007
Posts: 23

PostPosted: Sun Sep 30, 2007 4:19 pm    Post subject: Upgrading From 2.2 to 2.3; Clean Install Required? [Solved] Reply with quote

I have 2.2 installed. Can I upgrade to 2.3 somehow or do I need to install 2.3 into its own directory and copy over my files from 2.2?

Last edited by Mulsiphix on Mon Oct 01, 2007 8:36 am; edited 2 times in total
Back to top
View user's profile Send private message
maxqnz
Super User
Super User


Joined: 24 Mar 2003
Posts: 1290
Location: Te Ika a Maui, Aotearoa

PostPosted: Sun Sep 30, 2007 4:34 pm    Post subject: Reply with quote

You CAN upgrade, but given that many people here have reported various glitches that were often solved by uninstalling and reinstalling, I'd recommend uninstalling 2.2 first.
_________________
Noho ora mai, ka kite ano.
What Is A Pieriansipist?

OOo 2.4/XP Pro SP2 / OOo 2.3.0.1/OpenSuse 10.3
Back to top
View user's profile Send private message Visit poster's website
Mulsiphix
General User
General User


Joined: 01 Jul 2007
Posts: 23

PostPosted: Sun Sep 30, 2007 5:08 pm    Post subject: Reply with quote

How do I make sure my settings, like macros, are carried over to 2.3 if I do a clean install of 2.3?
Back to top
View user's profile Send private message
maxqnz
Super User
Super User


Joined: 24 Mar 2003
Posts: 1290
Location: Te Ika a Maui, Aotearoa

PostPosted: Sun Sep 30, 2007 5:36 pm    Post subject: Reply with quote

Mulsiphix wrote:
How do I make sure my settings, like macros, are carried over to 2.3 if I do a clean install of 2.3?


Copy the Documents and Settings\{username}\Application Data\OpenOffice.org2\user
directory somewhere else, then paste it back in after the fresh install. That should do the job/
_________________
Noho ora mai, ka kite ano.
What Is A Pieriansipist?

OOo 2.4/XP Pro SP2 / OOo 2.3.0.1/OpenSuse 10.3
Back to top
View user's profile Send private message Visit poster's website
esperantisto
Super User
Super User


Joined: 26 Dec 2003
Posts: 779
Location: Belarus

PostPosted: Sun Sep 30, 2007 10:09 pm    Post subject: Reply with quote

Normally, uninstalling OOo won't delete your settings, but you'd better follow maxqnz's advice. Also, don't forget to backup your dictionary directory in <OOo installation directory>/share/dict/ooo, if your dictionary set is different from the default one.

Within 2.0-2.2.1 line, I did not have any trouble in upgrading, but 2.3 just installed without removing the previous version. And when I uninstalled 2.2.1, I had to re-run installation of 2.3 in repair mode to get file associations and some other stuff work. So, yes, do a clean install.
Back to top
View user's profile Send private message
noranthon
Super User
Super User


Joined: 07 Jul 2005
Posts: 3318

PostPosted: Sun Sep 30, 2007 11:02 pm    Post subject: Reply with quote

This problem could be the subject of several bug reports. First, the website instructions should state that previous versions need to be removed. Secondly, they should advise people to retain the downloaded installer to assist with later removal. Thirdly, the touted installer "wizard" should cover these matters.

Every release I've seen for almost 2 years has been accompanied by stupid, avoidable problems.
_________________
search forum by month
Back to top
View user's profile Send private message
maxqnz
Super User
Super User


Joined: 24 Mar 2003
Posts: 1290
Location: Te Ika a Maui, Aotearoa

PostPosted: Sun Sep 30, 2007 11:07 pm    Post subject: Reply with quote

noranthon wrote:
This problem could be the subject of several bug reports. Secondly, they should advise people to retain the downloaded installer to assist with later removal. .


This I've never had a problem with. I've never needed the installer to help with removal, and I tend to run almost exclusively dev-builds as they become available.
_________________
Noho ora mai, ka kite ano.
What Is A Pieriansipist?

OOo 2.4/XP Pro SP2 / OOo 2.3.0.1/OpenSuse 10.3
Back to top
View user's profile Send private message Visit poster's website
noranthon
Super User
Super User


Joined: 07 Jul 2005
Posts: 3318

PostPosted: Sun Sep 30, 2007 11:56 pm    Post subject: Reply with quote

I rather fear that I posted my comment in the wrong thread. Embarassed There have been a few dealing with the issue of "clean install" and I've seen problems reported in relation to my distro's version which uses the official oo.o build. I see the O.P. in this case pre-empted the issue, as did your advice. I just hope the right people get to see it. Sad
_________________
search forum by month
Back to top
View user's profile Send private message
Mulsiphix
General User
General User


Joined: 01 Jul 2007
Posts: 23

PostPosted: Mon Oct 01, 2007 8:34 am    Post subject: Reply with quote

I went ahead and did a clean install. I backed up the user folder and dictionary mentioned in above posts. Everything works just as it should and all of my settings were preserved. Many thanks for all of your help Very Happy
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> Setup and Troubleshooting All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group