OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

[SOLVED] footnote conversion problem

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
mbb1
General User
General User


Joined: 10 Oct 2007
Posts: 5

PostPosted: Wed Oct 10, 2007 6:37 am    Post subject: [SOLVED] footnote conversion problem Reply with quote

Hi

I am having a weird OO Writer problem. I am new to OO, so please excuse me if the answer to my question is apparent.
I have a document, which is a consolidation of 3 other documents. All of them contain footnotes. The footnote numbering re-starts with each document. When I open the consolidated document in MS Word, the footnote numbering remains intact. OO Writer however, continues the footnote numbering from the first document into the second. The third one remains intact. Weird.
Further, I have to convert the doc format to html. On conversion, both Word and OO assigned continuous footnote numbering. I managed to solve the problem in Word by inserting a section break. I can't seem to be able to that in OO Writer. The organisation I work for has made it a policy to use open source solutions, hence I don't want to rely on MS Word for these special cases. Please help.


Last edited by mbb1 on Thu Oct 11, 2007 6:46 am; edited 1 time in total
Back to top
View user's profile Send private message
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Wed Oct 10, 2007 6:51 am    Post subject: Reply with quote

In Tools -> Footnotes you can set options for notes numbering. Footnotes can be numbered per page, per chapter or per document (I suppose that means you insert documents in one container document but didn't check that). Endnotes can be numbered by document only - I feel that's a major shortcoming, it should be easy to list endnotes by chapter and to insert breaking lines with chapter titles automatically. Note that this information is easily found in the help file that comes with OOo.

As far as I know chapters are defined by the Heading 1 paragraph style.

If answered your problem please add [Solved] to the title of your first post (click Edit to edit the post).
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
mbb1
General User
General User


Joined: 10 Oct 2007
Posts: 5

PostPosted: Wed Oct 10, 2007 9:38 am    Post subject: Reply with quote

Hi Floris,
Thanks for responding. Perhaps I should have elaborated further - I checked the Help file in OO and set the footnote numbering Per Chapter. The Help file is silent on how to set chapters but I am assuming it is as easy as assigning it as a Heading 1, 2, 3 etc from the Outline menu.
The problem still persists.
I am not sure if I can send you the file through PM and you can have a look?
Back to top
View user's profile Send private message
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Wed Oct 10, 2007 10:07 am    Post subject: Reply with quote

You can post your file on a filesharing website and post the link here.
You're correect: you set chapters with the Heading 1 style in the paragraph styles. You can check if that works by inserting a table of contents with only headings marked as Heading 1. Are you sure that you assigned the Heading 1 style to chapter titles and that you didn't just change a few settings for chapter numbering? And your notes are real footnotes and not endnotes? Make sure that your lay-out is consistent - either include page breaks at each new chapter or don't add them anywhere.
Some problems may not be related to OOo at all but can occur in any word processor if you use it wrongly. I've made a lot of mistakes in the past. Laughing Scrutinize your document and hunt down any differences in it, it's incredible how much you can learn from your own mistakes, and it's incredible how blind you can be for some of your mistakes. I've been there, and so have most of the experienced users here, I'm sure. Laughing
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
mbb1
General User
General User


Joined: 10 Oct 2007
Posts: 5

PostPosted: Wed Oct 10, 2007 10:24 pm    Post subject: Reply with quote

Morning Floris

The document is here http://concourt.law.wits.ac.za/files/nm/nm.doc

Please look at the first footnote after para 122 (Para 122 is where the second judgment starts).

Thank you once again for helping out
Back to top
View user's profile Send private message
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Thu Oct 11, 2007 2:34 am    Post subject: Reply with quote

Okay, here goes.

In Word everything looks good, and when I open it in OOo it doesn't. Of course that doesn't really matter, although it looks suspicious. you only convert your original odt file to the Word format so that people who don't have OOo can read it in Word. There's no need for you to continue working with it in Writer. You should continue with the odt file, and whenever you need to send it to others, you first save it as .odt and then as .doc, send the .doc file and continue with the .odt.

There was a funny part right before para 122 - a break in the middle of a sentence. Because you didn't send the original .odt file I can't see what you did there.

You didn't use the Heading 1 style. And that makes life so easy. The thing is that you can modify the formatting of the Heading 1 style so that the heading will look exactly like it does now, but OOo will recognize it as a chapter marking and will restart footnote numbering. To change the look of Heading 1 (and any other style) right click Heading 1 in the styles list and select Modify. On the font tab you can change the default settings to 13 pt, Standard etc, and in Font effects you can even apply Capitals.

Hope this helps.
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
mbb1
General User
General User


Joined: 10 Oct 2007
Posts: 5

PostPosted: Thu Oct 11, 2007 4:47 am    Post subject: Reply with quote

Hi Floris,

I get a doc file from the court. This is the original version. Then I convert to HTML and the footnote numbering gets lost.
I will try to copy and paste in OO with proper formatting (headings) ... but that's too much manual work.
Thanks... if I come up with anything I will post it here. If you come up with some solution, please let me know as well.
Thanks
Back to top
View user's profile Send private message
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Thu Oct 11, 2007 6:19 am    Post subject: Reply with quote

There's some formatting with the sections that I don't fully understand, but if you open the navigator and select Sections, then double click Section 6 and click Edit, then select Options in the dialog box, then select the Footnotes/Endnotes tab, check Collect and end of text and Restart numbering. That worked for me. For this file.
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
mbb1
General User
General User


Joined: 10 Oct 2007
Posts: 5

PostPosted: Thu Oct 11, 2007 6:46 am    Post subject: Reply with quote

Thanks, Floris. It was definately a bad document to start with. I converted to rtf(odt worked as well) and then assigned Heading 1 styles to separate chapters .. the rest just happened - it worked!
I am almost certain though that if one keeps the .doc format, applying chapters does not work (been doing that since yesterday). The key is to convert to rtf or odt.

Floris, bouncing this problem off with you has helped me a lot. Thank you
Back to top
View user's profile Send private message
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Thu Oct 11, 2007 6:47 am    Post subject: Reply with quote

You're very welcome. Laughing
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
student11
Newbie
Newbie


Joined: 08 Dec 2007
Posts: 3

PostPosted: Sat Dec 08, 2007 9:10 am    Post subject: Reply with quote

Hello,

New to this forum, but impressed by all the knowledge, here. I see you folks are way ahead of me on OO file conversion techniques. I'm using OO Writer 2.0.4 and trying to convert documents to Word 97. The conversion works fine except that none of the footnotes are carried into Word. The anchors themselves show, but not the footnotes. What am I doing wrong here? Any help would be appreciated. Student11
Back to top
View user's profile Send private message
jrkrideau
Super User
Super User


Joined: 08 Aug 2005
Posts: 6732
Location: Kingston ON Canada

PostPosted: Sat Dec 08, 2007 10:43 am    Post subject: Reply with quote

student11 wrote:
Hello,

New to this forum, but impressed by all the knowledge, here. I see you folks are way ahead of me on OO file conversion techniques. I'm using OO Writer 2.0.4 and trying to convert documents to Word 97. The conversion works fine except that none of the footnotes are carried into Word. The anchors themselves show, but not the footnotes. What am I doing wrong here? Any help would be appreciated. Student11


What OS and version of OOo are you using?

Were the documents created in OOo?

If possible it would be useful if you would post a sample OOo file for people on the forum to examine.


Handy places to post a file:

media fire http://www.mediafire.com/
or
mytempdir.com http://www.mytempdir.com

Oh yes, and welcome
_________________
jrkrideau
Kingston ON Canada
Currently using Windows 7 & OOo 3.4.0 and Ubuntu 12.04 & LibreOffice 3.5.2.2
Back to top
View user's profile Send private message
student11
Newbie
Newbie


Joined: 08 Dec 2007
Posts: 3

PostPosted: Thu Dec 13, 2007 1:42 pm    Post subject: Reply with quote

thanks jrk. using suse 10.2, OO writer 2.0.4. docs were created using OO writer, read by EMO's WWB(V.8.15)-enhanced Word 97, running on Win98SE. will try to post sample file.
Back to top
View user's profile Send private message
student11
Newbie
Newbie


Joined: 08 Dec 2007
Posts: 3

PostPosted: Wed Dec 19, 2007 9:51 am    Post subject: Reply with quote

Solved. Attached footnotes to pages rather than document (endnotes). Also, formatted them in bulk with Word, then converted document back to .odt wit OO.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group