OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Japanese input with English UI under Mandrake Linux 10.0

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> Setup and Troubleshooting
View previous topic :: View next topic  
Author Message
erikanderson3
OOo Advocate
OOo Advocate


Joined: 25 Feb 2004
Posts: 332
Location: San Francisco peninsula

PostPosted: Sat Mar 13, 2004 6:53 am    Post subject: Japanese input with English UI under Mandrake Linux 10.0 Reply with quote

Hello all --

I've spent some time trying to figure this one out. I ran across this helpful page over at U Wiscoonsin, but I can't seem to get it to work. I presume it's one of the environment variables in $HOME/.i18n, but which one? Setting LC_CTYPE to en_US gives me the UI in English, but it also disables Japanese input, even though kinput2 is still running... Question

Any help is appreciated.

TIA,

Erik
Back to top
View user's profile Send private message
erikanderson3
OOo Advocate
OOo Advocate


Joined: 25 Feb 2004
Posts: 332
Location: San Francisco peninsula

PostPosted: Wed Mar 17, 2004 4:54 pm    Post subject: Reply with quote

I've gotten the configuration to work, but only on a different user account -- I think my KDE has locked up into a specific configuration, as I've discovered that it's completely ignoring my .i18n file. I manually switched it back to completely English settings, and KDE still came up with Japanese. Hmph. I then made sure that KDE was not restoring a previous session -- but same results.

I'll spend some time tonight dorking about with the contents of the ~/.kde folder and see what I find. I'll also try changing the localization settings explicitly using the KDE control panels. If all else fails, I may simply delete the ~/.kde folder and see if that works. Twisted Evil (after backing up what I need, of course)

I'll post my .i18n file (the one that works on the other user account) later tonight once I get back home to my Mandrake box, just in case anyone else might find a use for CJK (Chinese - Japanese - Korean) input with an English UI.

Cheers,

Erik
Back to top
View user's profile Send private message
erikanderson3
OOo Advocate
OOo Advocate


Joined: 25 Feb 2004
Posts: 332
Location: San Francisco peninsula

PostPosted: Thu Mar 18, 2004 5:25 pm    Post subject: Reply with quote

Now I can't figure out *what* I did on that other user account. I thought I walked through all the steps to recreate it, but OOo still comes up with a Japanese UI. Argh. Exporting LC_ALL=en_US does the expected and forces an English UI, but it also disables any Japanese input -- not useful. It also seems to render OOo unable to recognize Japanese filenames -- they look like complete gibberish, and attempts to open such a file simply produce a "file not found" error. Likewise for LC_CTYPE=en_US.

I can't figure out what I did on the other account. I even tried just copying over the .i18n file, but no dice. Opening OOo and going through Tools -> Options -> Language Settings -> Language and specifically choosing English (USA) does exactly squat. Help me out here, is this a bug? I think I'll report it as one, as changing this setting under Linux seems to do nothing at all. For that matter, I just tried under Win2K and it also seems to do -- Nothing! Whee. What is this setting for? Window dressing? Manually tweaking .openoffice/user/registry/data/org/openoffice/Setup.xcu to read the following:
Code:
  <prop oor:name="ooSetupSystemLocale" oor:type="xs:string">
   <value>en-US</value>
  </prop>
also does nothing, as OOo does not read this data, it overwrites it on startup back to:
Code:
  <prop oor:name="ooSetupSystemLocale" oor:type="xs:string">
   <value>ja-JP</value>
  </prop>
What the devil is this file for, then? Setting it to read-only does nothing either, at least as the user, as OOo then simply resets it to read-write when it overwrites the data (I haven't tried chown yet, but I might just do that tonight...). I can find no other obvious place to put localization preferences. The .i18n file at least has some observable effect on OOo behavior, but the English UI and Japanese input seem mutually exclusive. Except I've done it once! That's the befuddling thing.

Help, help? I'm getting increasingly confused here. Perhaps someone could at least point me to a developer's email or forum where I could pick someone's brain?

Cheers,

Erik
Back to top
View user's profile Send private message
erikanderson3
OOo Advocate
OOo Advocate


Joined: 25 Feb 2004
Posts: 332
Location: San Francisco peninsula

PostPosted: Tue Mar 23, 2004 7:14 am    Post subject: Reply with quote

<grimble grumble>

Note to self --
Working out complicated issues is much easier after adequate sleep. Confused


After considerable frustration, I backed off for a while, and then started over from the beginning. I have now had success, thanks to Halldór Narfi Stefánsson's page.

The key was to ditch the ~/.openoffice folder (or backup, but since mine had nothing but the usual install info, I just hit rm -rf), and then run OOo from a console after entering
Code:
export LC_ALL=en_US.UTF-8
 export LANG=en_US.UTF-8
 export LANGUAGE=en_US.UTF-8

The minor detail I kept tripping on here was the encoding tacked onto the end of the language marker. It seems that without the UTF-8 specification, OOo seems to write different settings files to its dot-directory, and is more than happy to keep popping up with the Japanese UI.

So many thanks to Halldór! I hope this posting may help in future.

Cheers,

Erik
Back to top
View user's profile Send private message
jkim
Guest





PostPosted: Wed Apr 07, 2004 10:20 am    Post subject: Reply with quote

Would this work for KOREAN setting also? (with Eng. Menus)
Or do I need some adjustments? and how?
Thanks
Back to top
erikanderson3
OOo Advocate
OOo Advocate


Joined: 25 Feb 2004
Posts: 332
Location: San Francisco peninsula

PostPosted: Wed Apr 07, 2004 7:36 pm    Post subject: Reply with quote

All I can say is try it and see. I suspect it will; so far it's worked for Japanese and Swedish. It seems part of the key is the .UTF-8 suffix on locale variables.

Let us know if it works out! Smile

Cheers,

Erik
Back to top
View user's profile Send private message
LBWood
Guest





PostPosted: Wed Apr 21, 2004 1:42 am    Post subject: Korean Input Reply with quote

This is a duplicate post to another one I put in the General Discussion Forum.

Setting up RH9.0 and GNOME for Korean Input

1.Confirm that Korean language support has been installed.
System settings -> Language should display a dialog box that displays Korean as a choice.
If not, an update install will probably be required to install the additional languages.

2.Confirm that Ami, the Korean IME, has been installed.
Accessories -> More Accessories should have it.

3.Confirm that your home directory contains .Xclients-default.
If the file is not there, run the switchdesk program in a terminal window to create it.

4.Edit .Xclients-default and add the following line immediately before the exec command:
LC_ALL=ko_KR LANG=ko_KR ami &

5.Restart GNOME. The Ami preferences dialog should appear in the window list (in Korean).
You can close it if you wish.

6.Create a file called kinputx that contains the following command line within:
XMODIFIERS="@im=Ami" LANGUAGE=en_US LC_CTYPE=ko_KR ${1+"$@"} @

7.Make kinputx executable:
chmod 755 kinputx

8.Move kinputx to either /usr/bin or /usr/local/bin.

9.If Ami is not already running, start it now.
Accessories -> More Accessories -> Ami will bring it up in English.

10.Open a terminal window and start up the program you want as a parameter of kinputx:
E.g., kinputx oowriter

11.Confirm that Ami is active.
[EN] should appear underneath the cursor.

12.Select a Korean font from the font drop-down box.

13.Type <Shift><Spacebar> to switch to Korean input.
[KR] should appear underneath the cursor.

Note that this example will bring up oowriter with English menus and dialog boxes.
If you want it in Korean, substitute LC_ALL for LC_CTYPE in Step 6.
Back to top
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> Setup and Troubleshooting All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group