OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

After 2.3.1 install KeePass 1.10 behaviour changed

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> Setup and Troubleshooting
View previous topic :: View next topic  
Author Message
catkin
Power User
Power User


Joined: 03 Feb 2007
Posts: 83

PostPosted: Sun Feb 24, 2008 9:08 am    Post subject: After 2.3.1 install KeePass 1.10 behaviour changed Reply with quote

Hello Very Happy

This could be a complete red herring but ...

After installing OOo 2.3.1, KeePass 1.10 no longer starts with OnScreenKeyboard 1.10 and, after logging in to KeePass, when "Open URL(s)" is clcked, starts Mozilla Firefox 2.0.0.12 rather than IE 7.0.5013.13.

Firefox is the default browser but KeePass has to start IE so it can "AutoType" username and password (IE has the necessary API and Firefox does not -- yet).

Option "Close button [X] minimizes the main window instead of terminating the application" may have been deselected, too. (this makes little sense!)

I can't recall any changes to the computer that happened since KeePass behaved normally and this changed behaviour apart from the OOo 2.3.1 installation.
_________________
OOo 3.2.1 on Slackware64 13.1 with Xfce desktop
Registry Workshop (SourceForge project, based on OOo Calc)
Back to top
View user's profile Send private message
thomasjk
Super User
Super User


Joined: 16 Dec 2005
Posts: 2374

PostPosted: Sun Feb 24, 2008 11:09 am    Post subject: Reply with quote

I'm using 2.3.1 with KeePass 1.10 and I don't see the behavior you describe. AutoType works fine with Firefox. IE is not needed for me. OPen url opens Firefox my default browser as expected. What is OnScreen Keyboard 1.10?
Back to top
View user's profile Send private message
catkin
Power User
Power User


Joined: 03 Feb 2007
Posts: 83

PostPosted: Sun Feb 24, 2008 11:37 pm    Post subject: Reply with quote

Thanks Thomas Very Happy

I've PMed you about OnScreenKeyboard to avoid posting off topic here.

Sorry about AutoType -- I meant KeeForm. The reason for the changed behaviour is that the line required for KeeForm had disappeared from the KeePasss.ini file:
Code:
KeeUrlOverride=cmd://"{APPDIR}\KeeForm.exe" "{URL}" "{USERNAME}" "{PASSWORD}" {ENTERFORM}


Since the original post I also found that, In KeePass options, "Use puTTy for ssh: and telenet URLs" was no longer ticked.

The main issue is not how to fix the configuration but that it changed unepectedly. OK -- I probably did something stupid or the computer "glitched" (changing configuration for a plugin, the .ini file and options!).

The reason for posting is in case something systematic is going on here; if it happens to other KeePass installations and people search this forum ... and find some consistency of symptoms then we know there's a significant problem.

See also https://sourceforge.net/forum/message.php?msg_id=4797822
_________________
OOo 3.2.1 on Slackware64 13.1 with Xfce desktop
Registry Workshop (SourceForge project, based on OOo Calc)
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> Setup and Troubleshooting All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group