OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Problem: Graphics (JPGs) in Writer

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
ruzz
General User
General User


Joined: 20 Mar 2008
Posts: 6
Location: UK

PostPosted: Thu Mar 20, 2008 12:36 am    Post subject: Problem: Graphics (JPGs) in Writer Reply with quote

Hi all

Why is it that some images are fully editable using the Filter dropdown on the popup Picture toolbar and others are not. For some reason, the Filter (icon == wizard's wand) is greyed out.

Fyi, I'm using OO 2.1 on XPsp2 and the images are all jpegs copy/pasted into writer.

Anyone shed any light on this?

TIA
ruzz
Back to top
View user's profile Send private message
Ewald
OOo Advocate
OOo Advocate


Joined: 16 Dec 2005
Posts: 392

PostPosted: Thu Mar 20, 2008 8:09 am    Post subject: Reply with quote

The reason might be that in some cases you select the picture, then the jpeg will be editable (wizards wand active) and in other cases you select the frame which is around the picture. In the latter case you won't be able to edit the picture since you have selected a frame and not the picture itsself.
Depending on the default settings (Tools>Options>OpenOffice.org Writer>Auto Caption) you might automatically insert a picture including a frame around it (if Auto Caption Picture is checked, then this happens).
Back to top
View user's profile Send private message
ruzz
General User
General User


Joined: 20 Mar 2008
Posts: 6
Location: UK

PostPosted: Fri Mar 21, 2008 2:31 am    Post subject: Reply with quote

Ewald wrote:
The reason might be that in some cases you select the picture, then the jpeg will be editable (wizards wand active) and in other cases you select the frame which is around the picture. In the latter case you won't be able to edit the picture since you have selected a frame and not the picture itsself.


thanks but, there is no frame. I certainly don't see "Frame" listed in the context menu. Is a frame automatically added to all pictures though?
Quote:

Depending on the default settings (Tools>Options>OpenOffice.org Writer>Auto Caption) you might automatically insert a picture including a frame around it (if Auto Caption Picture is checked, then this happens).


No, no captions added either.

What I have since discovered is that, copy/pasting seems to be the culprit. While drag/dropping directly from disk (well, win explorer) allows the pic to be fully editable, copy/paste from the clipboard does not. Here's what I was doing:

1. open image file using photoimpact editing software
2. do some editing/resizing whatever
3. in photoimpact, Edit/Copy
4. In Writer, position cursor to place I wanted the image pasted
5. Paste

any image placed like this has the Filter dropdown disabled.

Bug.
Back to top
View user's profile Send private message
Ewald
OOo Advocate
OOo Advocate


Joined: 16 Dec 2005
Posts: 392

PostPosted: Fri Mar 21, 2008 2:56 am    Post subject: Reply with quote

Well, in that case you probably inserted a GDI Metafile. Try to control your image format using "paste special" instead of "paste" and use either the bitmap format or the Star format.

Re Frame: a frame in the strict sense is created when you add a caption. However, the picture itsself is behaving like a frame too, you can modify anchoring, alignement etc. In that sense a frame is created whenever you insert a picture.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group