OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

[SOLVED] Table of Contents (TOC) saving as HTML

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
djlerman
General User
General User


Joined: 03 Mar 2008
Posts: 12
Location: Los Angeles, CA

PostPosted: Wed May 07, 2008 8:39 am    Post subject: [SOLVED] Table of Contents (TOC) saving as HTML Reply with quote

I have 2 files that I brought in from WORD.

1 file when I save as HTML (from OO) the TOC turns into links
the other file when I save as HTML (from OO) the TOC turns into static text.

Any suggestion on how to get the TOC to save as links all of the time..

The files are completely separate files. There is no connection between the files. I'm just using them as an example to show that the issue probably isn't with the Application settings it might be how the TOC is set up or a setting in the document itself.

They are being saved as HTML so that they can be uploaded to a wiki and the wiki requires either it's own markup language or HTML.

For the problem document. The TOC refreshes in both WORD and OO but the links only work when it is opened in OO.

This is what I'm trying to do.
- Open word sample.doc in OO
- save as HTML (with the TOC being live hyperlinks.)

For the problem document:
- the TOC refreshs ok in WORD and OO
- the TOC <ctrl>+<click> only works in WORD but not in OO
- the TOC exports to HTML with the TOC as hyperlinks in WORD but not OO

Problem document:
One straight from WORD: http://www.iqaat.com/tmp/word%20sample.doc
One saved in OO: http://www.iqaat.com/tmp/word%20sample.odt
One saved as HTML from OO: http://www.iqaat.com/tmp/word%20sample.html

Document with working toc:
Word: http://www.iqaat.com/tmp/word_sample_working_toc.doc
OO: http://www.iqaat.com/tmp/word_sample_working_toc.odt
HTML: http://www.iqaat.com/tmp/word_sample_working_toc.html

Thanks,
~Donavon


Last edited by djlerman on Thu May 08, 2008 8:14 am; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Wed May 07, 2008 1:37 pm    Post subject: Reply with quote

This has also been posted in the new forum: http://user.services.openoffice.org/en/forum/viewtopic.php?f=7&t=5524
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
djlerman
General User
General User


Joined: 03 Mar 2008
Posts: 12
Location: Los Angeles, CA

PostPosted: Wed May 07, 2008 2:33 pm    Post subject: Reply with quote

I didn't find a solution in that forum, so I thought posting in a more specific forum would yeld a result.
Back to top
View user's profile Send private message Visit poster's website
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Wed May 07, 2008 2:49 pm    Post subject: Reply with quote

The other one has a lot of dedicated users, and Hagar is very helpful. Just don't expect that people will give you the right hint in one go. (How often does that work in real life?) You may have to explain more, then after a few posts you may find the correct answer. The people in this forum now know that the rel discussion is going on somewhere else. Keep your questions coming. Wink
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
djlerman
General User
General User


Joined: 03 Mar 2008
Posts: 12
Location: Los Angeles, CA

PostPosted: Thu May 08, 2008 8:15 am    Post subject: Reply with quote

Solved here: Chapter headings missing in Navigator.
http://user.services.openoffice.org/en/forum/viewtopic.php?f=30&t=3531
Back to top
View user's profile Send private message Visit poster's website
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Thu May 08, 2008 8:28 am    Post subject: Reply with quote

That's the spirit! Very good! Very Happy
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group