OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Why does the spell checker only check Danish?

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
War
Guest





PostPosted: Sat Apr 10, 2004 11:11 am    Post subject: Why does the spell checker only check Danish? Reply with quote

Maybe someone can help
I have set all my defaults to English but whenever I open the tools-options-language settings-writing aids the spellchecker is ALWAYS on Danish. When I set it to english UK and close, the spell checker still does not work and when I go back into writing aids, the language is Danish again. I have only just downloaded v1.1.1.
Back to top
erikanderson3
OOo Advocate
OOo Advocate


Joined: 25 Feb 2004
Posts: 332
Location: San Francisco peninsula

PostPosted: Sun Apr 11, 2004 5:26 pm    Post subject: Reply with quote

Here's a thought:

Go to Tools -> Options -> Language Settings -> Writing Aids, and in the "Available language modules" listbox choose OpenOffice.org MySpell SpellChecker" and click Edit. A different dialog should pop up, with a listbox on top marked Language. Drop this down, and you should see a blue checkmark to the left of each spellcheck language you have installed. Selecting a language in this list will show you which components are installed (SpellChecker, Hyphenator, Thesaurus).

If English isn't installed, the spellchecker will likely default to whatever is higher up the list that is installed. Have a look at http://lingucomponent.openoffice.org/download_dictionary.html for spellcheck dictionaries in other languages.

Cheers,

Erik
Back to top
View user's profile Send private message
esperantisto
Super User
Super User


Joined: 26 Dec 2003
Posts: 779
Location: Belarus

PostPosted: Sun Apr 11, 2004 10:37 pm    Post subject: Reply with quote

You also may need to check dictioonary.lst file in <OOo Home> / share / dict / ooo folder. To enable UK English spellchecker, the file must contain a line "DICT en GB en_GB", and the folder must contain files en_GB.aff and en_GB.dic. In fact, all this should be by default, but you still should check.
Back to top
View user's profile Send private message
War
Guest





PostPosted: Tue Apr 13, 2004 12:43 am    Post subject: Reply with quote

I have tried/checked all those things. I tried deleting the Danish spellcheck in the ooo file and all that hapens is that there is now no spell checker. The ticks on teh left of the english modules do not seem to make any difference. I can't even select the US english module.
Back to top
erikanderson3
OOo Advocate
OOo Advocate


Joined: 25 Feb 2004
Posts: 332
Location: San Francisco peninsula

PostPosted: Tue Apr 13, 2004 1:01 am    Post subject: Reply with quote

Just in case it might shed some light on your symptoms, what is your OS?

Cheers,

Erik
Back to top
View user's profile Send private message
DaveQB
Power User
Power User


Joined: 17 Apr 2004
Posts: 50
Location: Sydney

PostPosted: Sat Apr 17, 2004 5:15 am    Post subject: Reply with quote

I just found my problem* was that a Read Only attribute was set on <OOo>/basic/user/script.xlc
That would do it !! Laughing


* couldnt set the default settings to English (Australia), had to reset them manually every OOo open Sad . But dictionary worked fine.
Back to top
View user's profile Send private message
dkam
Guest





PostPosted: Wed Apr 28, 2004 11:45 am    Post subject: Reply with quote

I'm having the exact same problem, but I haven't been able to solve it. What did you do exactly?

BTW, I'm using the Ximian patch set with 1.1.1 on Gentoo.
Back to top
DaveQB
Power User
Power User


Joined: 17 Apr 2004
Posts: 50
Location: Sydney

PostPosted: Wed Apr 28, 2004 4:56 pm    Post subject: Reply with quote

All i can say from my experience is check the write permissions on your user files; ones that save settings.

To install the dictionary of choice try the auto pilot autodownloader, that should work as well as manually doing it.
Back to top
View user's profile Send private message
dkam
Guest





PostPosted: Wed Apr 28, 2004 9:56 pm    Post subject: Reply with quote

Turns out, it was the font. I selected a different font, and away we went. The spell checker worked in English. However, the Danish dictionary was still selected in Writing aids. Weird huh?
Back to top
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group