OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Mixed Spell Dicts: Using Russian as third language

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
PeterBSchmidt
Guest





PostPosted: Wed Apr 21, 2004 2:12 am    Post subject: Mixed Spell Dicts: Using Russian as third language Reply with quote

Dear all,

I use OOo 1.1.0 german on my debian box and WinXP Laptop.

I tried to configure spelcheck for the languages
- german
- english (US)
- english (UK)
- russian

using the dictionary installer .swx. It said that it worked, but it only works for german and english. The russian stuff is completely mis-checked.
[x] I have read the readmes
[x] I have read the FAQs
[x] I have checked my config
[x] I have activated everything in "Extras..." and "Format ..." as stated
[x] I have even changed my default language in OOo (not in the OSes!)
[ ] I get a proper result.

Anyone who has a clue?

Yours,


Peter
Back to top
blabla
General User
General User


Joined: 24 Mar 2004
Posts: 40
Location: Munich, Germany

PostPosted: Wed Apr 21, 2004 5:40 am    Post subject: Reply with quote

Hi

sounds like you've been through more or less everything. Have you checked your dictionary.lst file to see whether the Russian files are properly listed?

Ingo
Back to top
View user's profile Send private message Visit poster's website
Guest






PostPosted: Wed Apr 21, 2004 7:30 am    Post subject: Reply with quote

Hello Ingo,

blabla wrote:

(snip..)
Have you checked your dictionary.lst file to see whether the Russian files are properly listed?

Ingo


yes. it says:
DICT ru RU ru_RU_ye
DICT ru RU ru_RU
HYPH ru RU hyph_ru_RU

amongst other stuff...

To almost every russian (cyrillic) word, it offers the German "Mazurka" as 'correction'

Bummer.

Yours, Peter
Back to top
Guest






PostPosted: Wed Apr 21, 2004 8:47 am    Post subject: Reply with quote

Peter,

bummer it is. But then OOo 1.1.0 displayed some "problematic" behaviour when it came to languages.

Only advice I can offer is to switch to OOo 1.1.1 as it appears to handle multiglots a lot better!

Ingo
Back to top
esperantisto
Super User
Super User


Joined: 26 Dec 2003
Posts: 779
Location: Belarus

PostPosted: Wed Apr 21, 2004 9:55 pm    Post subject: Reply with quote

I have several spellcheckers in OOo, I had them in 1.0.1, in 1.1 and in 1.1.1. There was a time when I had two concurrent spellcheckers for Russian (namely, ru_RU and ru_RU yo) without any problem (it had a funny effect - for a misspelled Russian word the spellchecker offered doubled right variants - obviously, from each dictionary). So, your problem lies somewhere else (maybe, you'd better give up one spellchecker - say, don't use ru_RU_ye, ru_RU alone is just enough).

1. Check the contents of your "<OOo home>/share/dict/ooo/". For the configuration given by you, the folder must contain ru_RU.dic and ru_RU.aff and ru_RU_ye.dic and ru_RU_ye.aff files with exactly that names.
2. Check your options for language tools, the spellchecker for Russian must be on.
3. Check you text. Is it really Russian (look at Format -> Character).
4. If didn't help, examine ru_RU.dic and ru_RU.aff and ru_RU_ye.dic and ru_RU_ye.aff. Each file in the .dic/.aff couple must be in the same encoding (they in fact are, unless you modified them). Also, check the contents of .dic files. Are they full, not blank or broken?
5. Instead of step 4, you can just download the files from http://lingucomponent.openoffice.org/download_dictionary.html, there they seem to be good (not sure about ru_RU_ye) and copy to the mentioned folder. Don't forget to restart OOo (including QuickStarter).
Back to top
View user's profile Send private message
PeterBSchmidt
Guest





PostPosted: Thu Apr 22, 2004 2:22 am    Post subject: Now it works! [was: Mixed spell dicts...] Reply with quote

Hello esperantisto,
esperantisto wrote:

(snip...)
4. If didn't help, examine ru_RU.dic and ru_RU.aff and ru_RU_ye.dic and ru_RU_ye.aff. Each file in the .dic/.aff couple must be in the same encoding (they in fact are, unless you modified them). Also, check the contents of .dic files. Are they full, not blank or broken?
(snap..)

Woah, that's it! By some strange reason, I found
- Some lines of the dictionary.lst were terminated with ^M, some were not
- ru_RU.dic was ISO8859-5, ru_RU_ye.dic was KOI8R
(they were remains of OOo 1.0, I guess)

So I reloaded both from the net, and adapted my dicitonary.lst to have every line in DOS style, and see, it *works*!

Many thanks to you and Ingo. I would have dropped my faith without you!

&#1073;&#1086;&#1083;&#1096;&#1072;&#1103; &#1089;&#1087;&#1072;&#1089;&#1080;&#1073;&#1086;!

See you,

Peter
Back to top
esperantisto
Super User
Super User


Joined: 26 Dec 2003
Posts: 779
Location: Belarus

PostPosted: Thu Apr 22, 2004 9:40 pm    Post subject: Reply with quote

You're welcome Smile
Back to top
View user's profile Send private message
Guest






PostPosted: Sat Apr 24, 2004 2:30 am    Post subject: Reply with quote

Hello everyone!

Your tips did help me to get the spellchecker going for German and English - thanks a lot!

Now, how do I mange to get both thesauri working? I did copy them into the right folder, I copied them into the dic.list so they should be loaded when OO starts, but the only thesaurus that works is the German one (I installed 1.1.1 in the German version). As I do write stories in both languages, I would appreciate using the thesaurus in both of them.

Thanks!

- Frauke
Back to top
esperantisto
Super User
Super User


Joined: 26 Dec 2003
Posts: 779
Location: Belarus

PostPosted: Thu Apr 29, 2004 9:25 pm    Post subject: Reply with quote

More details needed:
1) contents of your dictionary.lst
2) names of you thesaurus files

As for English thesaurus, dictionary.lst must contain the following line (assuming, it's US English):
THES en US th_en_US

and the following files must be in the dictionary folder:
th_en_US.dat
th_en_US.idx
Back to top
View user's profile Send private message
esperantisto
Super User
Super User


Joined: 26 Dec 2003
Posts: 779
Location: Belarus

PostPosted: Thu Apr 29, 2004 9:28 pm    Post subject: Reply with quote

And don't forget, your English text should be really English: Format -> Character
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group