OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

I'm an OO newbee, trying to add an action button to a spread

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Calc
View previous topic :: View next topic  
Author Message
Bill Fox
General User
General User


Joined: 18 Oct 2005
Posts: 15
Location: Edmonton

PostPosted: Fri Nov 21, 2008 3:14 pm    Post subject: I'm an OO newbee, trying to add an action button to a spread Reply with quote

I did a View/Tool Bar/Forms Control and selected a push button. According to the help the cursor should change to a cross hairs to select an area, but it stays as the arrow.

Also when I create a chart can I assign it a name, the application that I am trying to build will have about 15 different charts, each on a separate sheet, and need to create a button that will act select a range and assign it to an existing chart.

Any help would be appreciated. Confused
Back to top
View user's profile Send private message Visit poster's website
JohnV
Administrator
Administrator


Joined: 07 Mar 2003
Posts: 9183
Location: Lexinton, Kentucky, USA

PostPosted: Fri Nov 21, 2008 3:37 pm    Post subject: Reply with quote

Quote:
According to the help the cursor should change to a cross hairs to select an area, but it stays as the arrow.
Click and release then move into the document.
Back to top
View user's profile Send private message
Bill Fox
General User
General User


Joined: 18 Oct 2005
Posts: 15
Location: Edmonton

PostPosted: Fri Nov 21, 2008 7:51 pm    Post subject: Reply with quote

That still does not work. I'm trying to create a button on a spreadsheet, but when I click on the Push Button thenmove into the body of the spreadsheet it still stays as an arrow. This is a spreadsheet with te XLS extension does that make any difference?
Back to top
View user's profile Send private message Visit poster's website
JohnV
Administrator
Administrator


Joined: 07 Mar 2003
Posts: 9183
Location: Lexinton, Kentucky, USA

PostPosted: Sun Nov 23, 2008 9:50 am    Post subject: Reply with quote

Quote:
This is a spreadsheet with te XLS extension does that make any difference?
Don't know. Try it in a new spreadsheet.

Also let us know what OS & version of OOo you are using.
Back to top
View user's profile Send private message
Bill Fox
General User
General User


Joined: 18 Oct 2005
Posts: 15
Location: Edmonton

PostPosted: Mon Nov 24, 2008 8:05 am    Post subject: Reply with quote

I'm using 2.4 on XP Pro.

Last edited by Bill Fox on Tue Nov 25, 2008 7:53 am; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website
Rich102
Newbie
Newbie


Joined: 25 Nov 2008
Posts: 4

PostPosted: Tue Nov 25, 2008 2:19 am    Post subject: Reply with quote

Quote:
Try it in a new spreadsheet.


Had similar problem to Bill's, with a spreadsheet that had been migrated from Lotus 123 through Excel. Creating the button works fine in a new spreadsheet (the button icon is not greyed out as it was before, and I created a button successfully).

Now I'm trying to hook a macro up to the button, but the button doesn't seem to be active, even after associating the macro with it. (Properties >..., Assign action: select event >Macro... , Macro Selector: select macro >OK) If I right click on the button and then click on Control..., it shows that the macro is associated with the event. I've tried various events, but with no effect. For example, I've got my macro associated with "Mouse button pressed" and "Mouse button released", but when I click on the button, it gets overlaid with an anchor icon and 6 little green resizing markers, but the macro doesn't run. (The macro works fine when I do Tools>Macro>Run macro... or run it from the toolbar.)

Any suggestions?

Dick

XP SP2, OOo 3.0.0

[/quote]
Back to top
View user's profile Send private message
keme
Moderator
Moderator


Joined: 30 Aug 2004
Posts: 2910
Location: Egersund, Norway

PostPosted: Tue Nov 25, 2008 2:53 am    Post subject: Reply with quote

You must leave "design mode" to use the button. Use the pen/rulers icon on the form controls toolbar.
Back to top
View user's profile Send private message
Bill Fox
General User
General User


Joined: 18 Oct 2005
Posts: 15
Location: Edmonton

PostPosted: Wed Nov 26, 2008 8:58 am    Post subject: Reply with quote

I created a new Spreadsheet and nowI can create a button. Is there a problem creating a button in an XLS?
Back to top
View user's profile Send private message Visit poster's website
Rich102
Newbie
Newbie


Joined: 25 Nov 2008
Posts: 4

PostPosted: Sat Dec 13, 2008 2:35 am    Post subject: Reply with quote

Thanks for the quick response. Moving into and out of design mode makes several things make more sense. Sorry to bother you with a newbie question, but your reply was very helpful.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Calc All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group