OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

[Solved] OoO 3.1 how do I disable 'translucent drag' ?

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Draw
View previous topic :: View next topic  
Author Message
ehanuise
General User
General User


Joined: 26 Oct 2004
Posts: 21

PostPosted: Mon May 11, 2009 12:43 am    Post subject: [Solved] OoO 3.1 how do I disable 'translucent drag' ? Reply with quote

Hi all.
I just upgraded to 3.1 on my ubuntu notebook.
When opening draw documents that are the leas bit complex (a few shapes with tranparency and gradients), dragging them becomes so slow it's totally unuseable.
Nothing gets redrawn until I release the mouse button, then only a few seconds later the redraw occurs.
This makes it impossible to effectively modify the drawing Confused

I seached in the options, and found no obvious way to disable the translucent drag effect introduced in the new 3.1 release. Did I miss it somewhere ?

I also tried a quick drag-n-move as some drawing softwares that do translucent dragging do recognise this as a request to just move the object as an outline rather than a full rendition, but no success.

Any help or pointers'd be welcome Smile


Last edited by ehanuise on Thu May 14, 2009 7:51 am; edited 1 time in total
Back to top
View user's profile Send private message
roadbike1
General User
General User


Joined: 17 Apr 2009
Posts: 5

PostPosted: Mon May 11, 2009 7:36 pm    Post subject: Reply with quote

I'm having the same issue you are on XP SP3 and OOo 3.1. I have a feeling that this has something to do with anti-aliasisng that was implemented with 3.1.

I do agree, Draw has now become so slow to do simple things that it's almost unbearable and I'm considering reverting back to 3.0.
Back to top
View user's profile Send private message
ehanuise
General User
General User


Joined: 26 Oct 2004
Posts: 21

PostPosted: Tue May 12, 2009 1:25 am    Post subject: Reply with quote

There has to be a way to disable it somehow, anyone in the know ?
Back to top
View user's profile Send private message
ehanuise
General User
General User


Joined: 26 Oct 2004
Posts: 21

PostPosted: Thu May 14, 2009 7:50 am    Post subject: Reply with quote

I eventually emailed armin legrand, who provided me with the following info :

- antialiasing can be disabled in tools/options/view/enable antialiasing
- 'full drag' can be disabled in view/toolbars/options (last to next item)

However this ain't the cause of the slowness :p it's because somehow hardware acceleration of the rendering was not enabled.
Xrender acceleration must be present on the system and enabled in your X server (option "RenderAccel" in Nvidia xorg server), and you must use an OoO build that has hardware acceleration enabled (not grayed out in tools/options/view/hardware acceleration).
Apparently this ain't the case with the http://www.openoffice.org .debs :
[url]http://user.services.openoffice.org/en/forum/viewtopic.php?f=10&t=13180 [/url]

The openoffice.org-ogltrans package may also help with slow impress transitions Smile
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Draw All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group