OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Date changes and I don't want it to.

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Calc
View previous topic :: View next topic  
Author Message
PDA1
General User
General User


Joined: 02 Oct 2009
Posts: 42

PostPosted: Thu Dec 31, 2009 7:08 am    Post subject: Date changes and I don't want it to. Reply with quote

I work on a sheet and when I'm done I email it to myself so I can get access to it from anywhere.

When I download and open it the dates I've entered change. This time the year has changed to 2005 even though I had previously entered 2009.

How do I fix this problem?
Back to top
View user's profile Send private message
jrkrideau
Super User
Super User


Joined: 08 Aug 2005
Posts: 6732
Location: Kingston ON Canada

PostPosted: Thu Dec 31, 2009 7:10 am    Post subject: Re: Date changes and I don't want it to. Reply with quote

PDA1 wrote:
I work on a sheet and when I'm done I email it to myself so I can get access to it from anywhere.

When I download and open it the dates I've entered change. This time the year has changed to 2005 even though I had previously entered 2009.

How do I fix this problem?


What OS and version of OOo are you using?

How are you entering the dates?

Are the cells predefined as date fields?

Is there any chance that the locale is defined differently on different computers?
_________________
jrkrideau
Kingston ON Canada
Currently using Windows 7 & OOo 3.4.0 and Ubuntu 12.04 & LibreOffice 3.5.2.2
Back to top
View user's profile Send private message
PDA1
General User
General User


Joined: 02 Oct 2009
Posts: 42

PostPosted: Thu Dec 31, 2009 7:36 am    Post subject: Re: Date changes and I don't want it to. Reply with quote

What OS and version of OOo are you using?

OS- Linux (ubuntu)
Oo- 3.1.1

How are you entering the dates?

With my keyboard- date format is defined as MM DD YYYY

I enter date like this- 12/31/2009 In fact I just entered 12/31/2009, saved the file, closed it and then opened it again only to find it read 12/30/2009. No, I didn't errantly enter 12/30. Geez, I just re-entered a date, came back to this page, went back to the sheet and it had changed to 12/3/1985. No, I'm not crazy!

Are the cells predefined as date fields?

I don't know how to do that. All I do is select the cell, right click and choose "format cells" and select the DATE stuff.

Is there any chance that the locale is defined differently on different computers?[/quote]

I don't know what locale is.
Back to top
View user's profile Send private message
jrkrideau
Super User
Super User


Joined: 08 Aug 2005
Posts: 6732
Location: Kingston ON Canada

PostPosted: Thu Dec 31, 2009 8:00 am    Post subject: Re: Date changes and I don't want it to. Reply with quote

PDA1 wrote:
What OS and version of OOo are you using?

OS- Linux (ubuntu)
Oo- 3.1.1


Is this the version that ships with Ubuntu or is it the one downloaded from the official OOo page? There are differences and people sometimes have a problem with the Ubuntu version but I have not heard anything like this.

How are you entering the dates?

Quote:
With my keyboard- date format is defined as MM DD YYYY

I enter date like this- 12/31/2009 In fact I just entered 12/31/2009, saved the file, closed it and then opened it again only to find it read 12/30/2009. No, I didn't errantly enter 12/30. Geez, I just re-entered a date, came back to this page, went back to the sheet and it had changed to 12/3/1985. No, I'm not crazy!


Is this a new installation? If so, I'd chalk it up to a bad installation and reintalll or run a repair and see what happens. If you are using the Ubuntu OOo try the official OOo at http://www.openoffice.org/

I tried playing around with dates and changing locales but don't see anything that would change 12/31/2009 to 12/3/1985 right off-hand.


Are the cells predefined as date fields?

Quote:
I don't know how to do that. All I do is select the cell, right click and choose "format cells" and select the DATE stuff.


Before you enter the number? If so that's preformatting. You can also do the same using the Format > Cells approach.

Is there any chance that the locale is defined differently on different computers?

Quote:
I don't know what locale is.


OOo, especially Calc makes some assumptions about the way you want things formatted based on where it thinks you live (i.e what your locale is. )

For example I live in Canada and normally would format dates as DD/MM/YY not MM/DD/YY. Most Europeans would write one thousand five hundred and thirty as 1.530 whereas most or all English speakers would write 1,530.

Your locale setting handles all this automatically but it also can be a pain.

If you want to play around with locale settings, different dictionaries etc go

Tools > Options > Language Settings Languages
_________________
jrkrideau
Kingston ON Canada
Currently using Windows 7 & OOo 3.4.0 and Ubuntu 12.04 & LibreOffice 3.5.2.2
Back to top
View user's profile Send private message
PDA1
General User
General User


Joined: 02 Oct 2009
Posts: 42

PostPosted: Thu Dec 31, 2009 8:37 am    Post subject: Getting new copy Reply with quote

I'm downloading and will install a new clean version of Oo.

I just re-opened the sheet I'm working on and the dates were changed to 1973.

Great.

Well, I'll let you know what happens.
Back to top
View user's profile Send private message
jrkrideau
Super User
Super User


Joined: 08 Aug 2005
Posts: 6732
Location: Kingston ON Canada

PostPosted: Thu Dec 31, 2009 9:48 am    Post subject: Re: Getting new copy Reply with quote

PDA1 wrote:
I'm downloading and will install a new clean version of Oo.

I just re-opened the sheet I'm working on and the dates were changed to 1973.

Great.

Well, I'll let you know what happens.


Good luck
I thnk OOo can handle dates to at least the 18th Century so you have a way to go yet.

It's one weird problem.
_________________
jrkrideau
Kingston ON Canada
Currently using Windows 7 & OOo 3.4.0 and Ubuntu 12.04 & LibreOffice 3.5.2.2
Back to top
View user's profile Send private message
Villeroy
Super User
Super User


Joined: 04 Oct 2004
Posts: 10106
Location: Germany

PostPosted: Mon Jan 04, 2010 11:08 am    Post subject: Reply with quote

No matter what version, locale or whatever could be involved. A date is really nothing but a number displayed in a sprecial way. Believe me, your spreadsheet does not have a single date value.

All numbers can be formatted to show a date and all dates can be formatted to show the underlying number. All spreadsheet contents are numbers unless they are text. Errors may yield errors as a third type.

A number formatted as date is interpreted as a day number since 1899-12-30. Put a zero in a cell and format. Do the same with =PI() and some date-time format. Simply try out: 2009-July-6 was day number 40000. How exactly some number is displayed as date may depend on the application locale if (and only if) the cells locale is not set (Default). The locale determines also how your input is interpreted (mostly DD/MM/YY or MM/DD/YY, YYYY/MM/DD always works the same).

No formatting, no locale, nothing will ever modify a cell's value. You, the user, are the only one to edit or import your data or manipulate them using the find&replace tool.

Regarding dates, the zero-day setting in the options influences which day is treated as day zero when displaying numbers as dates, but this won't change your cell values neither. It can help in some very rare cases when day numbers have to be imported from certain applications (Excel is compatible with the default setting).

Unlike Excel, Calc suports historic dates back until year one B.C. Most date related functions however expect a Gregorian date >=1582/Oct/15
_________________
Rest in peace, oooforum.org
Get help on https://forum.openoffice.org
Back to top
View user's profile Send private message
Villeroy
Super User
Super User


Joined: 04 Oct 2004
Posts: 10106
Location: Germany

PostPosted: Tue Jan 05, 2010 9:19 am    Post subject: Reply with quote

Silence?
Any numbers to offer?
Any document to download?
No?
Got it working?
What was the matter?
_________________
Rest in peace, oooforum.org
Get help on https://forum.openoffice.org
Back to top
View user's profile Send private message
jbbrwcky
Newbie
Newbie


Joined: 13 Jan 2010
Posts: 4

PostPosted: Wed Jan 13, 2010 6:22 am    Post subject: Reply with quote

I am experiencing the same issue, except my dates change when I sort the column.

I'm using OOo 3.1.1 on Windows 7, UK language, UK date format.

Richard
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Calc All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group