OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

LanguageTool Grammar check Installation Problems

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
raviteja
General User
General User


Joined: 11 Feb 2010
Posts: 13

PostPosted: Fri Feb 12, 2010 9:18 am    Post subject: LanguageTool Grammar check Installation Problems Reply with quote

Does anybody able to make LanguageTool Grammar check extension work ?

My Configuration:
WIndows Vista Home premium
Java 6 Update 18
Open Office Version 3.1.1
LanguageTool Version 1.0.0

I am trying to install language tool using Tools-> Extension Manager but while installing it gives me java runtime exceptions
Nullpointer exception
Failed to load rules.

Anybody has any ideas to fix this. Pls help.
Back to top
View user's profile Send private message Send e-mail
peterroots
Super User
Super User


Joined: 01 Nov 2006
Posts: 591
Location: United Kingdom

PostPosted: Fri Feb 12, 2010 10:17 am    Post subject: Reply with quote

In tools>options>java is your installed java runtime selected? Is it the latest of the updates you have installed? (assuming you have older versions present as well)
I just tried to download and install the grammar addon and it worked fine under the linux version of ooo3.1 with sun java 6 (1.6.0_15)
Do you have any other version of java installed other than the sun java6?
_________________
Kubuntu 11.10 LibreOffice3.4.4
Back to top
View user's profile Send private message
raviteja
General User
General User


Joined: 11 Feb 2010
Posts: 13

PostPosted: Fri Feb 12, 2010 10:35 am    Post subject: Reply with quote

Oh i missed this one. In Tools -> options -> Java was not selected.

I selected java and reinstalled it and it did install fine this time. But, again those error/exception messages keep popping up whenever i try to type something in the document.

No. I dont have any other versions installed.

Any more ideas ?
Back to top
View user's profile Send private message Send e-mail
peterroots
Super User
Super User


Joined: 01 Nov 2006
Posts: 591
Location: United Kingdom

PostPosted: Fri Feb 12, 2010 10:46 am    Post subject: Reply with quote

Sorry, no - that was the most obvious reason for things not working, if that was not it I am out of ideas.
_________________
Kubuntu 11.10 LibreOffice3.4.4
Back to top
View user's profile Send private message
raviteja
General User
General User


Joined: 11 Feb 2010
Posts: 13

PostPosted: Fri Feb 12, 2010 11:09 am    Post subject: Reply with quote

It is great input from you for the last two days. Thanks. I reall appreciate your help.

Let me figure out this issue myself.
Back to top
View user's profile Send private message Send e-mail
ChristopherPovey
General User
General User


Joined: 20 Feb 2010
Posts: 6

PostPosted: Sat Feb 20, 2010 8:18 am    Post subject: Reply with quote

Did you ever fix this problem as I get Java runtime errors whenever I type something or select Configure option in the menu?

Running:

Window XP Pro SP3
Java 6 Update 18.
OpenOffice Version 3.1.1. (Build: 9420)
LanguageTool Version 1.0.0

I have searched the web and the Java runtime engine is selected in options...Java.

I have also tried the delete: C:\Documents and Settings\<user>\Application Data\OpenOffice.org\3\user\config\javasettings_Windows_x86.xml fix.

Thanks.
_________________
Chris
Back to top
View user's profile Send private message
raviteja
General User
General User


Joined: 11 Feb 2010
Posts: 13

PostPosted: Sun Feb 21, 2010 12:32 pm    Post subject: Reply with quote

Yes. I did. I sent a mail to David (i guess he is the father of LanguageTool) and he did fix the problem by sending a fix for me but it is a development version. I will share it with you when i get home. i am in plane right now.

Thanks
-ravi
Back to top
View user's profile Send private message Send e-mail
ChristopherPovey
General User
General User


Joined: 20 Feb 2010
Posts: 6

PostPosted: Mon Feb 22, 2010 11:30 am    Post subject: Reply with quote

He picked up my error off the Extensions page and sent me 1.0.1 dev version. Though it did fix the Java issues it still did not work correctly.

Every so often when I started Writer it locked up. I had to kill SOffice.Exe and bin in the Task Manager.

When selecting the "ABC" with the Blue tick, sometimes LanguageTool did the checking other times the Writer Spell Checker ran.

Also the following sentence is fine, apparently: "I now I installed it correctly." Sad

I'll wait for version 2. Wink
_________________
Chris
Back to top
View user's profile Send private message
jrkrideau
Super User
Super User


Joined: 08 Aug 2005
Posts: 6732
Location: Kingston ON Canada

PostPosted: Mon Feb 22, 2010 11:36 am    Post subject: Reply with quote

Indeed, it should read, "I, now I installed it correctly!"
_________________
jrkrideau
Kingston ON Canada
Currently using Windows 7 & OOo 3.4.0 and Ubuntu 12.04 & LibreOffice 3.5.2.2
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group