OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

OpenOffice Writer v3.1.1 Network Printing Problem

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
SnakeEyedMojo
Newbie
Newbie


Joined: 19 Feb 2010
Posts: 2
Location: Allentown, Pennsylvania USA

PostPosted: Sat Feb 20, 2010 3:34 pm    Post subject: OpenOffice Writer v3.1.1 Network Printing Problem Reply with quote

I've searched the forums for a problem similar to the one I'm experiencing but, if a thread exists, I haven't found it.

First, the set-up...
1. I'm testing OOo v3.1.1 for use on my corporate domain. A "typical" OOo configuration with JRE has been installed on two test workstations by the domain administrator (me).
2. "Anyone who uses this workstation" was selected during the install.
3. Both Windows XP Pro SP3 workstations completed the installation without an error or warning.
4. Two test users accounts on the domain were created. Both users are members of the "Domain Users" group. Neither have "elevated" priviledges of any kind.
5. Neither user has a "Local Computer User" account meaning, if either user cannot log on or authenticate through the domain, they cannot log on or use the workstation. This is the typical security method that is used throughout the company.
6. Both test users have been granted "Print" and "Manage Print Documents" on a Windows Server 2003 shared printer. These privileges have been given to all members of the "Domain Users" group (of which both test users are members).
7. Both test users can access multiple domain applications. Both can print from all these applications without difficulty.

And now, the problem...
8. If either test user opens an existing 3.1.1 Writer document or creates a new document and attempts to print it, the following things happen:
- A message briefly displays stating that the document has been sent to the printer.
- Writer displays a message stating that an unknown error has occurred.
- Writer then shuts down and re-opens.
- During the restart Writer attempts to recover the document.
9. No errors or warnings appear in the XP Event Log related to the print issue.
10. This happens consistently.

If I add either user to the "Domain Admins" group (on the workstation, not through the domain controller), log on as the user, and perform the test print steps noted above, I have no problems whatsoever.
I have tried various configuration tweaks but the only consistent solution is to give the test users elevated security permissions. This is not an option due to the corporate security policy.
Writer (and presumably Calc, Impress, etc.) is the only program with this problem printing to a server-based shared printer.
I've been trying to resolve this problem for the better part of a week. Any assistance or suggestions you can provide is greatly appreciated.
Back to top
View user's profile Send private message
SnakeEyedMojo
Newbie
Newbie


Joined: 19 Feb 2010
Posts: 2
Location: Allentown, Pennsylvania USA

PostPosted: Sun Feb 21, 2010 8:16 am    Post subject: OpenOffice Writer v3.1.1 Network Printing Problem - REV 2 Reply with quote

Let me ask this a different way:
Is anyone currently using Writer v3.1.1 on a network and successfully printing to a shared network printer?
If so, do you have elevated security permissions on the workstation, the server, or the domain?
This is a migration stopper for me if the users can't print to a shared network printer.

And riddle me this:
I have a department of 32 domain workstations that have been running OOo v2.4 (Writer and Calc) for over 18 months. The users of these PCs are all members of the "Domain Users" group with NO elevated security rights (identical to my test users) and have not experienced any problems with printing to a network printer.
How can v2.4 work properly but v3.1.1 not?
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group