OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Switch Board thinks the DB is not registered.

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Base
View previous topic :: View next topic  
Author Message
flyfishing48
General User
General User


Joined: 14 Mar 2010
Posts: 6
Location: Michigan, USA

PostPosted: Thu Mar 18, 2010 1:34 pm    Post subject: Switch Board thinks the DB is not registered. Reply with quote

I have a switchboard that I want to edit. When I try to use the wizzard it tells me the database is not registered. I go through the registration process again, but get the same results. I have been using this switchboard and have it 1/2 done.
Whats up with the registration.
I use Neo Office 3.02 and have the latest version of switchboard.
_________________
Tom
Back to top
View user's profile Send private message
QuazzieEvil
Super User
Super User


Joined: 17 Jan 2007
Posts: 599
Location: Houston, TX

PostPosted: Fri Mar 19, 2010 5:16 am    Post subject: Reply with quote

what is the name of your database (file and registration name). it tends to get confused if the database name has '.' in addition to the extension part.

For Example: DB.V1.odb
Change it to [b]DBV1 or DDB_V1,, or anything simularly suitable.

If that is not the problem, What DB engine are you using ? native/built-in HSQL? or something else such as MySQL, PostgreSQL, etc?
_________________
Free Docs @ http://www.baseprogramming.com/resources.html
Book @ lulu.com http://www.lulu.com/content/2455551
Back to top
View user's profile Send private message Visit poster's website
flyfishing48
General User
General User


Joined: 14 Mar 2010
Posts: 6
Location: Michigan, USA

PostPosted: Fri Mar 19, 2010 8:08 am    Post subject: Thanks Reply with quote

Thanks for the reply and thanks for the naming tip. My database is named and registered as Race Database 2010.odb
I did get it to recognize it by deleting all of the databases from the registry and re registering them.
If it gives me any more trouble I will rename it according to your suggestion.
Thanks again.
_________________
Tom
Back to top
View user's profile Send private message
flyfishing48
General User
General User


Joined: 14 Mar 2010
Posts: 6
Location: Michigan, USA

PostPosted: Fri Mar 19, 2010 10:38 am    Post subject: Still having issues Reply with quote

The switchboard still is not seeing the registration. I have got it to work a few times by deleting the registration and then re registering the database. My current name is racedb.odb
At the moment I get back into the wizard to edit.
I am using HSQL in Neo Office on a Mac. I had the same issues when I used Open Office, plus a hand full of others. Neo Office has ben more stable for me, but the switchboard issue is still there.
If I get it to work, it seems to be fine until I close the program. When I open it back up, the registration is not recognized.
_________________
Tom
Back to top
View user's profile Send private message
flyfishing48
General User
General User


Joined: 14 Mar 2010
Posts: 6
Location: Michigan, USA

PostPosted: Fri Mar 19, 2010 12:20 pm    Post subject: Works on my XP machine Reply with quote

I copied the database to a stick and then put it on the desktop of my old windows XP laptop.
Seems to work fine there. Using Open Office 3.02 , I opened and edited twice, closed and reopened the program and still opens the switchboard wizard fine.
Wonder if it's a connection issue. I don't have drivers pooled enabled on either machine.
Any thoughts?
_________________
Tom
Back to top
View user's profile Send private message
QuazzieEvil
Super User
Super User


Joined: 17 Jan 2007
Posts: 599
Location: Houston, TX

PostPosted: Fri Mar 19, 2010 5:11 pm    Post subject: Reply with quote

I have not tested it on Neo Office, so I cannot say what is going on. I will let you know if I find something.
_________________
Free Docs @ http://www.baseprogramming.com/resources.html
Book @ lulu.com http://www.lulu.com/content/2455551
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Base All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group