OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

[SOLVED] Could not create java implementation loader

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Base
View previous topic :: View next topic  
Author Message
Ghostdreamer
Newbie
Newbie


Joined: 11 Feb 2011
Posts: 3

PostPosted: Fri Feb 11, 2011 3:48 pm    Post subject: [SOLVED] Could not create java implementation loader Reply with quote

Trying to install the extension Oracle Report Builder. I had just installed it ~1 week ago, but reformmated my computer.

I'm running Windows 7, I do have JRE v 6 update 23, and have uninstalled and reinstalled just to make sure that wasn't my problem. As I said I had JUST downloaded and successfully installed this extension less than a week ago, but for some reason now it will not take.

I get "Could not create Java Implementation Loader" when i try and add the extension (Tools > Extension Manager > Add)

Then, I try and install it again and get

"You are about to install version 1.2.1 of the extension 'Oracle Report Builder'.
That Version is already installed.
Click 'OK' to replace the installed extention.
Click 'Cancel' to stop the installation."

In the extention veiwer itself it does not show the extension as installed, nor can I use it under the Reports section.

I had rebooted my computer, thinking maybe it was just a bug, and it does show it as being installed, though it says that it is unknown, and is disabled. I tried to enabled it and just got the "Could not create Java Implementation Loader" error again.

I have also tried opening Tools/Options/OpenOffice.org/Java and unchecking the "use a Java runtime enviornment"

I Have also tried Opening Tools/Options/OpenOffice.org/Java , making sure that my Sun Microsystems Inc. 1.6.0_023" is clicked in, checking the "use a Java runtime enviornment"

I have also right-clicked on the program and ran as administrator.

I appreciate any help you guys give,

Thanks.


Last edited by Ghostdreamer on Tue Feb 15, 2011 12:38 pm; edited 1 time in total
Back to top
View user's profile Send private message
dacm
Super User
Super User


Joined: 07 Jan 2010
Posts: 769

PostPosted: Fri Feb 11, 2011 9:22 pm    Post subject: Reply with quote

Welcome Ghostdreamer Very Happy

I don't know...

Try this extension uninstall technique.

Try resetting your OOo user profile.

Finally, try the extension with OpenOfficePortable or LibreOffice Portable & JavaPortable.
_________________
Soli Deo gloria
Tutorial: avoiding data loss with Base + Splitting 'Embedded databases'
Back to top
View user's profile Send private message
mrbean123
Newbie
Newbie


Joined: 12 Feb 2011
Posts: 3

PostPosted: Sat Feb 12, 2011 4:21 am    Post subject: Same problem...different extension Reply with quote

Hi, I get the exact same behavior from trying to install the "flash cards" extension from sourceforge. I have installed other extensions up till now just fine, like PDF editor.

openoffice extension manager: could not create java implementation loader

Tools -> Options ->OpenOffice.org -> Java -> Use a Java runtime environment is checked
Sun Microsystems Inc. 1.6.0_23 is highlighted


Any further ideas on this?

Thanks


Rolling Eyes
Back to top
View user's profile Send private message
Ghostdreamer
Newbie
Newbie


Joined: 11 Feb 2011
Posts: 3

PostPosted: Sat Feb 12, 2011 2:09 pm    Post subject: Re Reply with quote

Alright, I tried the extension Uninstall Technique and that did not fix the problem.

Following the resetting of my OOo user profile, the \user folder is no where to be seen, I searched everything inside the OpenOffice folder installed in my program files and could not find it for the life of me.

In Lieu of that, I uninstalled completely, wiping everything to do with it off my laptop, reinstalled, same error.

I also uninstalled Java again and reinstalled just hoping, but again no progress.

As of right now I have not tried out the Portable option, as I have nothing to put it on other than the laptop itself, and that seems to defeat the purpose

I appreciate your help!
Back to top
View user's profile Send private message
Sliderule
Super User
Super User


Joined: 29 May 2004
Posts: 2499
Location: 3rd Rock From The Sun

PostPosted: Sat Feb 12, 2011 2:23 pm    Post subject: Reply with quote

Do I know if this will work for you . . . NO I do not.

But, I am using OpenOffice with the 'official' Java included in the OpenOffice 3.3 download package . . 1.6.0_22 . . . not the newer version you mentioned above as 1.6.0_23 .

Everthing works for me, yes I know, infamous last words.

I wonder, but do not know if you were to use the previous version of Java . . . if it might resolve your issue.

You can get a 32 bit Windows Java runtime environment 1.6.0.22 (32-bi from the Download This Version hotspot in the upper right corner:

http://www.filehippo.com/download_jre_32/8505/

Again, I do NOT know if this is the problem, but, it might be worth a try.

Please be sure to let me / us know if this helps.

Sliderule

Thanks to add [Solved] in your first post Title ( edit button ) if your issue has been fixed / resolved.
Back to top
View user's profile Send private message
Ghostdreamer
Newbie
Newbie


Joined: 11 Feb 2011
Posts: 3

PostPosted: Tue Feb 15, 2011 12:37 pm    Post subject: Reply with quote

Alright! So, three reinstalls of OpenOffice AND of the extension later, I finally got it to work. I have no idea what exactly did the trick I have changed nothing on my computer, but after reinstalling each time I tried to get the extension to work with the use JRE checked, and .23 click on, as well as .22 click on, and tried to get it to work without the use JRE checked. Repeating this three times and as of right now, with JRE + .22 checked, it finally pushed it through. I appreciate the help, and hope anyone else with this problem can find an easier fix hehe Smile
Back to top
View user's profile Send private message
mrbean123
Newbie
Newbie


Joined: 12 Feb 2011
Posts: 3

PostPosted: Tue Feb 15, 2011 12:59 pm    Post subject: I'm glad its working for you but... Reply with quote

I don't plan on uninstalling / reinstalling the the whole suite even once, let alone a number of times!

I've noticed some other people have had this same error message over the years with various success on working around it.

A little unnerving but I guess I'll just live without this particular extension until a solution presents itself.


Regards,

mrbean
Back to top
View user's profile Send private message
thedan
General User
General User


Joined: 02 Aug 2009
Posts: 6

PostPosted: Tue Feb 22, 2011 6:29 pm    Post subject: Could not create Java implementation loader Reply with quote

I am having this same problem. Driving me nuts. I have two identical Toshiba Salellite laptops ordered four months apart. Report Builder extension works on one but the other. Let me add my "Please help." to the list. I tried everything listed in the forum to no avail.
Back to top
View user's profile Send private message
wdonne
General User
General User


Joined: 10 Sep 2008
Posts: 14

PostPosted: Fri Mar 04, 2011 6:43 am    Post subject: Reply with quote

I have the same issue with the ODFToEPub extension. I reinstalled OOo 3.3 and made sure the JRE that comes with it was installed. Now that JRE is selected and it still doesn't work, also not after a restart of OOo.

Best regards,

Werner.
Back to top
View user's profile Send private message
yuko_gfu
General User
General User


Joined: 29 Mar 2011
Posts: 5
Location: Spain

PostPosted: Tue Apr 12, 2011 6:58 am    Post subject: Reply with quote

Hello

I have the same problem in Win. In Ubuntu it works right, but in Windows that error is raised.
I have tried all workarounds commented in this post and in this page:
http://wiki.services.openoffice.org/wiki/Extensions_trouble_shooting

But there's no way.....
Back to top
View user's profile Send private message
m0hn
Newbie
Newbie


Joined: 09 May 2011
Posts: 1

PostPosted: Mon May 09, 2011 8:08 pm    Post subject: Reply with quote

Sliderule wrote:

Thanks to add [Solved] in your first post Title ( edit button ) if your issue has been fixed / resolved.


it's not work Sad
I use Windows 7 x64, LibreOffice 3.3.2 java 6 update 25
I tried java 18, 22
I tried OpenOffice.org pro, portable...
I tried run as Administrator...
I tried many solution...

"Could not create java implementation loader"

I don't understand what need?
Back to top
View user's profile Send private message
BillllySamotar
Newbie
Newbie


Joined: 12 Sep 2011
Posts: 2

PostPosted: Mon Sep 12, 2011 10:25 pm    Post subject: SOLVED - really with Windows 7 and OpenOffice3.3.0 Reply with quote

Really final:
1) Install Java JRE (now 1.27)
2) Install OpenOffice 3.2
3) On the top of the /Tools / Options / .... / Java -> check box at the top to "Use a Java runtime environment"
4) Install Oracle Report Builder 1.2.1 to rev 2
5) Install OpenOffice 3.3.0 (no uninstall v 3.2)
6) Run Oo - check "Oracle Report Builder 1.2.1 to rev 2" -> Run
Finish. All good.

My OS Windows 7, Java JRE_1.27, OpenOffice 3.3.0 and Oracle Report Builder 1.2.1 to rev 2 -> ready all.
_________________
OS Windows XP, Open Office 3.3.0
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Base All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group