OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Problem with NetBeans.

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> Setup and Troubleshooting
View previous topic :: View next topic  
Author Message
satabau
General User
General User


Joined: 12 Mar 2012
Posts: 34

PostPosted: Mon Mar 12, 2012 4:47 pm    Post subject: Problem with NetBeans. Reply with quote

Hi, I'm new and I hope this topic doesn't already exist. I'll try to be clear but english is not my language. I use NetBeans 6.8 because I need to implement an extension of OpenOffice calc but the newer versions of NetBeans don't have the OpenOffice plugins in the download list.
I tried with 7.1.1 but to install the plugin, other plugins (that I can't find!!) are required.
I downloaded OpenOffice from the site and the version should be the 3.3.
In NetBeans I followed: New Project->OpenOffice.org->OpenOffice.org calc Add-in.
I left the default names of Project, Calc add-in, package, Location, Folder and function1.
I searched that function1 and I noticed that always returns 0. (obviously it's just for try).
Practically I followed this: http://wiki.services.openoffice.org/wiki/OpenOffice_Calc_Add-In_Project_Type
Finally I clicked on "Deploy and run extension in OpenOffice.org" but OO gave me this error: "could not create java implementation loader". I searched on internet to solve the problem and I found something like this: <<untick the check box at the top to "Use a Java runtime environment". You may need to restart OpenOffice (including Quickstarter) to be sure that this has taken>>. But it didn't work. Can anyone help me please? Step by step because I don't have experience with OO at all. Thank you.
Back to top
View user's profile Send private message
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Mon Mar 12, 2012 10:24 pm    Post subject: Reply with quote

Java should be enabled in OOo, I think, but you have to make sure that you have the correct version of Java - so far OOo doesn't support Java 7.x and on Windows you have to use a 32 bits version of Java.
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
satabau
General User
General User


Joined: 12 Mar 2012
Posts: 34

PostPosted: Tue Mar 13, 2012 2:37 am    Post subject: Reply with quote

On OO (tools->options->java) there is "use JRE" and I have two versions:
1.6.0_31 and 1.6.0_22. I tried with both but I have the same problem. Are they 32bit versions? And are they supported by OO? Thanks
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> Setup and Troubleshooting All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group