OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

RTF saving has issue in saving Latin1 characters

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
Chaitanya
Newbie
Newbie


Joined: 11 Apr 2012
Posts: 3

PostPosted: Wed Apr 11, 2012 10:43 am    Post subject: RTF saving has issue in saving Latin1 characters Reply with quote

Hi,

In Open Office 3.2 windows version, I observed issue in RTF file.
You may open Open Office writer and copy -paste this string -- šbkeâ}sKeve
(Note - this is not garbage data but meaningful asian word if used with monolingual font - APS-DV-PRAKASH)
Then save the file as RTF and check the RTF code using any notepad application.

It saves the non english characters as unicode values and HEX code in following fashion
For character š - RTF file code shows - \u353\'3f
For character â - RTF code shows - \u226\'3f
Like this for every special character the unicode value is correct but for each such character HEX code is incorrect and that is - \'3f for every special character.

Same string is stored in AbiWord shows proper HEX values-
For character š - RTF file code shows - \u353\'9a
For character â - RTF code shows - \u226\'e2
Which are correct as per wiki link.
http://en.wikipedia.org/wiki/Windows-1252

This does not give any issue in rendering the string in Open Office writer but if this file is used in other programs which strictly uses HEX values, we hit with issue. (Anyways incorrect HEX values is definitely an issue!)
_________________
Thanks,
Chaitanya
Back to top
View user's profile Send private message
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Wed Apr 11, 2012 11:57 am    Post subject: Reply with quote

RTF support in OOo is notoriously bad. You might report this at the developers' mailing list (http://incubator.apache.org/openofficeorg/mailing-lists.html#development-mailing-list) or report a bug ([Tutorial] Reporting bugs or suggestions ).
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
Chaitanya
Newbie
Newbie


Joined: 11 Apr 2012
Posts: 3

PostPosted: Thu Apr 12, 2012 2:15 am    Post subject: Reported as said Reply with quote

Hi,

I have reported the bug with id - 119219
https://issues.apache.org/ooo/show_bug.cgi?id=119219
_________________
Thanks,
Chaitanya
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group