OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

[SOLVED] Document is being re-formatted on save

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
lknoll
General User
General User


Joined: 19 Oct 2011
Posts: 32
Location: Harrisburg, Pa

PostPosted: Mon Apr 30, 2012 8:55 am    Post subject: [SOLVED] Document is being re-formatted on save Reply with quote

I am using open office version 3.3.0 on windows 7 professional.

The problem I am having is I have a document with 180 pages, when I perform a save as on this document, then close it, then re-open the newly saved document, it now has 181 pages. It appears that OpenOffice is re-formatting the document. The document I am working with does contain tables, I think this may have something to do with it. Is there a setting that would prevent this from happening?

Thanks,
Lee.


Last edited by lknoll on Thu May 24, 2012 5:26 am; edited 1 time in total
Back to top
View user's profile Send private message
lknoll
General User
General User


Joined: 19 Oct 2011
Posts: 32
Location: Harrisburg, Pa

PostPosted: Mon Apr 30, 2012 10:08 am    Post subject: Reply with quote

I compared the styles of the two documents and the original sets a rel-column-width and the newly saved document has a rel-column-width and also a column-width property set.
Back to top
View user's profile Send private message
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Mon Apr 30, 2012 10:45 am    Post subject: Reply with quote

Are you saving in .doc format? If so, try saving as .odt.
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
jrkrideau
Super User
Super User


Joined: 08 Aug 2005
Posts: 6732
Location: Kingston ON Canada

PostPosted: Mon Apr 30, 2012 10:46 am    Post subject: Re: Document is being re-formatted on save Reply with quote

lknoll wrote:
I am using open office version 3.3.0 on windows 7 professional.

The problem I am having is I have a document with 180 pages, when I perform a save as on this document, then close it, then re-open the newly saved document, it now has 181 pages. It appears that OpenOffice is re-formatting the document. The document I am working with does contain tables, I think this may have something to do with it. Is there a setting that would prevent this from happening?

Thanks,
Lee.


What OS and version of OOo/LO?
Are you saving as as OOo file
Was the file created as an odt file?
_________________
jrkrideau
Kingston ON Canada
Currently using Windows 7 & OOo 3.4.0 and Ubuntu 12.04 & LibreOffice 3.5.2.2
Back to top
View user's profile Send private message
lknoll
General User
General User


Joined: 19 Oct 2011
Posts: 32
Location: Harrisburg, Pa

PostPosted: Mon Apr 30, 2012 10:57 am    Post subject: Reply with quote

OO 3.3.0
Windows 7
Its an odt file being saved as an odt file.

The original odt document is the product of an odt template being inserted into another odt document by extracting the content xml using coldfusion. This original document is never saved using OO, but rather programmatically written to a location.

When this document is saved using OO, the problem occurs. After investigating, I believe/hoping it is a measurement settings issue. I think the template may be set to metric, while my profile is set to inches.
Back to top
View user's profile Send private message
lknoll
General User
General User


Joined: 19 Oct 2011
Posts: 32
Location: Harrisburg, Pa

PostPosted: Thu May 10, 2012 6:34 am    Post subject: Solved Reply with quote

Issue solved. When I open the original document the table has a cell that SHOULD spill over into a second page. I have the settings set to allow this, but this does not always occur.

When the document is first opened, I have a macro that adds reference marks to every line running, so in here I check to see if the cell should be spilling over into a second page, if so, I set the KeepTogether attribute to True and then back to false. This in a sense jump starts the value and the cell spans 2 pages like I would expect.
Back to top
View user's profile Send private message
lknoll
General User
General User


Joined: 19 Oct 2011
Posts: 32
Location: Harrisburg, Pa

PostPosted: Thu May 24, 2012 5:26 am    Post subject: Reply with quote

the issue wasn't completed resolved. see new thread.

http://www.oooforum.org/forum/viewtopic.phtml?t=159342&highlight=
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group