OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Conditional formatting is flaky?

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Calc
View previous topic :: View next topic  
Author Message
nostabo
OOo Enthusiast
OOo Enthusiast


Joined: 14 Nov 2004
Posts: 125
Location: Sacramento, CA

PostPosted: Thu Dec 09, 2004 5:36 pm    Post subject: Conditional formatting is flaky? Reply with quote

I am trying to use OOo Calc's Conditional formatting on a Windoze machine, but whenever I apply a Condition to the cell it BLINKS continually. The condition is met and the style is applied correctly, but the blinking is not right!

I have tried various Styles and conditions, all with the same result. Is there something I am doing wrong?
Back to top
View user's profile Send private message Visit poster's website
r_vinoya
Super User
Super User


Joined: 03 Dec 2003
Posts: 619
Location: Somewhere in the Philippines

PostPosted: Thu Dec 09, 2004 7:26 pm    Post subject: Re: Conditional formatting is flaky? Reply with quote

nostabo wrote:
I am trying to use OOo Calc's Conditional formatting on a Windoze machine, but whenever I apply a Condition to the cell it BLINKS continually. The condition is met and the style is applied correctly, but the blinking is not right!

I have tried various Styles and conditions, all with the same result. Is there something I am doing wrong?


This is unusual. It never happened to me.
However can you tell what is/are the condition(s) of your conditional formatting?


(Do not take this part seriously=> Maybe it blinks because Christmas time is near, Now you have Christmas Lights Laughing )
_________________
# : - )
Back to top
View user's profile Send private message
nostabo
OOo Enthusiast
OOo Enthusiast


Joined: 14 Nov 2004
Posts: 125
Location: Sacramento, CA

PostPosted: Thu Dec 09, 2004 11:27 pm    Post subject: Reply with quote

Thanks for your help...here is my conditional (which is very simple):

If cell value is less than $'Format Cells'.$D$3

I fixed it by removing the Absolute references as shown above...this is not right because the cell references were aquired by clicking on the cell, I did not enter them manually. When the cell reference is changed to simply "D3" it is fine, otherwise the whole row blinks like it is continually refreshing.

Please try this and tell me I am not alone on this...

Rick
Back to top
View user's profile Send private message Visit poster's website
r_vinoya
Super User
Super User


Joined: 03 Dec 2003
Posts: 619
Location: Somewhere in the Philippines

PostPosted: Fri Dec 10, 2004 1:10 am    Post subject: Reply with quote

nostabo wrote:
Thanks for your help...here is my conditional (which is very simple):

If cell value is less than $'Format Cells'.$D$3

I fixed it by removing the Absolute references as shown above...this is not right because the cell references were aquired by clicking on the cell, I did not enter them manually. When the cell reference is changed to simply "D3" it is fine, otherwise the whole row blinks like it is continually refreshing.

Please try this and tell me I am not alone on this...

Rick


I tried this:
1) Created a sheet named Format Cells
2) Created a new cell condition named untitled (set background color to "yellow")
3) Typed 5 on cell D3
4) Selected Row1, add conditional formatting, create cell reference by clicking on the cell to get:
If cell value is less than $'Format Cells'.$D$3

Now Row1 becomes yellow. When I type on cell A1 10 (>5), the cell format becomes default.

Shocked No blinking occurs Shocked
_________________
# : - )
Back to top
View user's profile Send private message
nostabo
OOo Enthusiast
OOo Enthusiast


Joined: 14 Nov 2004
Posts: 125
Location: Sacramento, CA

PostPosted: Fri Dec 10, 2004 9:58 am    Post subject: Reply with quote

This is odd...

...I opened the same spreadsheet under Linux on a different PC and it still "blinks", so it can't be the OS (Windows), or the software configuration, or the PC?

Oh, well...it must be me alone? I think I'll check the Issue Tracker for a problem...

...and ladys and gentlemen, it is a bug:
http://www.openoffice.org/issues/show_bug.cgi?id=21357

...with a work around that is scheduled to be fixed in OOo 2.0. Try it now when auto recalc is off. That's when the blinking occurs.

relieved he is Very Happy
Back to top
View user's profile Send private message Visit poster's website
r_vinoya
Super User
Super User


Joined: 03 Dec 2003
Posts: 619
Location: Somewhere in the Philippines

PostPosted: Sun Dec 12, 2004 4:22 pm    Post subject: Reply with quote

nostabo wrote:
This is odd...

...I opened the same spreadsheet under Linux on a different PC and it still "blinks", so it can't be the OS (Windows), or the software configuration, or the PC?

Oh, well...it must be me alone? I think I'll check the Issue Tracker for a problem...

...and ladys and gentlemen, it is a bug:
http://www.openoffice.org/issues/show_bug.cgi?id=21357

...with a work around that is scheduled to be fixed in OOo 2.0. Try it now when auto recalc is off. That's when the blinking occurs.

relieved he is Very Happy


Now that's why I don't have this problem... I have my AutoCalculate checked (ON)... I tried turning it OFF.

Now I see the blinking like you said (Ho Ho Ho.... Merry Christmas Laughing )

But seriously, it is good to know that the bug will be fixed soon. Smile
_________________
# : - )
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Calc All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group