OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

OpenOffice.org not listening to Bibus after upgrade

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> Setup and Troubleshooting
View previous topic :: View next topic  
Author Message
ToVeR
OOo Advocate
OOo Advocate


Joined: 06 Oct 2004
Posts: 238
Location: Belgi� - Belgique - Belgien - Belgium

PostPosted: Sat Jan 01, 2005 8:04 am    Post subject: OpenOffice.org not listening to Bibus after upgrade Reply with quote

For my bibliography references I make use of the Bibus software. After a painstaking installation I had it up and running nicely. On OpenOffice1.1.3, which was an update from my first OOo installation, OOo 1.1.2.

The problem I have now is that recently the upgrade to OOo 1.1.4 became available, I installed it today, upgrading 1.1.3, but now there is a 'communication problem' between OpenOffice.org and Bibus. OpenOffice does not seem to listen to Bibus. This despite me following the instructions for making this communication possible on the Bibus-site. The relevant lines are:

Quote:
To make the office listen whenever it is started, open the file <OfficePath>/share/registry/data/org/openoffice/Setup.xcu in an editor, and look for the element
<node oor:name="Office"/>
This element contains <prop/> elements. Insert the following <prop/> element on the same level as the existing elements:
<prop oor:name="ooSetupConnectionURL" oor:type="xs:string">
<value>socket,host=localhost,port=8100;urp;</value>
</prop>
This setting configures OpenOffice.org to provide a socket on port 8100, where it will serve connections through the UNO remote protocol (urp). If port 8100 is already in use on your machine, it may be necessary to adjust the port number. Block port 8100 for connections from outside your network in your firewall. If you have a OpenOffice.org network installation, this setting will affect all users. To make only a particular user installation listen for connections create a file <OfficePath>/user/registry/data/org/openoffice/Setup.xcu with the same structure as the file above and add the element <prop oor:name=" ooSetupConnectionURL"/> as shown above


And to see whether OOo is listening, the following can be done:

Quote:
Check if it is listening by calling netstat -a or -na on the command-line. An output similar to the following shows that the office is listening:

TCP <Hostname>:8100 <Fully qualified hostname>: 0 Listening


There is not a real element called " <node oor:name="Office"/> ", but I do have " <node oor:name="Office"> ". I do not know whether this has any influence on OOo listening to Bibus. After the "<node oor:name="Office">" that I do have, I entered the lines from above (copy/paste, so no typing errors).
Trying to enter a reference through Bibus results in an error being displayed (see: http://img.photobucket.com/albums/v77/ToVeR/Bibus-OOo_Problem.jpg).

Regrettably I do not remember whether I used OOo 1.1.2 or 1.1.3 when I installed Bibus. If yes, this problem should have occurred in the past as well, but I do not recall that, so I think only since version 1.1.3 I have Bibus up and running.

Maybe it could have been a problem with the need to set the Environment Variables in Windows, but the update, installed for 1.1.4 over my existing 1.1.3 installation, is installed in my original OOo folder, for 1.1.2, so the required path names etc. did not change with the installation of the upgrade.

This is very annoying for me, for now I cannot work with Bibus anymore, so any solution to this problem would be most appreciated.
_________________
LibreOffice 3.4.3
Back to top
View user's profile Send private message
ftack
Moderator
Moderator


Joined: 27 Jan 2003
Posts: 3102
Location: Belgium

PostPosted: Sat Jan 01, 2005 10:20 am    Post subject: Reply with quote

I always upgrade with a brand new installation of OOo. To make Bibus work with the new installation, all that is needed is

* update PATH to reflect new OOo directory
* update PYTHONPATH to reflect new OOo directory
* edit the new setup.xcu so that the new Ooo listens to a named pipe

Code:
 <node oor:name="Office">
   <prop oor:name="ooSetupConnectionURL" oor:type="xs:string">
   <value>pipe,name=OOo_pipe;urp;</value>
  </prop>



That's all that is needed for the connection and it never failed on me.
Back to top
View user's profile Send private message
ToVeR
OOo Advocate
OOo Advocate


Joined: 06 Oct 2004
Posts: 238
Location: Belgi� - Belgique - Belgien - Belgium

PostPosted: Sat Jan 01, 2005 11:36 am    Post subject: Reply with quote

So, this indicates the end for me on upgrading. I reinstalled OOo in a new directory, used the TCP/IP to make OOo and Bibus communicate, changed the environment variables Path and Pythonpath to the new directory. Now it works again.

I first tried with the pipe thing, did not work, decided not invest too much time in that, changed to TCP/IP an now it works.

Strangely enough it was the first time in years that I decided to upgrade a program instead of reinstalling it entirely. Now I learned again why I never upgraded Smile.

Thanks
_________________
LibreOffice 3.4.3
Back to top
View user's profile Send private message
ftack
Moderator
Moderator


Joined: 27 Jan 2003
Posts: 3102
Location: Belgium

PostPosted: Sat Jan 01, 2005 11:55 am    Post subject: Reply with quote

Yep, something must have gone wrong during your last upgrade. Glad you got it running again. I realise you were using a TCP/IP connection, while my previous post referred to a pipe connection. Changing to a pipe connection requires to tell Bibus about it under Openoffice.Org - Settings. With Win 98 or ME, it seems to be slow sometimes, but there probably is little difference in performance between TCP/IP and pipe connection on higher Windows versions, so as long as it works, you are fine. Enjoy!
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> Setup and Troubleshooting All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group