OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Setting paragraph style color doesn't change anything

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
JimWG
General User
General User


Joined: 22 Jan 2005
Posts: 19
Location: New York

PostPosted: Sun Jan 30, 2005 12:11 pm    Post subject: Setting paragraph style color doesn't change anything Reply with quote

Greetings!

I wish to assign a particular paragraph style a red text color and have it so change throughout the hundred page document, but even though I modify that paragraph style's color via the styles catalog's modify mode, my text remains black. All of it. Even using the Font Color icon on the function bar doesn't change any colors in any selected character or paragraph. It's like my document's fonts are all locked as black. I checked out the OOo Authors' page for any FAQ info but no go.

Any suggestions would be much much appreciated!

James Greenidge
Back to top
View user's profile Send private message Send e-mail Visit poster's website
8daysaweek.co.uk
Super User
Super User


Joined: 29 Nov 2003
Posts: 2130
Location: UK

PostPosted: Sun Jan 30, 2005 12:20 pm    Post subject: Reply with quote

Try highlighting the text and clicking Format > Default, then make sure that your paragraph is assigned to the "Red" paragraph style.

Let us know what (if anything) happens Shocked

Related topic:
http://www.oooforum.org/forum/viewtopic.phtml?t=16184&highlight=format+default

BFN Smile,
_________________
James
www.8daysaweek.co.uk - A User-Focused OOo site
Back to top
View user's profile Send private message Visit poster's website AIM Address
JimWG
General User
General User


Joined: 22 Jan 2005
Posts: 19
Location: New York

PostPosted: Sun Jan 30, 2005 1:03 pm    Post subject: Reply with quote

Thanks for the hyper-rapid response, BFN!

I highlighted a paragraph by itself and did Format>Defaut with the paragraph style color set for Red but no go. In frustration I even highlighted the whole document and tried it. No difference. What's telling is that the Font Color icon feature doesn't even have an effect on any character. I wonder is there some kind of "master override" color mode locking me into black font that I'm missing?

Baffled thoroughly!

Thanks,
James Greenidge
Back to top
View user's profile Send private message Send e-mail Visit poster's website
8daysaweek.co.uk
Super User
Super User


Joined: 29 Nov 2003
Posts: 2130
Location: UK

PostPosted: Sun Jan 30, 2005 1:11 pm    Post subject: Reply with quote

OK Confused

Try this:
Tools > Options > OpenOffice.org > Accessibility > UNCHECK Use automatic font color for screen display

Have you tried printing - does it print in the formatted colours?

BTW (By The Way) BFN = (Bye For Now), my name is James Laughing
Common Forum Abbreviations
_________________
James
www.8daysaweek.co.uk - A User-Focused OOo site
Back to top
View user's profile Send private message Visit poster's website AIM Address
JimWG
General User
General User


Joined: 22 Jan 2005
Posts: 19
Location: New York

PostPosted: Sun Jan 30, 2005 3:23 pm    Post subject: Reply with quote

James (not BFN!):

Well, you're a magician! I did your thing and it apparently "unlocked" black font mode, allowing me to use the Font Color icon and the Style Catalog to change color of a paragraph the cursor's on. If there's a way to effect the change in such paragraphs throughout the entire document in one swoop it'd be perfect. I'm hunting. Do you have any good hints in your magic hat?

Thanks a mill!

James Greenidge
Back to top
View user's profile Send private message Send e-mail Visit poster's website
8daysaweek.co.uk
Super User
Super User


Joined: 29 Nov 2003
Posts: 2130
Location: UK

PostPosted: Sun Jan 30, 2005 3:43 pm    Post subject: Reply with quote

Hi James,

Glad that worked for you Smile

JimWG wrote:
If there's a way to effect the change in such paragraphs throughout the entire document in one swoop it'd be perfect.

Well, I don't think we can do it in one fell swoop but...
JimWG wrote:
I highlighted a paragraph by itself and did Format>Defaut with the paragraph style color set for Red but no go. In frustration I even highlighted the whole document and tried it.

So, presumably your document's paragraphs are all "default" in whatever style they are set to. I think the quickest way to set your preferred style to each paragraph is to:
  • select the paragraph style you want in the stylist
  • Click on the paint can icon (Fill Format Mode)
  • Click once on each paragraph that should have the style you've selected
  • Click on the paint can icon again to deselect it

Then, when your format is applied to your desired paragraphs, any changes you make in the stylist will automatically be made to all of the paragraphs with that style.

HTH Smile,

It's late here so I'll check back tomorrow.
_________________
James
www.8daysaweek.co.uk - A User-Focused OOo site
Back to top
View user's profile Send private message Visit poster's website AIM Address
JimWG
General User
General User


Joined: 22 Jan 2005
Posts: 19
Location: New York

PostPosted: Mon Jan 31, 2005 8:13 am    Post subject: Balking color paragraph style solution found! Reply with quote

James, thanks!

After mucho hair-pulling, I finally got it. I was even thinking of going the route of search-replacing via indent styles to turn my paragraphs red!

In a nutshell in my non-programmer terms, if the document's font default color is black, it acts like a black mask coloring over any style color preferences one has. Format Default "washes away" this color to expose the true style colors beneath. So in setting up to see on screen your paragraph style colors, one should first be sure that the Print Black selection in is OFF in Tools Options Text document - Print, as so your recommended Use Automatic Font Color for Screen Display in Tools Options Accessibility. Then, even if you wish to view your text all black just select all and hit the Font Color icon for black, and to reverse back to your colored styles just hit Format Default!

Phew! Hope this makes as much sense as it works!

Thanks!
James Greenidge
Back to top
View user's profile Send private message Send e-mail Visit poster's website
8daysaweek.co.uk
Super User
Super User


Joined: 29 Nov 2003
Posts: 2130
Location: UK

PostPosted: Mon Jan 31, 2005 10:01 am    Post subject: Reply with quote

Glad everything's sorted Smile
_________________
James
www.8daysaweek.co.uk - A User-Focused OOo site
Back to top
View user's profile Send private message Visit poster's website AIM Address
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group