OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Spellchecker frustration (OO 2.0 beta)

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
Galmok
General User
General User


Joined: 22 Dec 2004
Posts: 19

PostPosted: Mon Mar 14, 2005 9:38 am    Post subject: Spellchecker frustration (OO 2.0 beta) Reply with quote

I have a document which is written in Danish. I installed the Danish dictionary and restarted oo (including quickstart). Then I wrote some more and got annoyed with the wavy lines belov every word. Then I changed the default language for the document to Danish but that didn't do anything. Running spellcheck reveals that most of the document is locked in English (USA) language.

My question:

Is there any way to change the language of the whole document, overriding every local setting?

I have tried the following:

1) Marked the whole text. Visited paragraph->Font->Language but the language was already Danish. I tried changing it to something else and back (clicking OK inbetween) but nothing changed. Also tried changing it to none but that also didn't change anything.

2) I began rightclicking on every word/paragraph and selected "Paragraph is Danish" but that got very tedious very fast. But it works. The language is changing.

3) Every new word in the document is entered as English (USA) regardless of my settings. I guess this is the actually problem. Somewhere I need to change this. But I already changed the Tools->Options->Language Settings->Language to Danish (except for the GUI which is english by choice).

4) I can select Format->Default formatting but that ruins every formatting I have made. Obviously not a good choice.

Is there an OpenOffice editor that can remove the language information from a document? Or is it builtin?
Back to top
View user's profile Send private message
Galmok
General User
General User


Joined: 22 Dec 2004
Posts: 19

PostPosted: Mon Mar 14, 2005 9:46 am    Post subject: Reply with quote

I sort of solved my problem. It seems that I had to change the Character formatting. If was English (USA) and I changed it to Danish.

Next problem. How can I remove the Character language formatting so the document language is inherited from the settings? Or is the document language setting only for new documents from which the Character language gets its initial language setting?

If I paste foreign text into Writer, what language will it become? Preferences or Character language? (Character language, I just checked).

Well, I can work with what I have, but it was far from intuitive.
Back to top
View user's profile Send private message
Galmok
General User
General User


Joined: 22 Dec 2004
Posts: 19

PostPosted: Mon Mar 14, 2005 10:04 am    Post subject: Reply with quote

Ok, completely wierd thing is happening.

I am writing my document in Danish and I have prior to that changed it completely to Danish language (select all, character..., language=Danish). This seems to work fine.

Now the wierd part is that everytime I write the word "studerende" which I wrote at the top of the document when it was all marked as English (USA) changes the current language setting back to English (USA). This happens for every word that Writer offers wordcomplete on.

So the bug must be that Writer doesn't update its wordcomplete language if the original word it recorded has changed language.

Quitting and restarting Writer solves the bad cache problem. Don't know if simply closeing the document and opening it again would be enough.
Back to top
View user's profile Send private message
Galmok
General User
General User


Joined: 22 Dec 2004
Posts: 19

PostPosted: Mon Mar 14, 2005 10:17 am    Post subject: Reply with quote

I was wrong. Auto Complete will change the language to English (USA) _everytime_ it offers a suggestion. Only solution is to turn off Auto Complete.

Do I have to submit a bug report or is the above good enough?
Back to top
View user's profile Send private message
esperantisto
Super User
Super User


Joined: 26 Dec 2003
Posts: 779
Location: Belarus

PostPosted: Tue Mar 15, 2005 12:09 am    Post subject: Reply with quote

Maybe, that's not actually good, but that's how the things work: autocorrection and autocompletion are language-specific.
Try:
a) change the language for the styles you use, especially for Default.
b) reset the autocompletion list (Tools -> Auto Correct ->Word Completion -> Reset).

You'll have, of course, to collect you autocompletion list anew Sad
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group