OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Problem Applying Styles

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
Bhikkhu Pesala
Super User
Super User


Joined: 23 Aug 2005
Posts: 2324
Location: Seven Kings, London, UK

PostPosted: Wed Aug 24, 2005 11:43 am    Post subject: Problem Applying Styles Reply with quote

I started off with Text body at 12 point, and updated it to use 11 point. Now some paragraphs are in 12 point and some in 11 point. If I select a 12 point paragraph, and apply 11 point, or change the paragraph style and reapply Text body, it stubbornly remains at 12 point. Why?
Back to top
View user's profile Send private message Visit poster's website
jrkrideau
Super User
Super User


Joined: 08 Aug 2005
Posts: 6732
Location: Kingston ON Canada

PostPosted: Wed Aug 24, 2005 12:09 pm    Post subject: Re: Problem Applying Styles Reply with quote

Bhikkhu Pesala wrote:
I started off with Text body at 12 point, and updated it to use 11 point. Now some paragraphs are in 12 point and some in 11 point. If I select a 12 point paragraph, and apply 11 point, or change the paragraph style and reapply Text body, it stubbornly remains at 12 point. Why?


I just tried it under WinXp and OOo.1.9.122 with no problem but I seem to recall it, or something similar happening in an earlier version of 1.9.x.

What OS and version are you using?
_________________
jrkrideau
Kingston ON Canada
Currently using Windows 7 & OOo 3.4.0 and Ubuntu 12.04 & LibreOffice 3.5.2.2
Back to top
View user's profile Send private message
Bhikkhu Pesala
Super User
Super User


Joined: 23 Aug 2005
Posts: 2324
Location: Seven Kings, London, UK

PostPosted: Wed Aug 24, 2005 12:11 pm    Post subject: Reply with quote

I'm using Windows ME with Open Office 1.9.122

I tried updating the default font too to use the same font at 11 point as for my Text body style, but no joy.

The paragraphs that have changed to 11 point seem not to contain any italic text. Those that refuse to change all seem to contain at least one word in Italics.
Back to top
View user's profile Send private message Visit poster's website
Bhikkhu Pesala
Super User
Super User


Joined: 23 Aug 2005
Posts: 2324
Location: Seven Kings, London, UK

PostPosted: Thu Aug 25, 2005 12:42 am    Post subject: Reply with quote

I found that if I remove all italic attributes from the paragraph, I can then apply the 11 point attribute. If I apply "Default Formatting" I can also then apply italics and the font size remains at 11 point.

There does seem to be a bug here though.
Back to top
View user's profile Send private message Visit poster's website
ftack
Moderator
Moderator


Joined: 27 Jan 2003
Posts: 3102
Location: Belgium

PostPosted: Thu Aug 25, 2005 1:33 am    Post subject: Reply with quote

My guess is that at one time, you applied the change to 11 point as direct formatting. This will remain, no matter how you change the style. In order for the style to control the formatting, you need to remove manual formatting using Format - Default first.

You can remove Italics+12pt using Search+replace: Search format Italic+12pt and replace by format Italic. the resulting "Italic" text will assume the point size of the underlying paragraph style.
Back to top
View user's profile Send private message
esperantisto
Super User
Super User


Joined: 26 Dec 2003
Posts: 779
Location: Belarus

PostPosted: Thu Aug 25, 2005 10:36 pm    Post subject: Reply with quote

There's no bug. Indeed, direct formatting has higher priority. Select the paragraph(s) and use the command "Clear formatting" that is on the top of the drop-down style list or simply press Ctrl+Shift+Space.
Back to top
View user's profile Send private message
eyolf
OOo Enthusiast
OOo Enthusiast


Joined: 21 Sep 2004
Posts: 102
Location: Denmark

PostPosted: Fri Aug 26, 2005 5:06 am    Post subject: Reply with quote

But that will remove all direct formatting, also that which has nothing to do with the font size. A better solution is to search for that specific attribute (Find & Replace > More options > Attributes... > Font Size), check Regular expressions, write .* in the Search for field and & in the replace field (this selects all text with the selected attribute and replaces it with the same, only without the attribute - or so I think; someone, correct me if I'm wrong . . .)
The "detour" through the Regexp, is necessary, because just a plain empty Replace field, will not have any text to work with, and hence do nothing.

One more note: the behaviour of the Attributes selection seems a bit strange: it finds "all instances of text that do not use the default font ... All text that has a directly coded font attribute, and all text where a style switches the font attribute, are found." That even font attributes which are defined in the Paragraph style should be considered deviations from the default, is very strange.
Back to top
View user's profile Send private message Visit poster's website
eyolf
OOo Enthusiast
OOo Enthusiast


Joined: 21 Sep 2004
Posts: 102
Location: Denmark

PostPosted: Fri Aug 26, 2005 8:42 am    Post subject: Reply with quote

Update: So, it wasn't that simple, after all. I'm getting more and more frustrated about the ability to search and replace specific direct formatting in Writer. I'd be extremely grateful if someone could clear up this mess for me, once and for all.
Basically, my problem is:
In a text like this:

Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Suspendisse dui magna, congue vitae, auctor condimentum, semper ac, arcu. Donec pellentesque. In accumsan aliquet velit. Nulla facilisi. Curabitur pulvinar viverra arcu. In hac habitasse platea dictumst. Pellentesque justo. Pellentesque iaculis leo sed risus. Quisque velit augue, tincidunt eu, scelerisque in, faucibus vel, lectus. Nulla nisi leo, hendrerit sit amet, pellentesque ut, faucibus et, diam. Proin consequat justo id pede.

How do I set the font size back to normal in the middle of the paragraph, without losing the italics? If I search for font size and set the resulting selection to default format, the italics will go too, and the various search and replace-combinations that I have tried, even the ones I mentioned in my previous post, have left the bigger-sized passage alone.

I hate to say it, but this works much smoother in Word, where all the different Styles
and combinations of Styles and hard formatting are listed in the "Stylist". Something like that would be a great enhancement for OOo as well. Perhaps a macro?

Help!
Back to top
View user's profile Send private message Visit poster's website
ftack
Moderator
Moderator


Joined: 27 Jan 2003
Posts: 3102
Location: Belgium

PostPosted: Mon Aug 29, 2005 12:13 am    Post subject: Reply with quote

You can search for "Italics" and replace it by "Not italics", or replace Font size 13 with Font size 12, i.e., you can replace selected direct formatting by other direct formatting. You cannot, however, REMOVE direct formatting, i.e., you cannot "search" italics and "replace" with (nothing). OOo reports it did a change, but in reality, nothing happened. The only way to effectively remove all formatting and thus let the settings of the current paragraph style take control, is "Format - Default".

I raised this as an issue. The vision of the developpers on this is not clear to me. http://qa.openoffice.org/issues/show_bug.cgi?id=41193

By the way, I believe Word is very similar in this respect. Searching "Formatting" and replacing with nothing there removes all text wit the specific formatting. I also see no way to replace formatting with no formatting (but I could be wrong).
Back to top
View user's profile Send private message
eyolf
OOo Enthusiast
OOo Enthusiast


Joined: 21 Sep 2004
Posts: 102
Location: Denmark

PostPosted: Mon Aug 29, 2005 5:10 am    Post subject: Reply with quote

It is true that this function doesn't work ideally in Word either, but (1) there is the very useful function which removes all direct formatting on the paragraph level (ctrl-Q, I think it is, don't remember the name), (2) the list of styles+applied formats, which I would love to see in OOo as well, e.g. under "Applied styles" in the Stylist, and (3) there seems to be a much wider spectre of possibilities and combinations any feature can be specified in both the find and the replace field. E.g. replace all bold text with a heading style, which I have not found out how to do with OOo, at least not without using Iannz Find&Replace (no, wait, it can't do it either, can it, since it doesn't yet search for direct formatting).

BTW, I believe I'm the only one who has voted for your issue - a good one! Everybody: go there and vote
Back to top
View user's profile Send private message Visit poster's website
Soilman
Newbie
Newbie


Joined: 16 May 2005
Posts: 3
Location: Davis, California United States of America

PostPosted: Mon Sep 05, 2005 1:34 pm    Post subject: Clearning direct formatting Reply with quote

esperantisto wrote:
There's no bug. Indeed, direct formatting has higher priority. Select the paragraph(s) and use the command "Clear formatting" that is on the top of the drop-down style list or simply press Ctrl+Shift+Space.


I used the "Clear formatting" at eh top of the drop-down style list and it did not work and was very disturbing. Crying or Very sad Evil or Very Mad I was happy to find the keyboard Ctrl+Shift+Space alternative as this did the trick. Seems as though the offending issue in this passage was hyperlinks.
The links are also removed with this Ctrl+Shif+Space method. Rebuilding these are a true pain!
Again this is a very disturbing issue as styles that will not apply globaly and require paragraph by page inspection and repair of a lengthly dissertation simply is not accptable.

Soilman
Back to top
View user's profile Send private message AIM Address Yahoo Messenger MSN Messenger
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group