OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Page + 1 correction

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
martho
OOo Enthusiast
OOo Enthusiast


Joined: 17 Apr 2004
Posts: 140
Location: Germany

PostPosted: Thu Sep 29, 2005 5:15 am    Post subject: Page + 1 correction Reply with quote

Hello!

Please do the following:
- create a new document
- add a header
- insert "Page " and the page-number into the header
- edit the page-number. Do a correction to make the 1st page saying "Page 2"
- create a 2nd page in the document

For me, it says "Page 2" ond the 1st page (-> correct)
But "Page " on the 2nd page (-> the page-number is emtpy here! It should be "Page 3").

We have an already a ready-printed "Page 1" and need to start the OO-Dokument with "Page 2". How is it done?
Back to top
View user's profile Send private message
David
Super User
Super User


Joined: 24 Oct 2003
Posts: 5668
Location: Canada

PostPosted: Thu Sep 29, 2005 6:10 am    Post subject: Re: Page + 1 correction Reply with quote

martho wrote:
Hello!

Please do the following:
- create a new document
- add a header
- insert "Page " and the page-number into the header
- edit the page-number. Do a correction to make the 1st page saying "Page 2"
- create a 2nd page in the document

For me, it says "Page 2" ond the 1st page (-> correct)
But "Page " on the 2nd page (-> the page-number is emtpy here! It should be "Page 3").

We have an already a ready-printed "Page 1" and need to start the OO-Dokument with "Page 2". How is it done?


This is wierd. I find that if you do the same on a new document with only one page, then continue into other fresh pages there is no problem. However, if you have an already available document with several pages, what you say occurs.

A possible temporary solution? :

I find that if you add an extra blank page [CTRL-ENTER] at the end the numbering continues from the adjusted offset [*] in the first page, but the last page is blank. If this works, the printer should spew out a blank last page.

[*] By this I mean that you select the "1" in the first header and then right mouse / Fields, and change the offset of 0 to 1, so increasing all by 1. This does result in the blank on the last page, but the above might correct that, or at least allow for it.

A definite bug, I'd suspect.

David.
Back to top
View user's profile Send private message
jrkrideau
Super User
Super User


Joined: 08 Aug 2005
Posts: 6732
Location: Kingston ON Canada

PostPosted: Thu Sep 29, 2005 6:30 am    Post subject: Re: Page + 1 correction Reply with quote

martho wrote:
Hello!

Please do the following:
- create a new document
- add a header
- insert "Page " and the page-number into the header
- edit the page-number. Do a correction to make the 1st page saying "Page 2"
- create a 2nd page in the document

For me, it says "Page 2" ond the 1st page (-> correct)
But "Page " on the 2nd page (-> the page-number is emtpy here! It should be "Page 3").

We have an already a ready-printed "Page 1" and need to start the OO-Dokument with "Page 2". How is it done?


I am not clear on what you have done but I think you may have inserted a page number field on the first page, deleted it and typed in a '2'.

Then you have inserted a page break? I don't I don't see why the '2' is not showing up on the second page if the "Page is Confused

I think to do what you want you can set page style for the first page to 'First Page
Insert a First Page footer, type "Page 2" into it and then insert a page break to create the second page.

When you do this you need to select a Style (default will work, ) and then Click the box that says "Change Page Number" and change that number to "3"
Insert a header
Then type "Page" and insert the page number and you should be okay

This should do it. Good luck
_________________
jrkrideau
Kingston ON Canada
Currently using Windows 7 & OOo 3.4.0 and Ubuntu 12.04 & LibreOffice 3.5.2.2
Back to top
View user's profile Send private message
8daysaweek.co.uk
Super User
Super User


Joined: 29 Nov 2003
Posts: 2130
Location: UK

PostPosted: Thu Sep 29, 2005 7:45 am    Post subject: Reply with quote

Hi martho,

You may find reading this helpful:
http://www.8daysaweek.co.uk/forums/viewtopic.php?t=34

BFN Smile,
_________________
James
www.8daysaweek.co.uk - A User-Focused OOo site
Back to top
View user's profile Send private message Visit poster's website AIM Address
ftack
Moderator
Moderator


Joined: 27 Jan 2003
Posts: 3102
Location: Belgium

PostPosted: Thu Sep 29, 2005 10:10 am    Post subject: Reply with quote

Do not use the "offset" to have a different starting page number. Instead, go to the first paragraph of the first page, then: Format - Paragraph, text flow tab: Check "Insert Breaks", check "With page style", leave the current style alone and then specify 2 as the starting page number.
Back to top
View user's profile Send private message
jrkrideau
Super User
Super User


Joined: 08 Aug 2005
Posts: 6732
Location: Kingston ON Canada

PostPosted: Thu Sep 29, 2005 2:18 pm    Post subject: Reply with quote

ftack wrote:
Do not use the "offset" to have a different starting page number. Instead, go to the first paragraph of the first page, then: Format - Paragraph, text flow tab: Check "Insert Breaks", check "With page style", leave the current style alone and then specify 2 as the starting page number.


Thanks ftack,
I knew there had to be a way to do that but I could not find it Very Happy
_________________
jrkrideau
Kingston ON Canada
Currently using Windows 7 & OOo 3.4.0 and Ubuntu 12.04 & LibreOffice 3.5.2.2
Back to top
View user's profile Send private message
martho
OOo Enthusiast
OOo Enthusiast


Joined: 17 Apr 2004
Posts: 140
Location: Germany

PostPosted: Fri Sep 30, 2005 3:16 am    Post subject: Reply with quote

ftack wrote:
Do not use the "offset" to have a different starting page number. Instead, go to the first paragraph of the first page, then: Format - Paragraph, text flow tab: Check "Insert Breaks", check "With page style", leave the current style alone and then specify 2 as the starting page number.


Thanks for your reply. This is getting really crazy. I tried this, it works fine on the document itself.

When printing the document on a HP DeskJet, it prints page 1 (= "Page 2") and then an empty page.

When printing the document on a HP LaserJet, it prints an empty page and then page 1 (= "Page 2").

So the page-number is now correct, but an empty page is printed, too. But the empty page is not shown in the document. It seems that the printer somehow gets confused by the "wrong" page-numbers.
Back to top
View user's profile Send private message
ftack
Moderator
Moderator


Joined: 27 Jan 2003
Posts: 3102
Location: Belgium

PostPosted: Fri Sep 30, 2005 4:26 am    Post subject: Reply with quote

No, now you are facing the "blank page" issue, which has been there always in Openoffice and which actually is "by design". The idea is that with duplex printing, your page 2 (or any even page) should be printed on the reversed side of the paper (to be a left page in the book). Uneven starting pages will not result in a blank page side. I also wish with you that that "feature" could be turned off. In the interim, remove the blank page and ideally return it to the stack Wink You can also avoid it by specifying a print range before printing (2- will print from page 2 on till the end). to get rid of that page during PDF export, do the same in the PDF export dialog (version 2, not sure whether you can specify pages in version 1). These blank pages do show up in the print preview.
Back to top
View user's profile Send private message
martho
OOo Enthusiast
OOo Enthusiast


Joined: 17 Apr 2004
Posts: 140
Location: Germany

PostPosted: Fri Sep 30, 2005 4:31 am    Post subject: Reply with quote

Thanks for your reply. I was afraid it was a feature Wink

I found another solution using fields and "set pagevariable" / "show pagevariable" (I hope this is translated correctly since I use the German version). You use "set pagevariable" to mark the first page, add a correction of +1, and instead of adding Insert > Fields > Page Number you use a field called "show pagevariable". It seems a bit "instable" as well, because the "set pagevariable" has to be before the first paragraph of text, but then it seem to work then.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group