OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Sections & Linking to HTML Page

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
Gauthic
Newbie
Newbie


Joined: 07 Jun 2010
Posts: 4

PostPosted: Mon Jun 07, 2010 8:54 am    Post subject: Sections & Linking to HTML Page Reply with quote

When I create a new section with a link to an HTML page, it inserts a Page Break just before the section. I can remove the page break by deleting and readding some of the text, however everytime I update the web page (a dynamic PHP list of items) the page break comes back.

Is there any way to keep this from happening?

The format of the generated HTML page is...
Code:
<h2>Item #1</h2>
<p><b>Effects</b>: blah blah.</p>
<p><b>Examples</b>: blah blah</p>
<p><b>Conflicts With</b>: blah blah</p>


<h2>Item #2</h2>
<p><b>Effects</b>: blah blah.</p>
<p><b>Examples</b>: blah blah</p>
<p><b>Conflicts With</b>: blah blah</p>

....


Thanks!
Jeff[/code]
Back to top
View user's profile Send private message
Gauthic
Newbie
Newbie


Joined: 07 Jun 2010
Posts: 4

PostPosted: Mon Jun 07, 2010 10:49 am    Post subject: Reply with quote

Just to clarify as I wasn't too specific...

"....however everytime I update the web page (a dynamic PHP list of items) the page break comes back"

should be

"....however every time I update the section link to the web page (a dynamic PHP list of items) the page break comes back"
Back to top
View user's profile Send private message
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Mon Jun 07, 2010 11:37 am    Post subject: Reply with quote

I'm clueless about what you want or about what your problem is. Displaying the html of the file you link to doesn't help and, for the record, html doesn't have page breaks. So, where does the page break occur? Better show the content of the file that gives the problems, you can upload it at for instance www.mediafire.com.
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
Gauthic
Newbie
Newbie


Joined: 07 Jun 2010
Posts: 4

PostPosted: Mon Jun 07, 2010 11:44 am    Post subject: Reply with quote

http://wiki.services.openoffice.org/wiki/Documentation/OOoAuthors_User_Manual/Writer_Guide/Using_sections_for_page_layout

When the Link Checkbox is checked, and a URL is placed under the file name the HTML content is then imported into the contents of the section.

However, I have noticed that before I reformat it when the page break is removed that the content reads 'HTML' instead of 'normal' as the rest of the document reads. I'm now thinking it may be an importer issue and the way the content is formatted.

If I have to modify the php page to write an open office format I can.
Back to top
View user's profile Send private message
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Mon Jun 07, 2010 12:44 pm    Post subject: Reply with quote

Okay, now it starts to make sense. I'm actually surprised that you can import html in a normal odt file. Smile I also get a page break at the start, don't know why, but it's odd that you don't get one at the end. Now that seems to be an oversight/bug.
The formatting of the html is simply imported with the text.
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
Gauthic
Newbie
Newbie


Joined: 07 Jun 2010
Posts: 4

PostPosted: Mon Jun 07, 2010 12:46 pm    Post subject: Reply with quote

Yeah I was catching that.

It's not a huge deal at this point as the imported text doesn't change often and I can manually update and then fix the page break.

I wonder where I can submit this bug report for this undocumented feature (I did just guess that a URL would work).
Back to top
View user's profile Send private message
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Mon Jun 07, 2010 12:54 pm    Post subject: Reply with quote

http://qa.openoffice.org/issue_handling/project_issues.html

Good luck.
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group