OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Read this if you cannot insert/delete/update records
Goto page Previous  1, 2, 3, 4, 5
 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Base
View previous topic :: View next topic  
Author Message
Arineckaig
OOo Advocate
OOo Advocate


Joined: 01 Mar 2004
Posts: 358

PostPosted: Wed Nov 24, 2010 3:00 am    Post subject: Reply with quote

Quote:
I mean the ability to copy individual records from one table to another

Apologies for the delay in my reply but other matters have priority. I know of no easy way in the GUI to copy individual records from one table to another. It can, however, be done with SQL but you will need to use the menu bar Tools > SQL... to issue the SQL commands directly. I would only suggest this if you have a fair degree of experience with SQL: otherwise such direct SQL commands to a table are powerful and can cause unexpected consequences. I would refer you to the posts of Sliderule for comprehensive and expert advice - far better than anything I could offer.
Back to top
View user's profile Send private message
mikeexplorer
General User
General User


Joined: 08 Nov 2010
Posts: 6

PostPosted: Tue Dec 21, 2010 1:29 pm    Post subject: Reply with quote

I decided to export the old databases into a format that calc can read. With calc I can copy rows from one to another with no issues. It also even allows a save as in DBF format which I can import to my label program

Mike
Back to top
View user's profile Send private message
ThisIsRidiculous
General User
General User


Joined: 30 May 2011
Posts: 8

PostPosted: Sat Jun 04, 2011 9:31 pm    Post subject: Status on Read Only?? Reply with quote

Ok, whats the status on this problem? I too am getting this- and it WAS working. Title bar says "Read Only" and I cannot add records. Starting to think OOo was a bad idea. Between insufficient documentation- cant find answers to any of my questions unless I post a ton of questions on the forums, and the issues it seems to have, it would take less time to write down the info I want to keep track of.
Back to top
View user's profile Send private message
gloria.clark
Newbie
Newbie


Joined: 28 Jun 2011
Posts: 1
Location: India

PostPosted: Mon Jul 04, 2011 1:51 am    Post subject: Reply with quote

Hello All..... The thread is really the best on this laudable topic. I concur with your conclusions and will eagerly look forward to your future updates. I request to all participants to continue this topic because with it i will learn many things.

Thanks to all who participate in the thread.
Regards...
Gloria Clark
Back to top
View user's profile Send private message Visit poster's website
Zerex71
General User
General User


Joined: 23 Feb 2012
Posts: 46

PostPosted: Wed Feb 29, 2012 12:32 pm    Post subject: Re: Status on Read Only?? Reply with quote

ThisIsRidiculous wrote:
Ok, whats the status on this problem? I too am getting this- and it WAS working. Title bar says "Read Only" and I cannot add records. Starting to think OOo was a bad idea. Between insufficient documentation- cant find answers to any of my questions unless I post a ton of questions on the forums, and the issues it seems to have, it would take less time to write down the info I want to keep track of.


I hear you!

I am checking in on this thread because even at this late date, after having migrated a database to the superior multi-mode configuration using HSQL 2.2.8, I cannot add any records, modify any table, or execute any UPDATE commands in queries. In short, it sounds to me like unless I manually enter a key value (which I HAD set to autonumber), I can't add any records to my tables. I believe I am therefore having this problem (it just started, don't know why, and didn't ask for it).

Mike
Back to top
View user's profile Send private message
admina
Newbie
Newbie


Joined: 20 Oct 2013
Posts: 2

PostPosted: Thu Oct 24, 2013 12:51 am    Post subject: Reply with quote

Using ODBC database views fine but always opens in read-only. Found problems adding records and sometimes with other functions.


Moderation probe1: disabled signatur with SPAM link
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Base All times are GMT - 8 Hours
Goto page Previous  1, 2, 3, 4, 5
Page 5 of 5

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group