OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Unable To Connect Base to My PostgreSQL

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Base
View previous topic :: View next topic  
Author Message
CarlosinFL
General User
General User


Joined: 27 Sep 2010
Posts: 5

PostPosted: Mon Sep 27, 2010 8:55 am    Post subject: Unable To Connect Base to My PostgreSQL Reply with quote

I am trying to connect Base to my PostgreSQL server and I downloaded and installed a plug-in however it doesn't appear to be working for some reason. I keep getting this error:

The connection to data source <name> could not be established.

No SDBC driver was found for the given URL.


I installed the 0.7.6b for Linux patch from here and it installed fine. I restarted Base and then under the database list I saw a new option for 'postgresql'. That is the one I selected and I keep getting the same error. Anyone know what's wrong?
Back to top
View user's profile Send private message
r4zoli
Super User
Super User


Joined: 17 May 2005
Posts: 570
Location: Budapest, Hungary

PostPosted: Mon Sep 27, 2010 9:42 am    Post subject: Reply with quote

0.7.6b is good only for coming OOo 3.3, for older versions use 0.7.6a, and works with 8.x versions of postgreSQL versions, not work with new 9.0 version.
You can use JDBC driver for 9.0.
Back to top
View user's profile Send private message
CarlosinFL
General User
General User


Joined: 27 Sep 2010
Posts: 5

PostPosted: Mon Sep 27, 2010 9:48 am    Post subject: Reply with quote

I removed the 0.7.6b & installed 0.7.6a from the same site and I don't appear to be using 9.0. I am using 8.4 right now and my version of OO Base is 3.2.

Code:
[root@database]# pacman -Qs postgresql
local/postgresql 8.4.4-5
    A sophisticated object-relational DBMS
local/postgresql-libs 8.4.4-5
    Libraries for use with PostgreSQL


Any ideas why this wouldn't work still?
Back to top
View user's profile Send private message
r4zoli
Super User
Super User


Joined: 17 May 2005
Posts: 570
Location: Budapest, Hungary

PostPosted: Mon Sep 27, 2010 8:53 pm    Post subject: Reply with quote

Maybe your linux distribution repackaged this driver, you can download from repo with package manager. This is true for debian, ubuntu and opensuse if I know well.
Back to top
View user's profile Send private message
CarlosinFL
General User
General User


Joined: 27 Sep 2010
Posts: 5

PostPosted: Wed Oct 20, 2010 9:24 am    Post subject: Reply with quote

I didn't know my Linux workstation had to have a driver installed. What driver are you talking about? I thought I downloaded the driver from this link so why would I need to install something from my Debian or Ubuntu package manager? Is the plugin simply not enough?
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Base All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group