OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Spellcheck problems

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
Todd Marshall
General User
General User


Joined: 16 Nov 2010
Posts: 7
Location: Plantersville, TX

PostPosted: Tue Nov 16, 2010 8:17 am    Post subject: Spellcheck problems Reply with quote

[SOLVED]
OpenOffice Writer: Spell checking works for me when I start with a new document. However, after I cut and paste into the document, it quits working. If I delete what was pasted (even to a completely blank new document) it still doesn't work. With a fresh start and spell check working, I copy and paste from a document where it does not work ... even just a few characters. Above and below the insertion, spell check works. But within the insertion it doesn't work. So it seems to be paragraph dependent in some way. I've checked option settings and all appears to be in order, within and outside the problem paragraph.

On further examination I find I can get spell check working in all the above cases if I check the "in this document only" box in the spell check options. However, this is counter intuitive to me as I want to spell check (English USA default) in all my documents. Further, I don't want this behavior to change when I cut and paste into a document I'm working on.
_________________
Todd Marshall
Plantersville, TX


Last edited by Todd Marshall on Tue Nov 16, 2010 2:07 pm; edited 2 times in total
Back to top
View user's profile Send private message Visit poster's website
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Tue Nov 16, 2010 8:28 am    Post subject: Reply with quote

The spell checker works dependent on the language attribute of your text. If no language has been assigned to it, the text will be ignored. If a language has been assigned but you don't have the dictionary for it, the text will be ignored as well. For a complete guide, see Tutorial Spell check and Language configuration.

If your problem has been solved, please edit the first post in this thread and add [Solved] to the title bar.
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
Todd Marshall
General User
General User


Joined: 16 Nov 2010
Posts: 7
Location: Plantersville, TX

PostPosted: Tue Nov 16, 2010 9:22 am    Post subject: Spellcheck problems Reply with quote

Consulting the referenced tutorial:
Spell check management is set in the paragraph style. This is the first place to look at: open the Stylist (F11) and right click the Default entry, then Modify (1) and go to the Font tab (2). Make sure there is the blue ABC✓ check mark (3) in front of the language selected (meaning the dictionary is installed). If not, it means that the dictionary is not installed and you've to download it (see section 4).
If no custom template has been defined, the Default paragraph style inherits the language set in Tools>Options>Language Settings>Languages.
If you use write whole parts in different languages, you should create different paragraph styles with a different language for each.
If you have only sentences in the middle of paragraphs, you should create a character style.

I placed the cursor in a paragraph which was not responding to spell checking. I pressed F11 and went to Font finding the ABC check mark was indeed English. However, when I edit within this paragraph, spell checking is not effective. After editing I placed the cursor within the edit and again followed F11 to font and again found the check mark. Both the Default style and Text Body style (the attribute of this paragraph) have English ABC spell checking check in the font properties page.
_________________
Todd Marshall
Plantersville, TX
Back to top
View user's profile Send private message Visit poster's website
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Tue Nov 16, 2010 10:53 am    Post subject: Reply with quote

That's odd. Can you upload a sample? You can do that at www.mediafire.com.
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
Todd Marshall
General User
General User


Joined: 16 Nov 2010
Posts: 7
Location: Plantersville, TX

PostPosted: Tue Nov 16, 2010 11:09 am    Post subject: Reply with quote

Uploaded file:

http://www.mediafire.com/?c9ao9qkr65eps5i
_________________
Todd Marshall
Plantersville, TX
Back to top
View user's profile Send private message Visit poster's website
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Tue Nov 16, 2010 11:21 am    Post subject: Reply with quote

Okay, I see. What happens here is the old stuff: the pasted text has some direct formatting and the language is part of that. The thing is that direct formatting overrides paragraph style formatting and default language settings, and the direct formatting for the offending text is Unknown. Apply Clear formatting (at the top of the paragraph styles drop down list in the tool bar) and your problem will disappear.
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
Todd Marshall
General User
General User


Joined: 16 Nov 2010
Posts: 7
Location: Plantersville, TX

PostPosted: Tue Nov 16, 2010 11:43 am    Post subject: Reply with quote

I have no icon in the toolbar of the style formatting and language settings (i.e. F11) for "Clear". I have only other drop down styles (like Paragraph, Character and Frame), a Fill Format Mode icon and a New Style from Selection icon.

I searched the help for "Clear" (3 instances none pertaining to formatting) and "formatting" (no mention of clear in that context).

I also went to the Format menu item and found no opportunity to Clear there either.

Further, I don't want to clear the formatting (e.g. I want to leave italics, bold, indenting, font, etc. unaffected). So what am I clearing (if should I ever find out how to do it)?

Edited after posting above:
Found "Tools/Language/For All Text/English" and got it done.
[Solved]
_________________
Todd Marshall
Plantersville, TX
Back to top
View user's profile Send private message Visit poster's website
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Tue Nov 16, 2010 12:01 pm    Post subject: Reply with quote

Here's a screenshot of what I mean.

http://www.mediafire.com/?5wxgg6kiz7lls1a
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
Todd Marshall
General User
General User


Joined: 16 Nov 2010
Posts: 7
Location: Plantersville, TX

PostPosted: Tue Nov 16, 2010 1:37 pm    Post subject: Spellcheck problems Reply with quote

Well, I'm glad I didn't understand and use that recommendation because it wiped out all formatting. That's exactly what I said I didn't want. From now on I suggest you recommend the process I used successfully ... that of setting the language through tools where it allows you to do it for all text, for a paragraph, or for selected text. Further, the documentation is really weak on this subject ... even if you do happen to stumble upon it in the tutorial. As I presume you're not paid for your efforts. Thanks for trying.
[SOLVED}
_________________
Todd Marshall
Plantersville, TX
Back to top
View user's profile Send private message Visit poster's website
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Tue Nov 16, 2010 1:57 pm    Post subject: Reply with quote

I fully understand that you don't want to lose the formatting of your text, but sometimes direct formatting conflicts with the paragraph style definitions, like in this case. I carefully checked all options, and the only way to get rid of this unwanted formatting was to clear it all.
And while you may think that you save much time by keeping the old formatting, you just wasted a lot of time trying to find out why the spell checker didn't work. Today it's the language setting, tomorrow it could be a wrong font size or something else.

All people here are volunteers as you correctly guessed.

Please edit the first post in this thread and add [Solved] to the title bar. That will help people find it.
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
Todd Marshall
General User
General User


Joined: 16 Nov 2010
Posts: 7
Location: Plantersville, TX

PostPosted: Tue Nov 16, 2010 2:14 pm    Post subject: Spellcheck problems Reply with quote

No offense, but the solution I tripped over is the obvious first try ... even if it doesn't always work (but I suspect it does). It really should be contained with the formatting options if it is an integral part of formatting.

The document I was working with had many pages (I spared you) as I was annotating someone else's document. Losing all the formatting was not an option and probably seldom is.

It's really disappointing to be called a newbie after programming computers for over 40 years and having difficulty with the current feast of buggy and poorly designed applications ... but you can't beat the price (until you count your wasted time).
_________________
Todd Marshall
Plantersville, TX
Back to top
View user's profile Send private message Visit poster's website
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Tue Nov 16, 2010 2:20 pm    Post subject: Reply with quote

I didn't mean to offend, but we do get a lot of questions about the spell checking and many by people who make rather odd assumptions about the software. AS a result I tend to get down to my knees a lot. But I didn't mean to make you feel a newbie. Smile Sorry about that.
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
Todd Marshall
General User
General User


Joined: 16 Nov 2010
Posts: 7
Location: Plantersville, TX

PostPosted: Tue Nov 16, 2010 2:35 pm    Post subject: Spellcheck problems Reply with quote

I checked this forum and Google for the solution to this problem before starting my own thread. I didn't find the solution I used mentioned once ... and the discussion went back several years. The solutions I found didn't solve the problem even though they were marked solved. None of the recommendations seemed logical or intuitive. Of course the solution I found didn't either (at least where I found it wasn't logical), but I still bet it works in all cases ... if it doesn't, it should.

Re. the newbie thing. When I opened the thread that's what it called me. Now I'm a general user ... pretty quick progress. Again, thanks for trying.
_________________
Todd Marshall
Plantersville, TX
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group