OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Solved] Check the Regular expressions checkbox with keyboard

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
regnbage
General User
General User


Joined: 17 Sep 2010
Posts: 30

PostPosted: Thu Dec 02, 2010 8:09 am    Post subject: Solved] Check the Regular expressions checkbox with keyboard Reply with quote

Is there a quicker way to check/uncheck the Regular expressions checkbox than clicking it with a mouse?

Last edited by regnbage on Thu Dec 02, 2010 9:50 am; edited 1 time in total
Back to top
View user's profile Send private message
keme
Moderator
Moderator


Joined: 30 Aug 2004
Posts: 2910
Location: Egersund, Norway

PostPosted: Thu Dec 02, 2010 8:14 am    Post subject: Reply with quote

Can you see an underlined character in the words at the checkbox? Try alt+that letter.
Back to top
View user's profile Send private message
BillP
Super User
Super User


Joined: 07 Jan 2006
Posts: 2703

PostPosted: Thu Dec 02, 2010 8:15 am    Post subject: Reply with quote

On the Find & Replace window, the "O" in "More Options" is underlined, as is the "x" in "Regular expressions", so using the keyboard, type:

ALT+ox
Back to top
View user's profile Send private message
therabi
Super User
Super User


Joined: 01 Sep 2010
Posts: 562

PostPosted: Thu Dec 02, 2010 8:16 am    Post subject: Reply with quote

ALT+x seems to work here.
_________________
OOO v3.3.0 & LO v3.4beta on Ubuntu 10.10 and Win7
If your problem has been solved please add "[Solved]" to the beginning of your first post title (edit button).
Back to top
View user's profile Send private message
BillP
Super User
Super User


Joined: 07 Jan 2006
Posts: 2703

PostPosted: Thu Dec 02, 2010 8:26 am    Post subject: Reply with quote

therabi wrote:
ALT+x seems to work here.


It works for me only if "More Options" has been opened by pressing ALT+o or clicking the "More Options" button.
Back to top
View user's profile Send private message
regnbage
General User
General User


Joined: 17 Sep 2010
Posts: 30

PostPosted: Thu Dec 02, 2010 9:47 am    Post subject: Reply with quote

There seems no hotkey for "More Options" button in Russian translation.
I'm going to get another interface language.

Back to top
View user's profile Send private message
regnbage
General User
General User


Joined: 17 Sep 2010
Posts: 30

PostPosted: Fri Dec 03, 2010 10:05 pm    Post subject: Reply with quote

I've installed the British English interface, now Alt+ox works. Thanks for the tip.
I wrote a little script for Autohotkey, which allows switching by pressing one custom key:
Code:
CUSTOM KEY::Send {Alt down}{o}{x}{o}{Alt up}{Tab 3}


P.S. Somehow, installing the new interface cleared all the custom hotkeys in the Writer.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group