OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

[SOLVED] change data source in a form

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Base
View previous topic :: View next topic  
Author Message
ramack
General User
General User


Joined: 30 Apr 2008
Posts: 45
Location: Centennial, CO

PostPosted: Wed Jun 15, 2011 6:14 am    Post subject: [SOLVED] change data source in a form Reply with quote

I have a form created with the form wizard, and I want to check and change the data source (query). I don't find a way to do so as you can similarly do in a report. Once a form is created, is the data source fixed?

Rich


Last edited by ramack on Wed Jun 15, 2011 9:13 am; edited 1 time in total
Back to top
View user's profile Send private message
r4zoli
Super User
Super User


Joined: 17 May 2005
Posts: 570
Location: Budapest, Hungary

PostPosted: Wed Jun 15, 2011 7:52 am    Post subject: Reply with quote

Open form in edit mode, open form navigator on form design toolbar, select MainForm properties, on Data tab you can change the from data source.
Back to top
View user's profile Send private message
ramack
General User
General User


Joined: 30 Apr 2008
Posts: 45
Location: Centennial, CO

PostPosted: Wed Jun 15, 2011 8:01 am    Post subject: Reply with quote

I don't know why, but I can not display the Form Controls or Form Design Toolbars. Is this a Java problem?
Back to top
View user's profile Send private message
ramack
General User
General User


Joined: 30 Apr 2008
Posts: 45
Location: Centennial, CO

PostPosted: Wed Jun 15, 2011 9:12 am    Post subject: Reply with quote

This appears to be a bug with LibreOffice....
Back to top
View user's profile Send private message
RPG
Super User
Super User


Joined: 24 Apr 2008
Posts: 2697
Location: Apeldoorn, Netherland

PostPosted: Wed Jun 15, 2011 11:12 am    Post subject: Reply with quote

Hello

Make standalone forms in stead of forms part of your databasedocument.

Romke
Back to top
View user's profile Send private message
Villeroy
Super User
Super User


Joined: 04 Oct 2004
Posts: 10106
Location: Germany

PostPosted: Wed Jun 15, 2011 11:16 am    Post subject: Reply with quote

ramack wrote:
This appears to be a bug with LibreOffice....

I can not confirm any such bug in LibreOffice 3.3.(Windows) nor 3.4.(Linux)
_________________
Rest in peace, oooforum.org
Get help on https://forum.openoffice.org
Back to top
View user's profile Send private message
ramack
General User
General User


Joined: 30 Apr 2008
Posts: 45
Location: Centennial, CO

PostPosted: Thu Jun 16, 2011 8:36 am    Post subject: Reply with quote

Villeroy wrote:
ramack wrote:
This appears to be a bug with LibreOffice....

I can not confirm any such bug in LibreOffice 3.3.(Windows) nor 3.4.(Linux)


When I was looking for problems, I found this thread . I upgraded to 3.4 (Debian Linux), it worked after the upgrade. Other issue that I was having was the toolbar was blank until the mouse hovered over the button.
Back to top
View user's profile Send private message
ramack
General User
General User


Joined: 30 Apr 2008
Posts: 45
Location: Centennial, CO

PostPosted: Wed Jun 22, 2011 7:17 am    Post subject: Reply with quote

RPG wrote:
Hello

Make standalone forms in stead of forms part of your databasedocument.

Romke


How is that done?
Back to top
View user's profile Send private message
Villeroy
Super User
Super User


Joined: 04 Oct 2004
Posts: 10106
Location: Germany

PostPosted: Wed Jun 22, 2011 7:32 am    Post subject: Reply with quote

http://user.services.openoffice.org/en/forum/viewtopic.php?f=13&t=27662&p=125944
_________________
Rest in peace, oooforum.org
Get help on https://forum.openoffice.org
Back to top
View user's profile Send private message
ramack
General User
General User


Joined: 30 Apr 2008
Posts: 45
Location: Centennial, CO

PostPosted: Wed Jun 22, 2011 8:38 am    Post subject: Reply with quote

Villeroy wrote:
http://user.services.openoffice.org/en/forum/viewtopic.php?f=13&t=27662&p=125944


Thank you!

Rich
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Base All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group