OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

[Solved] BootstrapException: no office executable found!

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Macros and API
View previous topic :: View next topic  
Author Message
Aleksejs
Newbie
Newbie


Joined: 25 Jul 2011
Posts: 2

PostPosted: Mon Jul 25, 2011 8:29 am    Post subject: [Solved] BootstrapException: no office executable found! Reply with quote

Hello, guys.
I realize the question sounds a bit common, and prolly there is a solution already, but I've honestly spent around 15mins looking for it in here. Smile

I've installed OOo 3 & it's SDK. I am using Windows7 64. The goal for now is to atleast simply convert a bunch of docs into pdfs, using example DocumentConverter.java, kindly provided by OOo SDK.

I've tried a million ways to run/not run soffice.exe, the result remains the same: I cannot obtain the remote office component context.

JAR's aren't copied-over (i use \OpenOffice.org 3\URE\java path). The environment is Eclipse Java EE IDE Indigo.

Many thanks to everyone, who will provide any help.
Aleksejs.

Tagged as solved - floris v
Back to top
View user's profile Send private message
hol.sten
Super User
Super User


Joined: 14 Nov 2004
Posts: 3533
Location: Hamburg, Germany

PostPosted: Mon Jul 25, 2011 12:34 pm    Post subject: Reply with quote

BootstrapException: no office executable found! has been discussed and solved in various OOo forums. Try this solution for example:
[Java solution] "no office executable found!": http://user.services.openoffice.org/en/forum/viewtopic.php?f=44&t=2520.
And take a look at this thread:
[Java] Caution with Bootstrap using OOo 3.0.0: http://user.services.openoffice.org/en/forum/viewtopic.php?f=44&t=10825, which explains why NOT moving around OOo's JAR does not suffice since OOo 3.0.0.
Back to top
View user's profile Send private message
Aleksejs
Newbie
Newbie


Joined: 25 Jul 2011
Posts: 2

PostPosted: Mon Jul 25, 2011 11:30 pm    Post subject: Reply with quote

many thanks! it is solved.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Macros and API All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group