OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

[issue] OO Won't Start - Error when Loading VCRT Library
Goto page Previous  1, 2
 
Post new topic   Reply to topic    OOoForum.org Forum Index -> Setup and Troubleshooting
View previous topic :: View next topic  
Author Message
Ruler2112
General User
General User


Joined: 18 Nov 2011
Posts: 8

PostPosted: Thu Jan 05, 2012 11:36 am    Post subject: Reply with quote

I contacted the web chat vendor and much to my surprise, they already knew all about the problem. She said that it was a problem with the way OO is distributing the VCRT runtime and that there's an open bug on it already. Surprisingly, the bug was opened in October of 2009 and is flagged as trivial. The problem DLL is Microsoft.VC80.CRT.MANIFEST. I downloaded a different version of the web chat software customized for OO users and things are now working normally again, but wanted to report back for the benefit of those who may find this information useful in the future. I'd wager that many of the errors similar to this could be traced back to the same root cause, but that's little more than gut feeling.

Thanks to all who responded trying to help. Smile
Back to top
View user's profile Send private message
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Thu Jan 05, 2012 11:44 am    Post subject: Reply with quote

Thanks for reporting that. Smile Much appreciated.
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
jamessmithonlinenow
Newbie
Newbie


Joined: 06 Jan 2012
Posts: 1

PostPosted: Fri Jan 06, 2012 5:36 am    Post subject: Re: [issue] OO Won't Start - Error when Loading VCRT Library Reply with quote

I think the bin file is damaged. Please re install a new copy of O Office. Visit here for a similler problem http://www.techyv.com/questions/openofficeorg-22-failed-initiate
Ruler2112 wrote:
One of my users is having trouble with OpenOffice and I really don't know what else to try. The computer is a dual-core AMD running XP SP3 with 2 gig of RAM. She gets the following:

Code:

---Microsoft Visual C++ Runtime Library---

Runtime Error!

Program: c:\Program Files\OpenOffice.org 3\program\soffice.bin

R6034
An application has made an attempt to load the C runtime library incorrectly.
Please contact the application's support team for more information.

OK


This messagebox comes up and the program immediately dies when you hit OK. It doesn't matter what component (writer, calc, draw, etc) you open or if you double-click on a document (OO or otherwise).

So far, I've tried reinstalling OpenOffice 3.2. I tried 3.1. I tried 3.3. I tried LibreOffice 3.4. I tried removing OpenOffice, deleting all directories remotely connected with OpenOffice, rebooting, and then installing fresh. I tried downloading and installing the M$ Visual C++ runtime for 2005, 2008, and 2010. (At least I think those were the years; I know I tried 3 different ones, rebooting between each.) I tried different version of JRE. After all this had no effect, I finally gave up and reinstalled windoze. Great – OpenOffice worked and opened without erroring out! The next day, she called me and the above error was popping up again and OO was inaccessible.

I've found references to this error online at M$, but don't understand most of it (I haven't coded for windoze in years – unix/linux is where I code). Plus, I know it's not a problem with the program itself, as the same exact thing works on other systems without any problems. I'm frankly out of ideas and at a loss of what to try at this point.

Any ideas as to what I could do to troubleshoot or fix the problem?

Tagged as issue - floris v, moderator
Back to top
View user's profile Send private message
francke
Newbie
Newbie


Joined: 12 May 2012
Posts: 1

PostPosted: Sat May 12, 2012 6:26 am    Post subject: Reply with quote

Ruler2112 wrote:
OK, just discovered something VERY strange about this problem. (Still waiting on the activation e-mail from the other forum.)

The user whose machine this is uses a web chat program to answer inquiries from visitors to our web site. If that program is shut down, OO works fine. If it's running, the error above happens. (Nice process separation by windoze...)

I'm contacting the company which provides the web chat program, but honestly don't expect to get far. Anybody here have ideas for further troubleshooting?


I came to the forum because I was having the same runtime error... and I use Contactatonce chat software. Turn off the contact at once, and now open office works! Thank you!
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> Setup and Troubleshooting All times are GMT - 8 Hours
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group