OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Installing fonts in OO 1.1.3 under Linux

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> Setup and Troubleshooting
View previous topic :: View next topic  
Author Message
Frank Billington
OOo Advocate
OOo Advocate


Joined: 10 Feb 2004
Posts: 226

PostPosted: Mon Nov 08, 2004 6:41 pm    Post subject: Installing fonts in OO 1.1.3 under Linux Reply with quote

OK, finally got OO 1.1.3 to install (whew!) Installer wouldn't upgrade my previous 1.1.0 install, so I installed 1.1.3 in another directory. Both of them work.

Now, the tarball for 1.1.3 came with a limited number of fonts. My previous install of 1.1.0 has more fonts. I want to make them available to 1.1.3.

Help system for 1.1.3 says to go to the program directory, which on my machine is at: /usr/local/OpenOffice.org1.1.3 and run spadmin, which I did. That opens a console, and an x-window. In the x-window, I am to select the "fonts" button, and navigate to the location of the fonts I want to add.

I did a bit of poking around on my system first, and found a lot of fonts in the /usr/share/fonts directory (or, more accurately, in the sub-directories under it). So, I began to navigate there. However, when I arrive, and though file manager shows a lot of fonts installed in the sub-directores under it, NOTHING SHOWS in the spadmin window. It remains blank, which means, of course, that there are no fonts in the spadmin list window for me to add.

I assume that spadmin must be looking for a particular kind of font, and that the ones in the /usr/share/fonts directory (and the directories under it) are not that type.

So, where do I go from here? What type of file is spadmin looking for, and where will I find them?

I did not change my original OO 1.1.0 installation at all. Everything is still there -- untouched.

Thanks.

Frank.
Back to top
View user's profile Send private message
nhall
General User
General User


Joined: 11 Jun 2004
Posts: 31
Location: West of Boston, MA, USA

PostPosted: Thu Nov 11, 2004 3:46 am    Post subject: Reply with quote

To install additional fonts in OO 1.1.x, open Spadmin. In the Spadmin window, click on the Fonts button at the bottom of the window. A different window will open. In this new window click on the Add button which will open a third window. In this third window you can navigate to any Linux directory. Tru-type Font files have the suffix *.tty. i suggest you do a Google search with the argument 'Linux Fonts' which will give you additional information. I hope this gets you started.
Norm.
Back to top
View user's profile Send private message
Frank Billington
OOo Advocate
OOo Advocate


Joined: 10 Feb 2004
Posts: 226

PostPosted: Thu Nov 11, 2004 6:10 pm    Post subject: Reply with quote

nhall:

I had already done as you suggested. I assumed that the fonts would show up in the browse window in the directory I was selecting. They don't, and that is what I found confusing. In the browse window, all I am selecting is the directory to look in. I navigated to the previously found directory, and it was still blank. This time, however I chose to select that directory in the browse window anyway. The browse window closed, but NOW all the fonts in that selected directory appeared in the "add fonts" window. I selected them all, then added them all. OO 1.1.3 now has the full complement of fonts that 1.1.0 had.

Thanks.

Frank.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> Setup and Troubleshooting All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group