OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

OOo 3.3 installed an old version of JRE on my PC

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> Setup and Troubleshooting
View previous topic :: View next topic  
Author Message
valoprube
General User
General User


Joined: 10 Mar 2012
Posts: 6
Location: New Jersey, USA

PostPosted: Sat Mar 10, 2012 2:12 pm    Post subject: OOo 3.3 installed an old version of JRE on my PC Reply with quote

When I installed OOo 3.3 on my PC, an older version of JRE ((Java 6 Update 22) was installed along with it. Can/should this be replaced with the latest version (Java 6 Update 31)?
Back to top
View user's profile Send private message
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Sat Mar 10, 2012 2:50 pm    Post subject: Reply with quote

Yes, that's no problem. You can also tell OOo to use the version you already had. (Tools - Options - OpenOffice - Java.)

If your problem has been solved, please edit the first post in this thread and add [Solved] to the title bar.
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
valoprube
General User
General User


Joined: 10 Mar 2012
Posts: 6
Location: New Jersey, USA

PostPosted: Sat Mar 10, 2012 9:02 pm    Post subject: Reply with quote

floris_v wrote:
Yes, that's no problem. You can also tell OOo to use the version you already had. (Tools - Options - OpenOffice - Java.)

If your problem has been solved, please edit the first post in this thread and add [Solved] to the title bar.


I'm not experiencing a problem. I downloaded/installed OOo 3.3 six days ago from www.openoffice.com after a clean installation of my operating system. JRE was not on my machine yet because I didn't know that OOo required it.

Is it safe to assume that OOo thought that I would be better off using JRE U22 instead of JRE U31, the most recent version?

If I do another clean installation of the operating system at some point in the distant future, would you suggest that I repeat what I just did or would you recommend that I install the most recent version of JRE before installing OOo? Thanks.
Back to top
View user's profile Send private message
PGAGA
OOo Advocate
OOo Advocate


Joined: 01 Aug 2004
Posts: 303

PostPosted: Wed Mar 14, 2012 10:14 am    Post subject: Reply with quote

March 14, 2012

Update to U31. U22 was likely the one bundled with the install and would have been the latest at the time the bundle was created.

Phil
_________________
Phil Griffin-Allwood
New Brunswick, Canada
Back to top
View user's profile Send private message
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Wed Mar 14, 2012 10:31 am    Post subject: Reply with quote

That doesn't really matter, as long as you don't try to link OOo to Java 7, it should be okay.
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
PGAGA
OOo Advocate
OOo Advocate


Joined: 01 Aug 2004
Posts: 303

PostPosted: Wed Mar 14, 2012 7:19 pm    Post subject: Reply with quote

Thursday, March 15, 2012

floris_v wrote:
That doesn't really matter, as long as you don't try to link OOo to Java 7, it should be okay.


Only if you are not using Java with anything else

Phil
_________________
Phil Griffin-Allwood
New Brunswick, Canada
Back to top
View user's profile Send private message
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Thu Mar 15, 2012 12:09 am    Post subject: Reply with quote

I used to have a few versions of the JRE side by side, but maybe Java now removes older versions when you install a new one.
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
PGAGA
OOo Advocate
OOo Advocate


Joined: 01 Aug 2004
Posts: 303

PostPosted: Thu Mar 15, 2012 7:08 am    Post subject: Reply with quote

Thursday, March 15, 2012

floris_v wrote:
I used to have a few versions of the JRE side by side, but maybe Java now removes older versions when you install a new one.


You can run versions side by side 1.5, 1.4, 1.6, 1.7 But for security reasons one should always use the latest update of the version, unless the update has broken something.

Phil
_________________
Phil Griffin-Allwood
New Brunswick, Canada
Back to top
View user's profile Send private message
valoprube
General User
General User


Joined: 10 Mar 2012
Posts: 6
Location: New Jersey, USA

PostPosted: Thu Mar 15, 2012 10:09 pm    Post subject: Reply with quote

Phil,
Thanks for your help. I monitorred the installation of OOo 3.3 using "Total Uninstall" and the "Total Uninstall" log indicates that it also monitored the installation of JRE 6 Update 22. So if I uninstall using "Total Uninstall", it should cleanly remove both OOo 3.3 and JRE 6 Update 22.

Do you think that I should then first install JRE 6 Update 31 and that after this is done install OOo 3.3?
Will OOo 3.3 recognize that JRE Update 31 is installed and not try to replace it with JRE6 Update 22?
Back to top
View user's profile Send private message
PGAGA
OOo Advocate
OOo Advocate


Joined: 01 Aug 2004
Posts: 303

PostPosted: Fri Mar 16, 2012 5:22 am    Post subject: Reply with quote

March 16, 2012

I would just install the the Java update. I never use the OOo install with Java included. I install the programs separately.

After you install the Java update, then use the OOo options to select U31 as the one you use.

Phil

valoprube wrote:
Phil,
Thanks for your help. I monitorred the installation of OOo 3.3 using "Total Uninstall" and the "Total Uninstall" log indicates that it also monitored the installation of JRE 6 Update 22. So if I uninstall using "Total Uninstall", it should cleanly remove both OOo 3.3 and JRE 6 Update 22.

Do you think that I should then first install JRE 6 Update 31 and that after this is done install OOo 3.3?
Will OOo 3.3 recognize that JRE Update 31 is installed and not try to replace it with JRE6 Update 22?

_________________
Phil Griffin-Allwood
New Brunswick, Canada
Back to top
View user's profile Send private message
valoprube
General User
General User


Joined: 10 Mar 2012
Posts: 6
Location: New Jersey, USA

PostPosted: Fri Mar 16, 2012 8:36 am    Post subject: Reply with quote

Phil,
What Web site will enable me to install OOo without installing JRE and how do I navigate to the JRE-free installation?
Back to top
View user's profile Send private message
PGAGA
OOo Advocate
OOo Advocate


Joined: 01 Aug 2004
Posts: 303

PostPosted: Fri Mar 16, 2012 7:47 pm    Post subject: Reply with quote

Saturday, March 17, 2012

valoprube wrote:
Phil,
What Web site will enable me to install OOo without installing JRE and how do I navigate to the JRE-free installation?


Download from here, but make sure you uncheck the "Include the JRE to the download" option:

http://www.openoffice.org/download/other.html

Phil
_________________
Phil Griffin-Allwood
New Brunswick, Canada
Back to top
View user's profile Send private message
valoprube
General User
General User


Joined: 10 Mar 2012
Posts: 6
Location: New Jersey, USA

PostPosted: Mon Mar 19, 2012 9:48 am    Post subject: Reply with quote

Phil,
Thank you so much. I now have the latest updates of JRE and OOo installed separately.
Matthew
Back to top
View user's profile Send private message
valoprube
General User
General User


Joined: 10 Mar 2012
Posts: 6
Location: New Jersey, USA

PostPosted: Mon Mar 19, 2012 5:39 pm    Post subject: Reply with quote

My wording in the previous post was incorrect. It should be:

I now have the latest versions of JRE and OOo installed separately.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> Setup and Troubleshooting All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group