OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

How to insert a fixed text in a report after the data

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Base
View previous topic :: View next topic  
Author Message
darkshark
General User
General User


Joined: 08 Feb 2010
Posts: 32

PostPosted: Wed Mar 28, 2012 5:14 am    Post subject: How to insert a fixed text in a report after the data Reply with quote

Hi,
i've created a simple report form a table, and i'm trying to insert some fixed text.
After some of tests i've come up with some problems/discovery...

- If i write some plain text before the table where are written the imported data, the text will show up when i generate the report

- if insert a simple table before the table where are written the imported data, the table will not show up when i generate the report

- If i insert anything after the table where are written the imported data, nothing show up when i generate the report.

I think that there's some option that i miss to set when i edit the report, but i'm really unable to find what is it...

Thank you in advance for any help, and sorry form my bad english.
Back to top
View user's profile Send private message
mgroenescheij
Super User
Super User


Joined: 20 Apr 2011
Posts: 870
Location: Australia

PostPosted: Wed Mar 28, 2012 8:55 pm    Post subject: Reply with quote

Hi,

You can add text by inserting a label field in your report, if you add this in your Details section it will be shown for every record.
It's hard to understand what you have tried so far.
What do you mean with "if insert a simple table before the table where are written the imported data"?
Probably uploading your file to www.mediafire.com will help us to understand your problem better.

Martin
_________________
If your problem has been solved please add "[Solved]" to the beginning of your first post title (edit button).
Back to top
View user's profile Send private message
darkshark
General User
General User


Joined: 08 Feb 2010
Posts: 32

PostPosted: Thu Mar 29, 2012 12:14 am    Post subject: Reply with quote

Hi,
i don't know exactly what i should upload, i can't upload all the db because it contains a lot of working data.

I'll try to better explain my problem:
I've just create ad very standard and simple report from one database table with the report creation wizard included in ooo Base.

Afer the creation of the report with the wizard i've open it in edit mode (ooo Base use ooo Writer to edit the reports, so form this point i think it's more a ooo Writer question then a ooo Base question).

Afer opening the report in edit mode, you can see that in the body of the document you have the table where Base will write the data that import from the database table.

What i'm trying to do is to add some fixed text (not imported each time form the db table) to the report before and after the table with the imported data.

If you open a report in edit mode and simply write some text before the table with the imported data, afer you save and open the report by double clicking on it, you could see that the text you have written will shows up exaclty as you had written and formatted it in edit mode.

But, if you try to write something in edit mode, after the table with the imported data, when you save and open the report by double clicking on it, nothing will show up.

If my problem is still unclear i can build a simple db with 1 table and 1 report that show the problem.

Thanks for the help!
Back to top
View user's profile Send private message
mgroenescheij
Super User
Super User


Joined: 20 Apr 2011
Posts: 870
Location: Australia

PostPosted: Thu Mar 29, 2012 1:52 am    Post subject: Reply with quote

Hi,

First of all when you run in Base the report it creates a Writer document.
By default this document is write protected, when you save this document in editing mode you can change the content.
The problem is that when you re-run the report from Base it overwrite the document.
So the solution should be that you add the text in the report in Base.
If the text is a constant you could do this by inserting a label field.
It's also possible to add fixed text in a query.

Martin
_________________
If your problem has been solved please add "[Solved]" to the beginning of your first post title (edit button).
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Base All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group