OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Fractions problem

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Calc
View previous topic :: View next topic  
Author Message
David
Super User
Super User


Joined: 24 Oct 2003
Posts: 5668
Location: Canada

PostPosted: Sat Jan 08, 2005 4:48 pm    Post subject: Fractions problem Reply with quote

It's quite unnecessary really. Entering fractions in a cell, it is necessary to first format. Entering 2/3 appears as a date default otherwise. Furthermore, if you enter 1/2 or 3/4 it is auto-formatted as text? Formatting first as fraction makes no difference. Formatting after entry makes no difference either, since it is apparently ignored. If 3/4 or 1/2 is entered, it switches to what ever the default format is.

Is there any way around this besides fiddling with formulas?

Thanks.

David.
Back to top
View user's profile Send private message
multi-lingual_ooo
OOo Advocate
OOo Advocate


Joined: 06 Nov 2004
Posts: 458

PostPosted: Sun Jan 09, 2005 3:56 am    Post subject: Re: Fractions problem Reply with quote

Quote:
Entering 2/3 appears as a date default otherwise.


Styles.

">Format >Catalog >Catalog Styles >Cell Styles >Numbers"
Select Fraction.


I'd suggest that you have one cell style for fractions, and another for the other numbers that you use.

xan

jonathon
_________________
One of the following might contain more details:

http://oooauthors.org/en/members/tutorials/multilingualooo/
http://esnips.com/web/OOoRelatedThings/
http://esnips.com/web/GraphologyTools
Back to top
View user's profile Send private message Send e-mail
JohnV
Administrator
Administrator


Joined: 07 Mar 2003
Posts: 9183
Location: Lexinton, Kentucky, USA

PostPosted: Sun Jan 09, 2005 8:26 am    Post subject: Reply with quote

In addition when formatting your cells as fractions you want to turn off Tools > AutoCorrect > Options tab > "Replace 1/2 with...." to avoid 1/2 & 3/4 changing to text.
Back to top
View user's profile Send private message
David
Super User
Super User


Joined: 24 Oct 2003
Posts: 5668
Location: Canada

PostPosted: Sun Jan 09, 2005 9:52 am    Post subject: Reply with quote

JohnV wrote:
In addition when formatting your cells as fractions you want to turn off Tools > AutoCorrect > Options tab > "Replace 1/2 with...." to avoid 1/2 & 3/4 changing to text.


That did it. Thanks!

David.
Back to top
View user's profile Send private message
gear
Newbie
Newbie


Joined: 09 Jan 2005
Posts: 4

PostPosted: Sun Jan 09, 2005 10:11 am    Post subject: Reply with quote

Quote:
">Format >Catalog >Catalog Styles >Cell Styles >Numbers"
Select Fraction.


So I do that and try to enter my first fraction -- 7/16, which is promptly turned into 4/9. I turn off the autocorrect thing, still my 7/16 is 4/9. So I say, "ok, I will move on". Next fraction is 41/64.

Oh dear, it thinks 41/64 is 5/8.

Why does it keep replacing the actual fractions with some other fraction that is not even close?

g
Back to top
View user's profile Send private message
JohnV
Administrator
Administrator


Joined: 07 Mar 2003
Posts: 9183
Location: Lexinton, Kentucky, USA

PostPosted: Sun Jan 09, 2005 10:29 am    Post subject: Reply with quote

gear,

Hadn't notice that but in the format dialog you have a choice of 1/8 or 10/81 and the 2nd one will fix your complaint. Unfortunately it displays a leading blank for 1/2., i.e., 1/ 2. If you have a fraction like 364/365 you can "roll your own" format code as # ???/???.
Back to top
View user's profile Send private message
bobharvey
Super User
Super User


Joined: 23 Apr 2004
Posts: 1075
Location: Lincolnshire

PostPosted: Sun Jan 09, 2005 10:29 am    Post subject: Reply with quote

gear wrote:
7/16, which is promptly turned into 4/9.

Check the precision in the 'fractions' format. If you change from "# ?/?" to "# ?/???" you may get what you want.

See the help pages for "entering fractions" and "number format codes" for more details.
Back to top
View user's profile Send private message
gear
Newbie
Newbie


Joined: 09 Jan 2005
Posts: 4

PostPosted: Sun Jan 09, 2005 2:20 pm    Post subject: Reply with quote

Thank yall for the fast responses.

Ok, changing the format kinda fixed it. I should have seen the different options available from which to choose. Most of the fractions work fine now, though there are a couple that act a tad strange. I have the # ??/?? selected and enter 63/64 with no prob, but 31/32 is rounded up to 1.

I wouldn't be so persnickety but I am listing a bunch of collets for machine tools, and, as you might know, most tend to all be fractional.

g
Back to top
View user's profile Send private message
bobharvey
Super User
Super User


Joined: 23 Apr 2004
Posts: 1075
Location: Lincolnshire

PostPosted: Sun Jan 09, 2005 2:53 pm    Post subject: Reply with quote

gear wrote:
Thank yall for the fast responses.
Well, that's what makes the world go round. I've had some useful help on here, and you have to pay your dues in this world.
Quote:
but 31/32 is rounded up to 1.
That is odd. It works fine here, as does "0 ?/??" to force a zero inch leading number. I'd suggest a clean sheet, or clearing out formats everywhere and starting again
Quote:
I am listing a bunch of collets for machine tools, and, as you might know, most tend to all be fractional.
Not for 35 years, in my experience. Apart from Trend router cutters, which is annoying because my Bosch came with a 12mm collet, and a half inch shaft is not safe in there!
Back to top
View user's profile Send private message
gear
Newbie
Newbie


Joined: 09 Jan 2005
Posts: 4

PostPosted: Sun Jan 09, 2005 3:41 pm    Post subject: Reply with quote

True about putting in the time. I spent a bit helping out at nukecops a while back.

Tried the new page and the leading 0, but still no joy.

Started experimenting. Anything with a denominator greater than 24 and less than 50 is rounded up to 1 for me, so something is off.

I am starting to wonder if I should wrap my office with aluminum foil and clamp special, high grade permanent magnets to my computer to fend off the evil Byte Faeries....

g
Back to top
View user's profile Send private message
David
Super User
Super User


Joined: 24 Oct 2003
Posts: 5668
Location: Canada

PostPosted: Sun Jan 09, 2005 4:02 pm    Post subject: Reply with quote

gear wrote:
Thank yall for the fast responses.

Ok, changing the format kinda fixed it. I should have seen the different options available from which to choose. Most of the fractions work fine now, though there are a couple that act a tad strange. I have the # ??/?? selected and enter 63/64 with no prob, but 31/32 is rounded up to 1.

g


Again, you must also format that cell to #?/??, or #??/??, but the first will do the trick and you'll see 31/32 as 31/32, not 1 as in the default. I could look around, but perhaps some kind soul already in the know can tell how to set the default fraction to 2 or more figures in the denominator.

David.
Back to top
View user's profile Send private message
gear
Newbie
Newbie


Joined: 09 Jan 2005
Posts: 4

PostPosted: Sun Jan 09, 2005 6:43 pm    Post subject: Reply with quote

David:

I tried deleting the space between the whole number and the fraction as you suggested, but still no joy. I am simply sent to the line number of the numerator.

It's late, I'm tired, and frickin wifey got the lists done in less than 5 minutes on the brand X spreadsheet. grrr

Thanks to all of yall for the help,

g
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Calc All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group