OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

All text underlined all the time when using spellcheck
Goto page 1, 2  Next
 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
riofield74
Newbie
Newbie


Joined: 31 May 2012
Posts: 4

PostPosted: Thu May 31, 2012 2:50 am    Post subject: All text underlined all the time when using spellcheck Reply with quote

As the title says using Open Office 3.3 and for some reason all of the text is underscored in red when using spell check. It doesn't appear to recognise the simplest of words such as 'the' and 'such' and 'as'.

Any help would be appreciated.
Back to top
View user's profile Send private message
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Thu May 31, 2012 2:59 am    Post subject: Reply with quote

Try Tutorial Spell check and Language configuration
The most obvious explanation is that you selected the wrong language for that text.
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
riofield74
Newbie
Newbie


Joined: 31 May 2012
Posts: 4

PostPosted: Thu May 31, 2012 4:46 am    Post subject: Reply with quote

Hi there

Thanks for the swift response. Could the following be causing this problem?

The User Interface Language is English US as the default however the locale is English (UK) and Western is also English UK.

How can I change the User Interface Language to English UK?
Back to top
View user's profile Send private message
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Thu May 31, 2012 5:49 am    Post subject: Reply with quote

Please check the tutorial, then tell us where you get stuck. The interface language has nothing to do with this.
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
riofield74
Newbie
Newbie


Joined: 31 May 2012
Posts: 4

PostPosted: Thu May 31, 2012 6:47 am    Post subject: Reply with quote

UK English is now default language.

I have removed both French and Spanish dictionaries.

Points 5-8 of the FAQ do not seem to be applicable.

The text is still all underscored in red. I have tried to create a new text document. The only word was Hello. It said that this was not in the English UK dictionary and suggested the word Telco.

Any ideas?
Back to top
View user's profile Send private message
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Thu May 31, 2012 8:24 am    Post subject: Reply with quote

Don't start new documents from Windows Explorer. There was/is a bug that breaks the dictionary link. Open OOo and start new documents from there.
Changing the default language doesn't affect existing documents, only new documents started within OOo.
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
riofield74
Newbie
Newbie


Joined: 31 May 2012
Posts: 4

PostPosted: Fri Jun 01, 2012 12:44 am    Post subject: Reply with quote

I'm afraid I have already tried this. Opened and Created a new document using Open Office. Hello is still underlined.
Back to top
View user's profile Send private message
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Fri Jun 01, 2012 2:48 am    Post subject: Reply with quote

Can you upload a sample at www.mediafire.com (and post a link here) or, better, register at the new forum and upload it there as an attachment? Don't forget to post a link to the topic in the new forum if you do.
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
mgarthwaite
Newbie
Newbie


Joined: 19 Jun 2012
Posts: 4

PostPosted: Tue Jun 19, 2012 9:44 am    Post subject: Only English is underlined all the time by spell checker Reply with quote

Similar to this thread, all English is underlined all the time by spell checker. I've been through the tutorial and the troubleshooting routines to no avail. "English" with the blue check mark shows up in the Paragraph Style: Default/Font/Language. I am using OO 3.4 on a Vista machine -- I had the same problem with 00 3.3 (removed 3.3 and installed 3.4 today, but didn't fix the problem).

I have a laptop with OO on it which works just fine. Very baffling problem.
Back to top
View user's profile Send private message
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Tue Jun 19, 2012 9:46 am    Post subject: Reply with quote

Upload a test document please.
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
mgarthwaite
Newbie
Newbie


Joined: 19 Jun 2012
Posts: 4

PostPosted: Tue Jun 19, 2012 9:53 am    Post subject: Reply with quote

floris_v wrote:
Upload a test document please.

This is going to sound really stupid, but I don't see an "upload" option?? I'm not generally so clueless... (thank you for the reply)

Okay, here's a link to it on Dropbox

https://www.dropbox.com/s/f8sw3jh0d17v18e/test.odt
Back to top
View user's profile Send private message
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Tue Jun 19, 2012 11:07 am    Post subject: Reply with quote

Reread my previous post.
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
jrkrideau
Super User
Super User


Joined: 08 Aug 2005
Posts: 6732
Location: Kingston ON Canada

PostPosted: Wed Jun 20, 2012 5:50 am    Post subject: Reply with quote

mgarthwaite wrote:
floris_v wrote:
Upload a test document please.

This is going to sound really stupid, but I don't see an "upload" option?? I'm not generally so clueless... (thank you for the reply)

Okay, here's a link to it on Dropbox

https://www.dropbox.com/s/f8sw3jh0d17v18e/test.odt



Seems fine to me in LibreOffice 3.5.3.2 & Ubuntu 12.04. It is showing an active USA English dictionary.
_________________
jrkrideau
Kingston ON Canada
Currently using Windows 7 & OOo 3.4.0 and Ubuntu 12.04 & LibreOffice 3.5.2.2
Back to top
View user's profile Send private message
mgarthwaite
Newbie
Newbie


Joined: 19 Jun 2012
Posts: 4

PostPosted: Wed Jun 20, 2012 7:08 am    Post subject: Reply with quote

The test document I put on Dropbox works for me too... but on a different computer. On a Windows 7 laptop with OO 3.3 I don't have any problems. The document opens, the word "test" is not flagged as being misspelled (spell checker is on). All good.

However, on my desktop, Windows 7 Professional, under both OO 3.3 and now under OO 3.4, the word "test" is flagged as being misspelled. The English (USA) dictionary is installed and has the blue check mark (with "ABC" above it) is visible under "Language" in the "Paragraph Style: Default." and in "Tools/Options/Languages Settings/Languages"

Strangely, when (on the desktop) I go through the "[Tutorial] Spell check and Language configuration" and "[Troubleshooting] Spell check in OOo 3.x" routines (during which everything checks out) and I download and look at "Spellcheck_samples.odt" the ONLY words in the sample which are underlined (as being misspelled) are the English and Latin words. The French and Spanish words are not underlined. It's like there is something wrong with the US English dictionary, like OO isn't finding it.
Back to top
View user's profile Send private message
floris_v
Moderator
Moderator


Joined: 12 Jul 2007
Posts: 4791
Location: Netherlands

PostPosted: Wed Jun 20, 2012 12:41 pm    Post subject: Reply with quote

Copy the en.oxt from your user profile to a safe place, reset your user profile. Click here for help how to do that. Re-install all extensions.
_________________
LibreOffice 3.6.3; OOo 3.4.1 on Windows Vista
Join the Official community forum - in several languages, including Nederlandstalig forum
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group