OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

vector arrow too much separated

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Math
View previous topic :: View next topic  
Author Message
fullpull
Guest





PostPosted: Tue Feb 04, 2003 1:11 am    Post subject: vector arrow too much separated Reply with quote

When I write this expression:

vec P

The vector arrow is too mech separated from the P letter (too high).
It may be: ->
P

And is: ->

P

A friend of mine has the same problem.
I modified the "Spacing" (Format->Spacing) but doesn't work.
Back to top
rhone
General User
General User


Joined: 21 Jan 2003
Posts: 25

PostPosted: Tue Feb 04, 2003 3:22 pm    Post subject: Reply with quote

This could be a font issue. Have you tried all of the spacing settings (other spacing settings can be accessed by clicking on the 'category' button in the spacing dialog).

Another option is to use something like 'binom rightarrow P'.
Back to top
View user's profile Send private message
Guest






PostPosted: Wed Feb 12, 2003 12:46 pm    Post subject: Re: vector arrow too much separated Reply with quote

I know this problem from 'tilde c'. This should create the letter 'c' with a serpentthing above. But in OO1.0.1 the serpent is too high, the distance is too big.

The funny thing is: when i save the document in starwriter 5 format and open the document whth SO5.2, the thing is as it should be!!
Back to top
Guest






PostPosted: Tue Mar 11, 2003 8:01 am    Post subject: Reply with quote

I have a same problem and it's very frustrating. I've tried other font and spacing settings, but nothing helped.

Does it relate anyhow with the Symbol font?
Back to top
Santaoja
Guest





PostPosted: Thu Mar 13, 2003 11:56 am    Post subject: Arrows and other similar objects too high Reply with quote

Dear OOo Users

There is a bug in the code. I have tested the version 1.0.1 in Windows XP and Red Hat Linux and version 1.0.2 in Windows XP. All the objects belonging to the same group as vector and tilde are located too high. Please, repaire to bug.

Best Regards

Kari SAntaoja


Crying or Very sad
Back to top
guest
Guest





PostPosted: Fri Mar 28, 2003 3:40 am    Post subject: Re: Arrows and other similar objects too high Reply with quote

Hi,
you can use widevec, widetilde, ... which seems to scale correctly:

widevec a
{widevec a}_1
.
.
.

Cheers - Andreas.
Back to top
Ed
Guest





PostPosted: Sat Apr 19, 2003 9:17 am    Post subject: Reply with quote

This bug has been correctecd in OOo1.1Beta, and all appears well now.
Back to top
chouchoups38
General User
General User


Joined: 20 May 2003
Posts: 20

PostPosted: Tue May 20, 2003 12:49 pm    Post subject: Reply with quote

i had have this problem and i correct it by coping a "smi641.dll like" from the before version in this last version but i don't found again wich file exactly ! Crying or Very sad
Back to top
View user's profile Send private message Yahoo Messenger
Guest
Guest





PostPosted: Thu Jun 05, 2003 1:35 am    Post subject: dll replacement works Reply with quote

Hi all, Very Happy Very Happy Very Happy

I also encountered this problem, and it was a real problem for me, let me tell you why:

I wrote my diploma thesis using SO5.2, and there were almost no problems at all - until I tried to produce a pdf file. The acrobat distiller refuses to embed the font "starmath.ttf", because the font vendor doesn't allow that. The other way to make a pdf file is to print the file using a ps driver and then make a pdf using gsview. This also doesn't work properly in most cases, the formulae look somehow awful in the files. The only driver that worked (sometimes) was the Minolta QMS 6110 driver for Win2000 (and only exactly this one, not the one for Win98!!!).

As OpenOffice produces the formulae otherwise (not using starmath.ttf) all my problems could be solved by using OpenOffice - if there were not the mentioned bug! Dear chouchoups38: Thank you very very much for the hint with the dll which has to be replaced. I'll explain now, how it works exactly: Download OO1.0.1 (this and only this version!) and download the file sm641mi.dll from http://www.dmaths.com/modules.php?name=Downloads&d_op=getit&lid=26. Replace the dll in the directory ...\program. Now everything works as it should do.

It is also true, that this bug has been corrected in Oo1.1Beta, but there are several other problems, e.g. I didn't manage to use the hyphenation. Thus I recommend to choose the above described way!

Thank you all!

Cheers
Thomas
Back to top
cyber_spooky
General User
General User


Joined: 06 Jun 2003
Posts: 8
Location: Belgium

PostPosted: Fri Jun 06, 2003 2:59 am    Post subject: Reply with quote

Guest, whoever you are you saved my life. I was making a document for school (very important) in OO 1.1 beta 2 due to the vector bug in releases 1.0.x. But beta 2 has a memoery leak when the filesize becomes too big and i coudn't open it anymore.
So i installed OO 1.0.1 with your fix for it and works like a charm after fixing some layout and images problems from going from 1.1 to 1.0.1.

Why they don't release an update to OO 1.0.3.1 to fix this math bug is beyond me...
Back to top
View user's profile Send private message
cyber_spooky
General User
General User


Joined: 06 Jun 2003
Posts: 8
Location: Belgium

PostPosted: Fri Jun 06, 2003 3:23 pm    Post subject: Reply with quote

Quick question tho. Is there any fixed sm641mi.dll for OO 1.0.3.1?? Cuz the one i found on the net only works for OO 1.0.1 Sad
Back to top
View user's profile Send private message
chouchoups38
General User
General User


Joined: 20 May 2003
Posts: 20

PostPosted: Fri Jun 13, 2003 12:52 am    Post subject: great ! Reply with quote

you found the file i've forgotten but now, it's a zip file and i can't connect anymore under windows ... that's too funny !

Laughing
Back to top
View user's profile Send private message Yahoo Messenger
maf
Guest





PostPosted: Mon Jun 07, 2004 1:39 am    Post subject: same problem in Oo 1.1.1 Reply with quote

Using package Oo.org 1.1.1 and Debian Linux.

I think this problem appeared after updating to package version 1.1.1-3 although I'm not sure.

Since there're no DLLs - does anyone know which files to change?
Back to top
Hal
Newbie
Newbie


Joined: 14 Oct 2004
Posts: 3

PostPosted: Thu Oct 14, 2004 3:14 am    Post subject: vector, hat, etc. distance problem in 1.1.1 Reply with quote

In 1.1.1 I had the same problem with the distance of the vector or hat symbol being to large. A change to the font replacement table cured it:
Tools->Options->OOo->Fonts
replace StarSymbol with OpenSymbol


Cheers, Hal
Back to top
View user's profile Send private message
snurb
General User
General User


Joined: 24 Apr 2004
Posts: 5

PostPosted: Wed Jan 26, 2005 10:07 am    Post subject: Reply with quote

Hi!
Do you also have an idea how to fix this: if I write
vec a^2
I get a vector above the a^2 and not as it is usual in math formulas above the a.
I know that there is the possibilty to wirte
{vec a}^2
to fix it, but I think that is not quite nice. I don't mind of one time somebody wants to habe the vector above the ^2. Do you?

If not, maybe you would like to vote for this issue:
http://www.openoffice.org/issues/show_bug.cgi?id=31774

yours,
Stefan
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Math All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group