OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

Gdb crashes for running openoffice 1.9.91

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> Setup and Troubleshooting
View previous topic :: View next topic  
Author Message
adipan
General User
General User


Joined: 19 Apr 2005
Posts: 48
Location: Noida, India

PostPosted: Fri May 06, 2005 4:32 am    Post subject: Gdb crashes for running openoffice 1.9.91 Reply with quote

This is the first time I am trying to debug my c++ addin in openoffice. I have trying to develop an c++ based addin for Writer in Open Office 1.9.91. The Writer addin worked well and Open Office is properly installed.

I have recently added some code and I need to single step (so I need gdb).
To do that, I compilled my add-in with MAKECMDGOALS=debug, which is similar to hardcoded -g in each file's compilation.

There after when I try to attach to running open office, with gdb
using gdb> attach <proc id>. gdb fails, and gets stopped hanging my openofffice app as well. Please find below the error:

adipan@localhost]$ ps -w
PID TTY TIME CMD
3777 pts/0 00:00:00 bash
3807 pts/0 00:00:00 setsdkenv_unix
3852 pts/0 00:00:00 bash
3878 pts/0 00:00:00 export
3879 pts/0 00:00:00 bash
4167 pts/0 00:00:00 soffice
4181 pts/0 00:00:01 soffice.bin
4187 pts/0 00:00:00 ps
[adipan@localhost]$ gdb
GNU gdb 5.3
Copyright 2002 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB. Type "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu".
(gdb) attach 4181
Attaching to process 4181
Reading symbols from /opt/openoffice.org1.9.91/program/soffice.bin...(no debugging symbols found)...done.
Reading symbols from /opt/openoffice.org1.9.91/program/libvcl680li.so...(no debugging symbols found)...done.
Loaded symbols for /opt/openoffice.org1.9.91/program/libvcl680li.so
Reading symbols from /opt/openoffice.org1.9.91/program/libsvl680li.so...(no debugging symbols found)...done.
Loaded symbols for /opt/openoffice.org1.9.91/program/libsvl680li.so
Reading symbols from /opt/openoffice.org1.9.91/program/libsvt680li.so...(no debugging symbols found)...done.
Loaded symbols for /opt/openoffice.org1.9.91/program/libsvt680li.so
Reading symbols from /opt/openoffice.org1.9.91/program/libutl680li.so...(no debugging symbols found)...done.
Loaded symbols for /opt/openoffice.org1.9.91/program/libutl680li.so
Reading symbols from /opt/openoffice.org1.9.91/program/libtl680li.so...(no debugging symbols found)...done.
Loaded symbols for /opt/openoffice.org1.9.91/program/libtl680li.so
Reading symbols from /opt/openoffice.org1.9.91/program/libcomphelp4gcc3.so...(no debugging symbols found)...done.
Loaded symbols for /opt/openoffice.org1.9.91/program/libcomphelp4gcc3.so
Reading symbols from /opt/openoffice.org1.9.91/program/libucbhelper3gcc3.so...(no debugging symbols found)...done.
Loaded symbols for /opt/openoffice.org1.9.91/program/libucbhelper3gcc3.so
Reading symbols from /opt/openoffice.org1.9.91/program/libvos3gcc3.so...(no debugging symbols found)...done.
Loaded symbols for /opt/openoffice.org1.9.91/program/libvos3gcc3.so
Reading symbols from /opt/openoffice.org1.9.91/program/libuno_cppuhelpergcc3.so.3...(no debugging symbols found)...done.
Loaded symbols for /opt/openoffice.org1.9.91/program/libuno_cppuhelpergcc3.so.3
Reading symbols from /opt/openoffice.org1.9.91/program/libuno_cppu.so.3...(no debugging symbols found)...done.
Loaded symbols for /opt/openoffice.org1.9.91/program/libuno_cppu.so.3
Reading symbols from /opt/openoffice.org1.9.91/program/libuno_sal.so.3...(no debugging symbols found)...done.
Loaded symbols for /opt/openoffice.org1.9.91/program/libuno_sal.so.3
Reading symbols from /opt/openoffice.org1.9.91/program/libtk680li.so...(no debugging symbols found)...done.
Loaded symbols for /opt/openoffice.org1.9.91/program/libtk680li.so
Reading symbols from /opt/openoffice.org1.9.91/program/libjvmfwk.so.3...(no debugging symbols found)...done.
Loaded symbols for /opt/openoffice.org1.9.91/program/libjvmfwk.so.3
Reading symbols from /usr/X11R6/lib/libXext.so.6...(no debugging symbols found)...done.
Loaded symbols for /usr/X11R6/lib/libXext.so.6
Reading symbols from /usr/X11R6/lib/libSM.so.6...(no debugging symbols found)...done.
Loaded symbols for /usr/X11R6/lib/libSM.so.6
Reading symbols from /usr/X11R6/lib/libICE.so.6...(no debugging symbols found)...done.
Loaded symbols for /usr/X11R6/lib/libICE.so.6
Reading symbols from /usr/X11R6/lib/libX11.so.6...(no debugging symbols found)...done.
Loaded symbols for /usr/X11R6/lib/libX11.so.6
Reading symbols from /lib/libdl.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib/libdl.so.2
Reading symbols from /lib/tls/libpthread.so.0...(no debugging symbols found)...done.
Loaded symbols for /lib/tls/libpthread.so.0
Reading symbols from /opt/openoffice.org1.9.91/program/libstlport_gcc.so...(no debugging symbols found)...done.
Loaded symbols for /opt/openoffice.org1.9.91/program/libstlport_gcc.so
Reading symbols from /opt/openoffice.org1.9.91/program/libstdc++.so.6...(no debugging symbols found)...done.
Loaded symbols for /opt/openoffice.org1.9.91/program/libstdc++.so.6
Reading symbols from /lib/tls/libm.so.6...(no debugging symbols found)...done.
Loaded symbols for /lib/tls/libm.so.6
Reading symbols from /opt/openoffice.org1.9.91/program/libgcc_s.so.1...(no debugging symbols found)...done.
Loaded symbols for /opt/openoffice.org1.9.91/program/libgcc_s.so.1
Reading symbols from /lib/tls/libc.so.6...(no debugging symbols found)...done.
Loaded symbols for /lib/tls/libc.so.6
Reading symbols from /opt/openoffice.org1.9.91/program/libsot680li.so...(no debugging symbols found)...done.
Loaded symbols for /opt/openoffice.org1.9.91/program/libsot680li.so
Reading symbols from /opt/openoffice.org1.9.91/program/libicuuc.so.26...(no debugging symbols found)...done.
Loaded symbols for /opt/openoffice.org1.9.91/program/libicuuc.so.26
Reading symbols from /opt/openoffice.org1.9.91/program/libicule.so.26...(no debugging symbols found)...done.
Loaded symbols for /opt/openoffice.org1.9.91/program/libicule.so.26
Reading symbols from /opt/openoffice.org1.9.91/program/libjvmaccessgcc3.so.3...(no debugging symbols found)...done.
Loaded symbols for /opt/openoffice.org1.9.91/program/libjvmaccessgcc3.so.3
Reading symbols from /usr/lib/libfreetype.so.6...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libfreetype.so.6
Reading symbols from /opt/openoffice.org1.9.91/program/libuno_salhelpergcc3.so.3...(no debugging symbols found)...done.
Loaded symbols for /opt/openoffice.org1.9.91/program/libuno_salhelpergcc3.so.3
Reading symbols from /opt/openoffice.org1.9.91/program/libbasegfx680li.so...(no debugging symbols found)...done.
Loaded symbols for /opt/openoffice.org1.9.91/program/libbasegfx680li.so
Reading symbols from /opt/openoffice.org1.9.91/program/libxml2.so.2...(no debugging symbols found)...done.
Loaded symbols for /opt/openoffice.org1.9.91/program/libxml2.so.2
Reading symbols from /lib/ld-linux.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib/ld-linux.so.2
Reading symbols from /opt/openoffice.org1.9.91/program/libicudata.so.26...(no debugging symbols found)...done.
Loaded symbols for /opt/openoffice.org1.9.91/program/libicudata.so.26
Reading symbols from /usr/lib/libz.so.1...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libz.so.1
Reading symbols from /opt/openoffice.org1.9.91/program/libvclplug_gtk680li.so...(no debugging symbols found)...done.
Loaded symbols for /opt/openoffice.org1.9.91/program/libvclplug_gtk680li.so
Reading symbols from /usr/lib/libgtk-x11-2.0.so.0...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libgtk-x11-2.0.so.0

[2]+ Stopped gdb
[adipan@localhost ]$


I am wondering how to find why gdb fails? Am I missing something?
_________________
Aditya Pandey
Back to top
View user's profile Send private message Yahoo Messenger
adipan
General User
General User


Joined: 19 Apr 2005
Posts: 48
Location: Noida, India

PostPosted: Fri Aug 12, 2005 11:10 pm    Post subject: [Solution] Reply with quote

http://www.oooforum.org/forum/viewtopic.phtml?t=19931&highlight=
_________________
Aditya Pandey
Back to top
View user's profile Send private message Yahoo Messenger
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> Setup and Troubleshooting All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group