OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

keeping non-spaced text together

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer
View previous topic :: View next topic  
Author Message
Doerr485
Newbie
Newbie


Joined: 19 Jun 2006
Posts: 3
Location: Maryland

PostPosted: Mon Jun 19, 2006 7:11 am    Post subject: keeping non-spaced text together Reply with quote

I have a text spacing problem similar to issue 64532, but is not solved so simply as with a non-breaking space (Ctrl-space). In my text, I am writing about something like "A(4000)" and the break occurs between the "A" and "(". I have been able to get the string back together with the Ctrl-space, but then I have a space there. Is there any way to highlight the whole string and give it some attribute such that it won't be split? Any other ideas?
Thanks in advance!
--Tom Doerr
Back to top
View user's profile Send private message
Robert Tucker
Moderator
Moderator


Joined: 16 Aug 2004
Posts: 3407
Location: Manchester UK

PostPosted: Mon Jun 19, 2006 7:22 am    Post subject: Reply with quote

I can't repeat your finding. If I type A(4000) at the end of a line and add more text before it the whole of A(4000) goes to the next line - I cannot get it to break between the A and the (4000).

If you say a non-breaking space works, maybe try a narrow no-break space U+202F or a zero-width non-breaking space U+FEFF.
Back to top
View user's profile Send private message
Doerr485
Newbie
Newbie


Joined: 19 Jun 2006
Posts: 3
Location: Maryland

PostPosted: Mon Jun 19, 2006 7:28 am    Post subject: Reply with quote

Perhaps it is my version of OO, then? I am using 1.1.4. I thought perhaps this could be because it is a paragraph within a table, but then I replicated the problem in a regular paragraph as well... Weird.
Back to top
View user's profile Send private message
jrkrideau
Super User
Super User


Joined: 08 Aug 2005
Posts: 6732
Location: Kingston ON Canada

PostPosted: Mon Jun 19, 2006 10:50 am    Post subject: Reply with quote

Doerr485 wrote:
Perhaps it is my version of OO, then? I am using 1.1.4. I thought perhaps this could be because it is a paragraph within a table, but then I replicated the problem in a regular paragraph as well... Weird.


Using 2.0.2 I agree with Roger. I cannot duplicate it. I have never used the 1.1.x series so cannot check it there.
_________________
jrkrideau
Kingston ON Canada
Currently using Windows 7 & OOo 3.4.0 and Ubuntu 12.04 & LibreOffice 3.5.2.2
Back to top
View user's profile Send private message
Doerr485
Newbie
Newbie


Joined: 19 Jun 2006
Posts: 3
Location: Maryland

PostPosted: Mon Jun 19, 2006 12:34 pm    Post subject: Reply with quote

A colleague using a 1.9beta version also could not replicate the problem. Apparently my problem was fixed between 1.1.4 and 1.9... Smile Unfortunately, when I installed 2.0.2 and tried to open my document, I couldn't. Perhaps my nearly-100-page document has too many bookmarks and cross-references to be updated..? Oh well, for the time being I'm going to leave well enough alone and get this Test Plan done!
Thanks all!
--Tom
Back to top
View user's profile Send private message
lengo
OOo Enthusiast
OOo Enthusiast


Joined: 17 Sep 2005
Posts: 120

PostPosted: Thu Jan 31, 2008 11:01 am    Post subject: Reply with quote

I have the following text in a page with 1.25" left/right margins:

The one exception to the syllabification rules above is that the mid-high vowel sequence /eu/ are members of different syllables

The line breaks between '/' and 'e', which is not good. I tried using a non-breaking space (shift+space bar) between '/' and 'e', but then adds space between them and it pulls 'sequence' with it to the following line. Is there any other way around this?
Back to top
View user's profile Send private message
jrkrideau
Super User
Super User


Joined: 08 Aug 2005
Posts: 6732
Location: Kingston ON Canada

PostPosted: Thu Jan 31, 2008 4:12 pm    Post subject: Reply with quote

lengo wrote:
I have the following text in a page with 1.25" left/right margins:

The one exception to the syllabification rules above is that the mid-high vowel sequence /eu/ are members of different syllables

The line breaks between '/' and 'e', which is not good. I tried using a non-breaking space (shift+space bar) between '/' and 'e', but then adds space between them and it pulls 'sequence' with it to the following line. Is there any other way around this?


I cannot reproduce the problem probably because your font and perhaps some other settings are different from mine.

Can you post an example of the problem for someone to take a look at?

Handy places to post a file:

media fire http://www.mediafire.com/
or
mytempdir.com http://www.mytempdir.com
_________________
jrkrideau
Kingston ON Canada
Currently using Windows 7 & OOo 3.4.0 and Ubuntu 12.04 & LibreOffice 3.5.2.2
Back to top
View user's profile Send private message
foxcole
Super User
Super User


Joined: 19 Jan 2006
Posts: 2771
Location: Minneapolis, Minnesota

PostPosted: Thu Jan 31, 2008 4:19 pm    Post subject: Reply with quote

I would encourage posting a new thread in cases like this. The original thread is from 2006 and a lot has changed since then.
_________________
Cheers!
---Fox

WinXP Pro SP2, OOo Portable 2.3.1, OOo local 2.4 RC4
New OpenOffice forum: http://user.services.openoffice.org/en/forum/
Manuals: http://documentation.openoffice.org/manuals/index.html
Back to top
View user's profile Send private message AIM Address Yahoo Messenger
lengo
OOo Enthusiast
OOo Enthusiast


Joined: 17 Sep 2005
Posts: 120

PostPosted: Thu Jan 31, 2008 4:29 pm    Post subject: Reply with quote

I figured since it was the same problem, reviving a thread with no apparent solution would help someone when they're searching--fewer 'rabbit trail' posts to wade through. Though "a lot has changed since [2006]", apparently this has not . . . Any ideas? Or do you really want me to start a new thread before you answer? Wink

@ jrkrideau: there's a file here.
Back to top
View user's profile Send private message
foxcole
Super User
Super User


Joined: 19 Jan 2006
Posts: 2771
Location: Minneapolis, Minnesota

PostPosted: Thu Jan 31, 2008 5:16 pm    Post subject: Reply with quote

lengo wrote:
I figured since it was the same problem, reviving a thread with no apparent solution would help someone when they're searching--fewer 'rabbit trail' posts to wade through. Though "a lot has changed since [2006]", apparently this has not . . .

I understand your reasoning, but, having read the original thread, I believed that you have a different situation. Not only are you working with different characters, but the solution to the original question was to upgrade to version 1.9. The original issue was thus closed and the solution is, of course, not applicable to your problem.

I wasn't insisting you start a new thread for this discussion, especially not since it already had a reply, but requesting a little more caution for future posts.

But back to the question... I wonder... if you exclude that string for hyphenation by one of the following methods, does it work and treat the slashes as part of the word?

    In Tools> Options> Language settings> Writing Aids, select or create a user-defined dictionary. In the Word box, type /eu/= and click New.

--OR--
    Select the text you want treated as a whole word, choose Format> Character and on the Font tab, tick the "None" checkbox.


Alternatively, there is a zero-width Unicode character, as mentioned in this thread:
Word breaks in Thai, Lao, and Khmer
_________________
Cheers!
---Fox

WinXP Pro SP2, OOo Portable 2.3.1, OOo local 2.4 RC4
New OpenOffice forum: http://user.services.openoffice.org/en/forum/
Manuals: http://documentation.openoffice.org/manuals/index.html
Back to top
View user's profile Send private message AIM Address Yahoo Messenger
jrkrideau
Super User
Super User


Joined: 08 Aug 2005
Posts: 6732
Location: Kingston ON Canada

PostPosted: Thu Jan 31, 2008 5:25 pm    Post subject: Reply with quote

lengo wrote:
I figured since it was the same problem, reviving a thread with no apparent solution would help someone when they're searching--fewer 'rabbit trail' posts to wade through. Though "a lot has changed since [2006]", apparently this has not . . . Any ideas? Or do you really want me to start a new thread before you answer? Wink

@ jrkrideau: there's a file here.


Nasty little thing isn't it. Sad

It's late here so I'll have to have a look at it tomorrow.
_________________
jrkrideau
Kingston ON Canada
Currently using Windows 7 & OOo 3.4.0 and Ubuntu 12.04 & LibreOffice 3.5.2.2
Back to top
View user's profile Send private message
lengo
OOo Enthusiast
OOo Enthusiast


Joined: 17 Sep 2005
Posts: 120

PostPosted: Thu Jan 31, 2008 6:24 pm    Post subject: Reply with quote

foxcole wrote:
    In Tools> Options> Language settings> Writing Aids, select or create a user-defined dictionary. In the Word box, type /eu/= and click New.

Thanks, foxcole; that looks like a reasonable work around. But I'll wait to see what jrkrideau can uncover as well.

And I'll think twice before resurrecting an old thread next time--warning taken. Smile
Back to top
View user's profile Send private message
jrkrideau
Super User
Super User


Joined: 08 Aug 2005
Posts: 6732
Location: Kingston ON Canada

PostPosted: Fri Feb 01, 2008 6:08 am    Post subject: Reply with quote

lengo wrote:
foxcole wrote:
    In Tools> Options> Language settings> Writing Aids, select or create a user-defined dictionary. In the Word box, type /eu/= and click New.

Thanks, foxcole; that looks like a reasonable work around. But I'll wait to see what jrkrideau can uncover as well.

And I'll think twice before resurrecting an old thread next time--warning taken. Smile


I think foxcole may have the best solution. I don't see anything else that might work.
_________________
jrkrideau
Kingston ON Canada
Currently using Windows 7 & OOo 3.4.0 and Ubuntu 12.04 & LibreOffice 3.5.2.2
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> OpenOffice.org Writer All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group