OpenOffice.org Forum at OOoForum.orgThe OpenOffice.org Forum
 
 [Home]   [FAQ]   [Search]   [Memberlist]   [Usergroups]   [Register
 [Profile]   [Log in to check your private messages]   [Log in

starting problem

 
Post new topic   Reply to topic    OOoForum.org Forum Index -> Setup and Troubleshooting
View previous topic :: View next topic  
Author Message
bingoxXx
General User
General User


Joined: 28 Feb 2006
Posts: 6
Location: INDIA

PostPosted: Tue Feb 28, 2006 11:32 am    Post subject: starting problem Reply with quote

$ oocalc2
/usr/lib/openoffice/program/javaldx: error while loading shared libraries: /usr/lib/openoffice/program/libuno_sal.so.3: file too short
/usr/lib/openoffice/program/soffice.bin: error while loading shared libraries: /usr/lib/openoffice/program/libucbhelper3gcc3.so: file too short
how to handle this error? Sad
Back to top
View user's profile Send private message Send e-mail Yahoo Messenger
hol.sten
Super User
Super User


Joined: 14 Nov 2004
Posts: 3533
Location: Hamburg, Germany

PostPosted: Tue Feb 28, 2006 11:36 am    Post subject: Re: starting problem Reply with quote

bingoxXx wrote:
$ oocalc2
/usr/lib/openoffice/program/javaldx: error while loading shared libraries: /usr/lib/openoffice/program/libuno_sal.so.3: file too short
/usr/lib/openoffice/program/soffice.bin: error while loading shared libraries: /usr/lib/openoffice/program/libucbhelper3gcc3.so: file too short
how to handle this error? Sad

What operating system do you use? Besides it is a Unix or Linux system.
Where did you get your OOo version from?
Is your OOo version a stable OOo 2.0.0 or 2.0.1?

With kind regards
hol.sten
Back to top
View user's profile Send private message
bingoxXx
General User
General User


Joined: 28 Feb 2006
Posts: 6
Location: INDIA

PostPosted: Tue Feb 28, 2006 11:42 am    Post subject: Reply with quote

My system is Gentoo-2.6.13-r6 and the OOo version is 2.0.1. I got it from gentoo emerge thing during my OOo update.
Back to top
View user's profile Send private message Send e-mail Yahoo Messenger
hol.sten
Super User
Super User


Joined: 14 Nov 2004
Posts: 3533
Location: Hamburg, Germany

PostPosted: Tue Feb 28, 2006 11:47 am    Post subject: Reply with quote

bingoxXx wrote:
My system is Gentoo-2.6.13-r6 and the OOo version is 2.0.1. I got it from gentoo emerge thing during my OOo update.

That was hard to guess from your first post. I have virtually no knowledge about Gentoo. Perhaps you can rollback you OOo update.

WIth kind regards
hol.sten
Back to top
View user's profile Send private message
bingoxXx
General User
General User


Joined: 28 Feb 2006
Posts: 6
Location: INDIA

PostPosted: Tue Feb 28, 2006 11:54 am    Post subject: Reply with quote

can't i just do something with those buggy libraries...replace them with a new file or something like that??
Back to top
View user's profile Send private message Send e-mail Yahoo Messenger
noranthon
Super User
Super User


Joined: 07 Jul 2005
Posts: 3318

PostPosted: Tue Feb 28, 2006 5:50 pm    Post subject: Reply with quote

Did you get the install files from Gentoo or Open Office? If the download from OO is sound, you could try reinstalling. Check the Setup Guide. If you want to get the individual files, try a web search of the repository.
Back to top
View user's profile Send private message
bingoxXx
General User
General User


Joined: 28 Feb 2006
Posts: 6
Location: INDIA

PostPosted: Tue Feb 28, 2006 7:00 pm    Post subject: Reply with quote

I got it from gentoo portage update.Can I just copy paste a lib file without compiling it?
Also where can i find those two specific lib files?
Back to top
View user's profile Send private message Send e-mail Yahoo Messenger
noranthon
Super User
Super User


Joined: 07 Jul 2005
Posts: 3318

PostPosted: Tue Feb 28, 2006 7:35 pm    Post subject: Reply with quote

If you've got a Gentoo installation, you should go to Gentoo for the fix. I believe you should not use the OO files to patch a Gentoo programme.
Back to top
View user's profile Send private message
bingoxXx
General User
General User


Joined: 28 Feb 2006
Posts: 6
Location: INDIA

PostPosted: Tue Feb 28, 2006 7:43 pm    Post subject: Reply with quote

k thanks for ur suggestions...... actually I now emerged openoffice-bin from gentoo portage and its tunning without any glitch( but now i have OOo2.0 instead)....... are there any major differences between OOo 2.0.1 and OOo2.0
Back to top
View user's profile Send private message Send e-mail Yahoo Messenger
hol.sten
Super User
Super User


Joined: 14 Nov 2004
Posts: 3533
Location: Hamburg, Germany

PostPosted: Wed Mar 01, 2006 10:18 am    Post subject: Reply with quote

bingoxXx wrote:
are there any major differences between OOo 2.0.1 and OOo2.0

No, there are "only" some bug fixes. You'll find more here http://development.openoffice.org/releases/2.0.1.html.

With kind regards
hol.sten
Back to top
View user's profile Send private message
bingoxXx
General User
General User


Joined: 28 Feb 2006
Posts: 6
Location: INDIA

PostPosted: Wed Mar 01, 2006 11:23 am    Post subject: Reply with quote

Thanx every body for their help. Smile
Back to top
View user's profile Send private message Send e-mail Yahoo Messenger
Display posts from previous:   
Post new topic   Reply to topic    OOoForum.org Forum Index -> Setup and Troubleshooting All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group